summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-12 18:08:01 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-12 18:08:01 +0000
commit971012a6ac0ee5b2ed631ca174a20ce502795200 (patch)
treeeb96841ce0348f7ffa58fc62fe12c3c38c06036b /app-accessibility
parentVersion bump for Gnome 2.32 (diff)
downloadgentoo-2-971012a6ac0ee5b2ed631ca174a20ce502795200.tar.gz
gentoo-2-971012a6ac0ee5b2ed631ca174a20ce502795200.tar.bz2
gentoo-2-971012a6ac0ee5b2ed631ca174a20ce502795200.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/accerciser/ChangeLog9
-rw-r--r--app-accessibility/accerciser/accerciser-1.12.0.ebuild61
2 files changed, 69 insertions, 1 deletions
diff --git a/app-accessibility/accerciser/ChangeLog b/app-accessibility/accerciser/ChangeLog
index e7937bcdb68c..ba019859bf02 100644
--- a/app-accessibility/accerciser/ChangeLog
+++ b/app-accessibility/accerciser/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/accerciser
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/ChangeLog,v 1.14 2010/10/08 21:08:38 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/ChangeLog,v 1.15 2010/10/12 18:08:01 pacho Exp $
+
+*accerciser-1.12.0 (12 Oct 2010)
+
+ 12 Oct 2010; Pacho Ramos <pacho@gentoo.org> +accerciser-1.12.0.ebuild:
+ Version bump for Gnome 2.32: A fix for AT-SPI2 issues and updated
+ translations. This also has improved python support (bug #308259 by
+ Arfrever Frehtes Taifersar Arahesis).
08 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
-accerciser-1.6.1.ebuild, -accerciser-1.8.0.ebuild:
diff --git a/app-accessibility/accerciser/accerciser-1.12.0.ebuild b/app-accessibility/accerciser/accerciser-1.12.0.ebuild
new file mode 100644
index 000000000000..6ed1ea3a27e6
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-1.12.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/accerciser-1.12.0.ebuild,v 1.1 2010/10/12 18:08:01 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+
+inherit gnome2 python
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="http://live.gnome.org/Accerciser"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/ipython
+ dev-python/pygtk
+ dev-python/pygobject
+ dev-python/pycairo
+ dev-python/libgnome-python
+ dev-python/libwnck-python
+ dev-python/gtksourceview-python
+ dev-python/gconf-python
+ dev-python/librsvg-python
+ >=gnome-extra/at-spi-1.7
+ >=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.12"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --without-pyreqs"
+ DOCS="AUTHORS COPYING ChangeLog NEWS README"
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ python_convert_shebangs -r 2 .
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize "${PN}"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "${PN}"
+}