summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-11-12 19:19:21 +0000
committerFabian Groffen <grobian@gentoo.org>2012-11-12 19:19:21 +0000
commit9459297c84e9e16fdc90eff2be01eca8f5a1ed68 (patch)
tree44aba02dbc6053f8ce3aaad119bf7b4dc698aff3 /app-admin/chrpath
parentx86 stable, see 426496 (diff)
downloadgentoo-2-9459297c84e9e16fdc90eff2be01eca8f5a1ed68.tar.gz
gentoo-2-9459297c84e9e16fdc90eff2be01eca8f5a1ed68.tar.bz2
gentoo-2-9459297c84e9e16fdc90eff2be01eca8f5a1ed68.zip
Fix broken dlopen -ldl check, marked ~x64-freebsd
(Portage version: 2.2.01.21313-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'app-admin/chrpath')
-rw-r--r--app-admin/chrpath/ChangeLog7
-rw-r--r--app-admin/chrpath/chrpath-0.13-r2.ebuild4
-rw-r--r--app-admin/chrpath/files/chrpath-0.13-multilib.patch5
3 files changed, 10 insertions, 6 deletions
diff --git a/app-admin/chrpath/ChangeLog b/app-admin/chrpath/ChangeLog
index bcd29332549f..f9d5ffa8012d 100644
--- a/app-admin/chrpath/ChangeLog
+++ b/app-admin/chrpath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/chrpath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/ChangeLog,v 1.24 2012/01/09 19:51:17 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/ChangeLog,v 1.25 2012/11/12 19:19:21 grobian Exp $
+
+ 12 Nov 2012; Fabian Groffen <grobian@gentoo.org> chrpath-0.13-r2.ebuild,
+ files/chrpath-0.13-multilib.patch:
+ Fix broken dlopen -ldl check, marked ~x64-freebsd
09 Jan 2012; Brent Baude <ranger@gentoo.org> chrpath-0.13-r2.ebuild:
Marking chrpath-0.13-r2 ppc for bug 391239
@@ -102,4 +106,3 @@
05 Feb 2005; Tavis Ormandy <taviso@gentoo.org> +metadata.xml:
initial import
-
diff --git a/app-admin/chrpath/chrpath-0.13-r2.ebuild b/app-admin/chrpath/chrpath-0.13-r2.ebuild
index 1d2293ead8d7..57ea5a84aaab 100644
--- a/app-admin/chrpath/chrpath-0.13-r2.ebuild
+++ b/app-admin/chrpath/chrpath-0.13-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/chrpath-0.13-r2.ebuild,v 1.10 2012/01/09 19:51:17 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/chrpath-0.13-r2.ebuild,v 1.11 2012/11/12 19:19:21 grobian Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://ftp.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 arm ppc x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
src_prepare() {
diff --git a/app-admin/chrpath/files/chrpath-0.13-multilib.patch b/app-admin/chrpath/files/chrpath-0.13-multilib.patch
index a0d54666ffe0..e7db0a124053 100644
--- a/app-admin/chrpath/files/chrpath-0.13-multilib.patch
+++ b/app-admin/chrpath/files/chrpath-0.13-multilib.patch
@@ -37,7 +37,7 @@ Index: chrpath-0.13/configure.ac
dnl Checks for libraries.
-@@ -26,11 +27,18 @@ AC_CHECK_HEADERS([getopt.h elf.h fcntl.h
+@@ -26,11 +27,19 @@ AC_CHECK_HEADERS([getopt.h elf.h fcntl.h
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_C_BIGENDIAN
@@ -50,7 +50,8 @@ Index: chrpath-0.13/configure.ac
+LDLIBS=
+save_LIBS="$LIBS"
+LIBS=
-+AC_SEARCH_LIBS([dlopen], [dl], [LDLIBS="-ldl"])
++AC_SEARCH_LIBS([dlopen], [dl])
++LDLIBS=${LIBS}
+LIBS="${save_LIBS}"
+AC_SUBST([LDLIBS])
+