summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2011-10-25 17:28:42 +0000
committerDaniel Pielmeier <billie@gentoo.org>2011-10-25 17:28:42 +0000
commit8caa1d74194eabc5b9545b6f98acf65dbfb06149 (patch)
tree9a64d1b89661f3a5dda820adb7aa2a479b94d59a /app-admin/conky
parentFix bad BIOS symlink. (diff)
downloadgentoo-2-8caa1d74194eabc5b9545b6f98acf65dbfb06149.tar.gz
gentoo-2-8caa1d74194eabc5b9545b6f98acf65dbfb06149.tar.bz2
gentoo-2-8caa1d74194eabc5b9545b6f98acf65dbfb06149.zip
Revison bump to fix bug #384505. Thanks to Renato Alves for the report and Cesar Garcia for the fix.
(Portage version: 2.1.10.31/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog9
-rw-r--r--app-admin/conky/conky-1.8.1-r3.ebuild (renamed from app-admin/conky/conky-1.8.1-r2.ebuild)2
-rw-r--r--app-admin/conky/files/conky-1.8.1-maxinterfaces.patch38
3 files changed, 42 insertions, 7 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index 03c5d27a964e..24a1571c6306 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.166 2011/10/13 18:45:04 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.167 2011/10/25 17:28:41 billie Exp $
+
+*conky-1.8.1-r3 (25 Oct 2011)
+
+ 25 Oct 2011; Daniel Pielmeier <billie@gentoo.org> -conky-1.8.1-r2.ebuild,
+ +conky-1.8.1-r3.ebuild, files/conky-1.8.1-maxinterfaces.patch:
+ Revison bump to fix bug #384505. Thanks to Renato Alves for the report and
+ Cesar Garcia for the fix.
13 Oct 2011; Daniel Pielmeier <billie@gentoo.org> -conky-1.8.0-r1.ebuild,
-files/conky-1.8.0-audacious-2.3.patch, -files/conky-1.8.0-ncurses.patch:
diff --git a/app-admin/conky/conky-1.8.1-r2.ebuild b/app-admin/conky/conky-1.8.1-r3.ebuild
index a2c21f88e441..6a5d0c75c7d9 100644
--- a/app-admin/conky/conky-1.8.1-r2.ebuild
+++ b/app-admin/conky/conky-1.8.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.1-r2.ebuild,v 1.8 2011/08/06 23:14:18 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.1-r3.ebuild,v 1.1 2011/10/25 17:28:41 billie Exp $
EAPI=2
diff --git a/app-admin/conky/files/conky-1.8.1-maxinterfaces.patch b/app-admin/conky/files/conky-1.8.1-maxinterfaces.patch
index 41bb9584ab12..97c58460114f 100644
--- a/app-admin/conky/files/conky-1.8.1-maxinterfaces.patch
+++ b/app-admin/conky/files/conky-1.8.1-maxinterfaces.patch
@@ -1,8 +1,20 @@
-Index: conky-1.8.1/configure.ac
-===================================================================
---- conky-1.8.1.orig/configure.ac
-+++ conky-1.8.1/configure.ac
-@@ -790,7 +790,7 @@ AC_DEFINE(CONFIG_FILE, "$HOME/.conkyrc",
+From f6aac5981e70118dc28b3c7a1fe6065955fe3dcb Mon Sep 17 00:00:00 2001
+From: Pavel Labath <pavelo@centrum.sk>
+Date: Tue, 25 Oct 2011 18:53:09 +0200
+Subject: [PATCH] Increase MAX_NET_INTERFACES to 64
+
+also change a magic constant in net_stat.h to reflect the fact that it depends on
+MAX_NET_INTERFACES. For more info, see sf.net #2872682 and gentoo bug #384505
+---
+ configure.ac.in | 2 +-
+ src/net_stat.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac.in b/configure.ac.in
+index 0f00237..d52d998 100644
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -802,7 +802,7 @@ AC_DEFINE(CONFIG_FILE, "$HOME/.conkyrc", [Configfile of the user])
AC_DEFINE(MAX_SPECIALS_DEFAULT, 512, [Default maximum number of special things, e.g. fonts, offsets, aligns, etc.])
AC_DEFINE(MAX_USER_TEXT_DEFAULT, 16384, [Default maximum size of config TEXT buffer, i.e. below TEXT line.])
AC_DEFINE(DEFAULT_TEXT_BUFFER_SIZE, 256, [Default size used for temporary, static text buffers])
@@ -11,3 +23,19 @@ Index: conky-1.8.1/configure.ac
dnl
dnl Some functions
+diff --git a/src/net_stat.h b/src/net_stat.h
+index 463e7db..6f5533c 100644
+--- a/src/net_stat.h
++++ b/src/net_stat.h
+@@ -41,7 +41,7 @@ struct net_stat {
+ double recv_speed, trans_speed;
+ struct sockaddr addr;
+ #if defined(__linux__)
+- char addrs[273];
++ char addrs[17 * MAX_NET_INTERFACES + 1];
+ #endif /* __linux__ */
+ double net_rec[15], net_trans[15];
+ // wireless extensions
+--
+1.7.0.4
+