summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-05-16 11:23:39 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-05-16 11:23:39 +0000
commitcf1463dc5efcba43f4164515a4892daf0bf9278c (patch)
treeea1f81570e487cd5aafdb494c379b924e729080c /app-admin/conky
parentassumed maintainership - added <longdescription> added working configuration ... (diff)
downloadgentoo-2-cf1463dc5efcba43f4164515a4892daf0bf9278c.tar.gz
gentoo-2-cf1463dc5efcba43f4164515a4892daf0bf9278c.tar.bz2
gentoo-2-cf1463dc5efcba43f4164515a4892daf0bf9278c.zip
version bump thanks to Brenden in bug #133439
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog7
-rw-r--r--app-admin/conky/conky-1.4.2.ebuild104
-rw-r--r--app-admin/conky/files/digest-conky-1.3.4-r22
-rw-r--r--app-admin/conky/files/digest-conky-1.3.5-r12
-rw-r--r--app-admin/conky/files/digest-conky-1.4.23
5 files changed, 117 insertions, 1 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index 4771e00967d3..cd39edf35129 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.28 2006/04/12 16:43:24 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.29 2006/05/16 11:23:39 dragonheart Exp $
+
+*conky-1.4.2 (16 May 2006)
+
+ 16 May 2006; Daniel Black <dragonheart@gentoo.org> +conky-1.4.2.ebuild:
+ version bump thanks to Brenden in bug #133439
12 Apr 2006; Thomas Cort <tcort@gentoo.org> conky-1.4.1.ebuild:
Added ~alpha keyword wrt Bug #122637.
diff --git a/app-admin/conky/conky-1.4.2.ebuild b/app-admin/conky/conky-1.4.2.ebuild
new file mode 100644
index 000000000000..3000ae4ad1ab
--- /dev/null
+++ b/app-admin/conky/conky-1.4.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.4.2.ebuild,v 1.1 2006/05/16 11:23:39 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
+HOMEPAGE="http://conky.sf.net"
+SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="truetype X ipv6 bmpx bmp xmms infopipe audacious"
+
+DEPEND_COMMON="
+ virtual/libc
+ X? (
+ || ( ( x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libXrender
+ x11-libs/libXft
+ )
+ virtual/x11
+ )
+ truetype? ( >=media-libs/freetype-2 )
+ bmpx? ( media-sound/bmpx
+ >=sys-apps/dbus-0.35
+ )
+ bmp? ( media-sound/beep-media-player )
+ audacious? ( media-sound/audacious )
+ infopipe? ( media-plugins/xmms-infopipe )
+ xmms? ( media-sound/xmms )
+ )"
+
+RDEPEND="${DEPEND_COMMON}"
+
+DEPEND="
+ ${DEPEND_COMMON}
+ X? (
+ || ( ( x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/xproto
+ )
+ virtual/x11
+ )
+ )
+ sys-apps/grep
+ sys-apps/sed"
+
+src_compile() {
+ local mymake
+ if useq ipv6 ; then
+ ewarn
+ ewarn "You have the ipv6 USE flag enabled. Please note that"
+ ewarn "using the ipv6 USE flag with Conky disables the port"
+ ewarn "monitor."
+ ewarn
+ epause
+ else
+ mymake="MPD_NO_IPV6=noipv6"
+ fi
+ local myconf
+ myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime \
+ --enable-mpd --enable-mldonkey"
+ econf \
+ ${myconf} \
+ $(use_enable truetype xft) \
+ $(use_enable X x11) \
+ $(use_enable bmpx) \
+ $(use_enable bmp) \
+ $(use_enable xmms) \
+ $(use_enable audacious) \
+ $(use_enable infopipe) \
+ $(use_enable !ipv6 portmon) || die "econf failed"
+ emake ${mymake} || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "make install failed"
+ dodoc ChangeLog AUTHORS README doc/conkyrc.sample doc/variables.html
+ dodoc doc/docs.html doc/config_settings.html
+}
+
+pkg_postinst() {
+ einfo 'Default configuration file is "~/.conkyrc"'
+ einfo "you can find a sample configuration file in"
+ einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
+ einfo
+ einfo "For more info on Conky's new features,"
+ einfo "please look at the README and ChangeLog:"
+ einfo "/usr/share/doc/${PF}/README.gz"
+ einfo "/usr/share/doc/${PF}/ChangeLog.gz"
+ einfo "There are also pretty html docs available"
+ einfo "on Conky's site or in /usr/share/doc/${PF}"
+ einfo
+ einfo "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
+ einfo
+ einfo "Check out app-vim/conky-syntax for conkyrc"
+ einfo "syntax highlighting in Vim"
+ einfo
+}
diff --git a/app-admin/conky/files/digest-conky-1.3.4-r2 b/app-admin/conky/files/digest-conky-1.3.4-r2
index 3d1c4064a29c..b9c3e88e7462 100644
--- a/app-admin/conky/files/digest-conky-1.3.4-r2
+++ b/app-admin/conky/files/digest-conky-1.3.4-r2
@@ -1 +1,3 @@
MD5 91f7d4ce29a6bc2d785f13224ea4aaac conky-1.3.4.tar.bz2 332871
+RMD160 13f61eaada0171f5c60010941cbed3b030ff99b8 conky-1.3.4.tar.bz2 332871
+SHA256 049e490936769d3b4ce7c2d9a240dc61a31aa065ec0ccd8e4ab0dcd35cdca99e conky-1.3.4.tar.bz2 332871
diff --git a/app-admin/conky/files/digest-conky-1.3.5-r1 b/app-admin/conky/files/digest-conky-1.3.5-r1
index 4c00f75d609b..d3d362320e65 100644
--- a/app-admin/conky/files/digest-conky-1.3.5-r1
+++ b/app-admin/conky/files/digest-conky-1.3.5-r1
@@ -1 +1,3 @@
MD5 e93e0f930dc2d8adfff6dec1e8db301b conky-1.3.5.tar.bz2 339478
+RMD160 d3054cfeb896c16f753830e023ab5e0896de1040 conky-1.3.5.tar.bz2 339478
+SHA256 5e7ac1fb87073bef4565066920e98923a04207cf7519a4552de99f19d027a6e5 conky-1.3.5.tar.bz2 339478
diff --git a/app-admin/conky/files/digest-conky-1.4.2 b/app-admin/conky/files/digest-conky-1.4.2
new file mode 100644
index 000000000000..b059f021302b
--- /dev/null
+++ b/app-admin/conky/files/digest-conky-1.4.2
@@ -0,0 +1,3 @@
+MD5 050a53bdb359a96421ef3ddf761f143c conky-1.4.2.tar.bz2 400574
+RMD160 9622c9e5115dc5bfb6995424cfc66d3a6f90002e conky-1.4.2.tar.bz2 400574
+SHA256 e792a1ea4f865225e6f9d1e4cafd405745390a09d48d4a8936d4b0556e6e32b2 conky-1.4.2.tar.bz2 400574