summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-09-26 18:49:25 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-09-26 18:49:25 +0000
commit1a66e6d533c4eb8991d2d04ac7e07965b44e4242 (patch)
tree20ed048e77faa70067dc15c57ecb63567ffc69e6 /app-admin/ec2-api-tools
parentFix bug #281895 (install manual pages). Also install the nvidia-smi tool and... (diff)
downloadgentoo-2-1a66e6d533c4eb8991d2d04ac7e07965b44e4242.tar.gz
gentoo-2-1a66e6d533c4eb8991d2d04ac7e07965b44e4242.tar.bz2
gentoo-2-1a66e6d533c4eb8991d2d04ac7e07965b44e4242.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-admin/ec2-api-tools')
-rw-r--r--app-admin/ec2-api-tools/ChangeLog8
-rw-r--r--app-admin/ec2-api-tools/ec2-api-tools-1.3.42584.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/app-admin/ec2-api-tools/ChangeLog b/app-admin/ec2-api-tools/ChangeLog
index 657131f82ec0..719bb9197837 100644
--- a/app-admin/ec2-api-tools/ChangeLog
+++ b/app-admin/ec2-api-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/ec2-api-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.1 2009/06/02 22:17:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.2 2009/09/26 18:49:25 caleb Exp $
+
+*ec2-api-tools-1.3.42584 (26 Sep 2009)
+
+ 26 Sep 2009; Caleb Tennis <caleb@gentoo.org>
+ +ec2-api-tools-1.3.42584.ebuild:
+ Version bump
*ec2-api-tools-1.3.36506 (02 Jun 2009)
diff --git a/app-admin/ec2-api-tools/ec2-api-tools-1.3.42584.ebuild b/app-admin/ec2-api-tools/ec2-api-tools-1.3.42584.ebuild
new file mode 100644
index 000000000000..6614a9b25b6f
--- /dev/null
+++ b/app-admin/ec2-api-tools/ec2-api-tools-1.3.42584.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ec2-api-tools-1.3.42584.ebuild,v 1.1 2009/09/26 18:49:25 caleb Exp $
+
+inherit versionator
+
+EC2_VERSION=$(get_version_component_range 1-2)
+EC2_PATCHLEVEL=$(get_version_component_range 3)
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service."
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=351&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}.zip"
+
+S=${WORKDIR}/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}"
+ find . -name *.cmd -exec rm {} \;
+}
+
+src_install() {
+ dodir /opt/${P}
+ insinto /opt/${P}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${P}/bin
+ doexe "${S}"/bin/*
+ insinto /usr/bin
+ for exe in "${S}"/bin/*; do
+ target="$(basename ${exe})"
+ base="$(basename ${exe})"
+ ln -s /opt/${P}/bin/${target} "${D}"/usr/bin/${base}
+ done
+
+ dodir /etc/env.d
+ echo "EC2_HOME=/opt/${P}" > ${D}/etc/env.d/99ec2-api-tools
+
+ dodoc THIRDPARTYLICENSE.TXT
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog ""
+ elog ""
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full paths to your key and certificate."
+ elog " "
+ elog " export EC2_PRIVATE_KEY=/path/to/pk-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+ elog " export EC2_CERT=/path/to/cert-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+}