summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-09-27 10:59:44 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-09-27 10:59:44 +0000
commitf2943d9924abc0114fdd1fa3400995452e36fe3b (patch)
tree00138bee7b7ac7d2db76f18256c324c8c2cdf30b /app-admin/equo/equo-144.ebuild
parentversion bump (diff)
downloadgentoo-2-f2943d9924abc0114fdd1fa3400995452e36fe3b.tar.gz
gentoo-2-f2943d9924abc0114fdd1fa3400995452e36fe3b.tar.bz2
gentoo-2-f2943d9924abc0114fdd1fa3400995452e36fe3b.zip
version bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/equo/equo-144.ebuild')
-rw-r--r--app-admin/equo/equo-144.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/equo/equo-144.ebuild b/app-admin/equo/equo-144.ebuild
new file mode 100644
index 000000000000..37b8325737bc
--- /dev/null
+++ b/app-admin/equo/equo-144.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-144.ebuild,v 1.1 2012/09/27 10:59:44 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/rigo-daemon"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}