summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-11-23 21:51:42 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-11-23 21:51:42 +0000
commit2478ca13b8b8667afed73aff5b310a8ffc0d5a91 (patch)
tree7956f06a3125682ddd0340b8cab3bcda140309d6 /app-admin/equo
parentversion bump (diff)
downloadgentoo-2-2478ca13b8b8667afed73aff5b310a8ffc0d5a91.tar.gz
gentoo-2-2478ca13b8b8667afed73aff5b310a8ffc0d5a91.tar.bz2
gentoo-2-2478ca13b8b8667afed73aff5b310a8ffc0d5a91.zip
version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-1.0_rc77.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index d8c8790c6ff0..ccb7602df2e3 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.15 2011/11/13 09:26:47 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.16 2011/11/23 21:51:42 lxnay Exp $
+
+*equo-1.0_rc77 (23 Nov 2011)
+
+ 23 Nov 2011; Fabio Erculiani <lxnay@gentoo.org> +equo-1.0_rc77.ebuild:
+ version bump
*equo-1.0_rc76 (13 Nov 2011)
diff --git a/app-admin/equo/equo-1.0_rc77.ebuild b/app-admin/equo/equo-1.0_rc77.ebuild
new file mode 100644
index 000000000000..bc4716d33faf
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc77.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc77.ebuild,v 1.1 2011/11/23 21:51:42 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}