summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-07-08 18:13:13 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-07-08 18:13:13 +0000
commitc67049dd0ca283b0ee6fe4786c775bdbcffc3750 (patch)
tree37b7a5be785f6c8e6b057e231a0ce4ce778b7f62 /app-admin/haskell-updater
parentsys-kernel/genkernel: 3.4.24_p2 (diff)
downloadgentoo-2-c67049dd0ca283b0ee6fe4786c775bdbcffc3750.tar.gz
gentoo-2-c67049dd0ca283b0ee6fe4786c775bdbcffc3750.tar.bz2
gentoo-2-c67049dd0ca283b0ee6fe4786c775bdbcffc3750.zip
Version bump. With new '--list-only' and '--quiet' options requested by Martin von Gagern in bug #407301
(Portage version: 2.2.0_alpha116_p2/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/haskell-updater')
-rw-r--r--app-admin/haskell-updater/ChangeLog10
-rw-r--r--app-admin/haskell-updater/files/haskell-updater-1.2.0.5-ghc-7.5.patch20
-rw-r--r--app-admin/haskell-updater/haskell-updater-1.2.0.6.ebuild50
3 files changed, 78 insertions, 2 deletions
diff --git a/app-admin/haskell-updater/ChangeLog b/app-admin/haskell-updater/ChangeLog
index b89e58be3dd3..699bc84f9668 100644
--- a/app-admin/haskell-updater/ChangeLog
+++ b/app-admin/haskell-updater/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/haskell-updater
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/ChangeLog,v 1.29 2012/04/09 18:32:24 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/ChangeLog,v 1.30 2012/07/08 18:13:13 slyfox Exp $
+
+*haskell-updater-1.2.0.6 (08 Jul 2012)
+
+ 08 Jul 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/haskell-updater-1.2.0.5-ghc-7.5.patch, +haskell-updater-1.2.0.6.ebuild:
+ Version bump. With new '--list-only' and '--quiet' options requested by Martin
+ von Gagern in bug #407301
*haskell-updater-1.2.0.5-r1 (09 Apr 2012)
@@ -141,4 +148,3 @@
22 Jul 2009; Lennart Kolmodin <kolmodin@gentoo.org> +metadata.xml,
+haskell-updater-0.9.0.0-r2.ebuild:
Initial import.
-
diff --git a/app-admin/haskell-updater/files/haskell-updater-1.2.0.5-ghc-7.5.patch b/app-admin/haskell-updater/files/haskell-updater-1.2.0.5-ghc-7.5.patch
new file mode 100644
index 000000000000..adc7e5c72f78
--- /dev/null
+++ b/app-admin/haskell-updater/files/haskell-updater-1.2.0.5-ghc-7.5.patch
@@ -0,0 +1,20 @@
+--- haskell-updater-1.2.0.5-orig/Distribution/Gentoo/PkgManager.hs 2012-02-12 07:08:49.000000000 +1100
++++ haskell-updater-1.2.0.5/Distribution/Gentoo/PkgManager.hs 2012-06-29 22:06:38.858341358 +1000
+@@ -26,7 +26,7 @@
+ import Data.Maybe(mapMaybe, fromMaybe)
+ import qualified Data.Map as M
+ import Data.Map(Map)
+-import System.IO.Error(try)
++import Control.Exception(try, SomeException)
+ import System.Environment(getEnv)
+
+ -- -----------------------------------------------------------------------------
+@@ -48,7 +48,7 @@
+ -- "portage". Note that even if that environment variable is
+ -- defined, if it is unknown then it won't be used.
+ defaultPM :: IO PkgManager
+-defaultPM = do eDPM <- try $ getEnv "PACKAGE_MANAGER"
++defaultPM = do eDPM <- (try $ getEnv "PACKAGE_MANAGER") :: IO (Either SomeException String)
+ let dPM = either (const defaultPMName) id eDPM
+ mPM = dPM `M.lookup` pmNameMap
+ return $ fromMaybe knownDef mPM
diff --git a/app-admin/haskell-updater/haskell-updater-1.2.0.6.ebuild b/app-admin/haskell-updater/haskell-updater-1.2.0.6.ebuild
new file mode 100644
index 000000000000..abcb378901b1
--- /dev/null
+++ b/app-admin/haskell-updater/haskell-updater-1.2.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/haskell-updater-1.2.0.6.ebuild,v 1.1 2012/07/08 18:13:13 slyfox Exp $
+
+EAPI=4
+
+CABAL_FEATURES="bin nocabaldep"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
+HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris" # Add keywords as those archs have a binpkg
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.12.1"
+
+# Need a lower version for portage to get --keep-going
+RDEPEND="|| ( >=sys-apps/portage-2.1.6
+ sys-apps/pkgcore
+ sys-apps/paludis )"
+
+src_prepare() {
+ if use prefix; then
+ sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \
+ "${S}/Distribution/Gentoo/Packages.hs" || die
+
+ sed -i -e 's,"/","'"${EPREFIX}"'/",g' \
+ "${S}/Distribution/Gentoo/GHC.hs" || die
+ fi
+ epatch "${FILESDIR}/${PN}-1.2.0.5-ghc-7.5.patch"
+ sed -e 's@Cabal >= 1.8 && < 1.15@Cabal >= 1.8 \&\& < 1.16@' \
+ -e 's@containers < 0.5@containers < 0.6@' \
+ -i "${S}/${PN}.cabal" || die "Could not loosen dependencies"
+}
+
+src_configure() {
+ cabal_src_configure \
+ --bindir="${EPREFIX}/usr/sbin" \
+ --constraint="Cabal == $(cabal-version)"
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc TODO
+}