summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-09-09 13:19:29 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-09-09 13:19:29 +0000
commit4fb8b39bc6f2421b6db2150a2686d5b249131d55 (patch)
tree5870cd5a086892514ec97392e72e0b3000e058a1 /app-admin/hddtemp
parentUpdate homepage and download URL to Oracle site. (diff)
downloadgentoo-2-4fb8b39bc6f2421b6db2150a2686d5b249131d55.tar.gz
gentoo-2-4fb8b39bc6f2421b6db2150a2686d5b249131d55.tar.bz2
gentoo-2-4fb8b39bc6f2421b6db2150a2686d5b249131d55.zip
app-admin/hddtemp-0.3_beta15-r4: Bumped EAPI to 4. Fixed bug #374163.
(Portage version: 2.1.10.13/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/hddtemp')
-rw-r--r--app-admin/hddtemp/ChangeLog8
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild18
2 files changed, 15 insertions, 11 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
index 537889d650b4..abe862909809 100644
--- a/app-admin/hddtemp/ChangeLog
+++ b/app-admin/hddtemp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/hddtemp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.100 2011/09/09 12:58:28 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.101 2011/09/09 13:19:29 aidecoe Exp $
+
+ 09 Sep 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ hddtemp-0.3_beta15-r4.ebuild:
+ Bumped EAPI to 4. Fixed bug #374163.
+
+ Thanks to Agostino Sarubbo <ago@autistici.org> for the patch.
09 Sep 2011; Amadeusz Żołnowski <aidecoe@gentoo.org> files/hddgentoo.db:
New drives for hddgentoo.db. Fixed bug #381517.
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
index 507538948dfe..782d406c6be8 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild,v 1.4 2011/07/05 14:33:29 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild,v 1.5 2011/09/09 13:19:29 aidecoe Exp $
+
+EAPI=4
inherit eutils autotools
@@ -21,9 +23,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-satacmds.patch
epatch "${FILESDIR}"/${P}-byteswap.patch
epatch "${FILESDIR}"/${P}-execinfo.patch
@@ -32,18 +32,17 @@ src_unpack() {
AT_M4DIR="m4" eautoreconf
}
-src_compile() {
+src_configure() {
local myconf
myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
# disabling nls breaks compiling
use nls || myconf="--disable-nls ${myconf}"
- econf ${myconf} || die
- emake || die
+ econf ${myconf}
}
src_install() {
- make DESTDIR="${D}" install || die
+ default
dodoc README TODO ChangeLog
insinto /usr/share/hddtemp
@@ -59,8 +58,7 @@ src_install() {
if use network-cron ; then
exeinto /etc/cron.monthly
echo -e "#!/bin/sh\n/usr/sbin/update-hddtemp.db" > "${T}"/hddtemp.cron
- newexe "${T}"/hddtemp.cron update-hddtemp.db \
- || die "Failed to install update cronjob"
+ newexe "${T}"/hddtemp.cron update-hddtemp.db
fi
}