summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-04 23:03:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-04 23:03:27 +0000
commit831d9fbb6a9e448849117c50aeee5034147a3c29 (patch)
tree28cc05ea6054ba4b2d977594a02828a36e611859 /app-admin/integrit/integrit-4.1.ebuild
parentChange virtual/xft dependency to x11-libs/libXft, bug 253771. (diff)
downloadgentoo-2-831d9fbb6a9e448849117c50aeee5034147a3c29.tar.gz
gentoo-2-831d9fbb6a9e448849117c50aeee5034147a3c29.tar.bz2
gentoo-2-831d9fbb6a9e448849117c50aeee5034147a3c29.zip
Bump to 4.1. Fixes #202803
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-admin/integrit/integrit-4.1.ebuild')
-rw-r--r--app-admin/integrit/integrit-4.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/integrit/integrit-4.1.ebuild b/app-admin/integrit/integrit-4.1.ebuild
new file mode 100644
index 000000000000..4257e159c381
--- /dev/null
+++ b/app-admin/integrit/integrit-4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/integrit/integrit-4.1.ebuild,v 1.1 2009/01/04 23:03:27 patrick Exp $
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="file integrity verification program"
+HOMEPAGE="http://integrit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "/^CC/d" configure.in hashtbl/configure.in || die
+ sed -i -e "/^AC_PROGRAM_PATH/d" configure.in hashtbl/configure.in || die
+
+ eautoreconf
+}
+
+src_compile() {
+ tc-export AR
+ econf
+ emake || die
+ emake utils || die
+ cd "${S}"/doc
+ emake || die
+ cd "${S}"/hashtbl
+ emake hashtest || die
+ mv README README.hashtbl
+}
+
+src_install() {
+ dosbin integrit || die
+ dolib libintegrit.a
+ dodoc Changes HACKING README todo.txt
+
+ cd "${S}"/utils
+ dosbin i-viewdb
+ dobin i-ls
+
+ cd "${S}"/hashtbl
+ dolib libhashtbl.a
+ insinto /usr/include
+ doins hashtbl.h
+ dobin hashtest
+ dodoc README.hashtbl
+
+ cd "${S}"/doc
+ doman i-ls.1 i-viewdb.1 integrit.1
+ doinfo integrit.info
+
+ cd "${S}"/examples
+ docinto examples
+ dodoc *
+}
+
+pkg_postinst() {
+ elog "It is recommended that the integrit binary is copied to a secure"
+ elog "location and re-copied at runtime or run from a secure medium."
+ elog "You should also create a configuration file (see examples)."
+}