summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-03-16 18:16:41 +0000
committerMike Gilbert <floppym@gentoo.org>2014-03-16 18:16:41 +0000
commit59955c4fb60bd13ee5ef534839ced912d9fba4d2 (patch)
tree161b0a2853cef0c584327788ab0e3fa75b19970b /app-admin/python-updater/python-updater-9999.ebuild
parentAdd new, drop oldest version. (diff)
downloadgentoo-2-59955c4fb60bd13ee5ef534839ced912d9fba4d2.tar.gz
gentoo-2-59955c4fb60bd13ee5ef534839ced912d9fba4d2.tar.bz2
gentoo-2-59955c4fb60bd13ee5ef534839ced912d9fba4d2.zip
Version bump. Incorporate prefix support. Source /lib/gentoo/functions.sh, bug 504130.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-admin/python-updater/python-updater-9999.ebuild')
-rw-r--r--app-admin/python-updater/python-updater-9999.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/app-admin/python-updater/python-updater-9999.ebuild b/app-admin/python-updater/python-updater-9999.ebuild
index 3fb8dd6365d3..6cd9d7101f24 100644
--- a/app-admin/python-updater/python-updater-9999.ebuild
+++ b/app-admin/python-updater/python-updater-9999.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v 1.11 2014/01/20 02:49:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v 1.12 2014/03/16 18:16:41 floppym Exp $
EAPI=5
if [[ "${PV}" == "9999" ]]; then
- inherit git-2
+ inherit git-r3
fi
DESCRIPTION="Script used to reinstall Python packages after changing of active Python versions"
HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/python-updater.git"
else
SRC_URI="http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
@@ -22,17 +21,18 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-DEPEND="$([[ "${PV}" == "9999" ]] && echo "sys-apps/help2man")"
-RDEPEND="|| ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 )"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND="
+ sys-apps/gentoo-functions
+ sys-apps/help2man
+ "
+fi
+RDEPEND="
+ sys-apps/gentoo-functions
+ || ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 sys-apps/pkgcore )
+"
src_compile() {
- if [[ "${PV}" == "9999" ]]; then
- emake ${PN}.1 || die "Generation of man page failed"
- fi
-}
-
-src_install() {
- dosbin ${PN}
- doman ${PN}.1
- dodoc AUTHORS
+ [[ ${PV} == 9999 ]] && emake python-updater
+ default
}