summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 17:51:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 17:51:03 +0000
commit61023644e0f292b2c12fc94c239b941cfce25e03 (patch)
treeffaa98fa0c4374f005e4994d511e4007bf197150 /app-admin/python-updater
parenttweak default variable value so eclass-manpages can figure things out (diff)
downloadgentoo-2-61023644e0f292b2c12fc94c239b941cfce25e03.tar.gz
gentoo-2-61023644e0f292b2c12fc94c239b941cfce25e03.tar.bz2
gentoo-2-61023644e0f292b2c12fc94c239b941cfce25e03.zip
Fix dependencies.
(Portage version: 15754-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/python-updater')
-rw-r--r--app-admin/python-updater/python-updater-0.7-r1.ebuild6
-rw-r--r--app-admin/python-updater/python-updater-0.7.ebuild8
-rw-r--r--app-admin/python-updater/python-updater-0.8.ebuild6
-rw-r--r--app-admin/python-updater/python-updater-9999.ebuild16
4 files changed, 18 insertions, 18 deletions
diff --git a/app-admin/python-updater/python-updater-0.7-r1.ebuild b/app-admin/python-updater/python-updater-0.7-r1.ebuild
index 4dc3afaf9d4e..a397b7efd2a4 100644
--- a/app-admin/python-updater/python-updater-0.7-r1.ebuild
+++ b/app-admin/python-updater/python-updater-0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.7-r1.ebuild,v 1.2 2010/02/01 22:02:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.7-r1.ebuild,v 1.3 2010/03/07 17:51:03 arfrever Exp $
inherit eutils
@@ -15,6 +15,7 @@ IUSE=""
DEPEND=""
RDEPEND="!<dev-lang/python-2.3.6-r2
+ dev-lang/python
>=sys-apps/portage-2.1.2"
src_unpack() {
@@ -25,8 +26,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-fix_import.patch"
}
-src_install()
-{
+src_install() {
dosbin ${PN} || die "dosbin failed"
doman ${PN}.1 || die "doman failed"
dodoc AUTHORS ChangeLog || die "dodoc failed"
diff --git a/app-admin/python-updater/python-updater-0.7.ebuild b/app-admin/python-updater/python-updater-0.7.ebuild
index 1dc49dfd604c..2bc635d82706 100644
--- a/app-admin/python-updater/python-updater-0.7.ebuild
+++ b/app-admin/python-updater/python-updater-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.7.ebuild,v 1.8 2009/10/17 19:22:40 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.7.ebuild,v 1.9 2010/03/07 17:51:03 arfrever Exp $
DESCRIPTION="Script used to remerge python packages when changing Python version."
HOMEPAGE="http://www.gentoo.org/proj/en/Python"
@@ -13,10 +13,10 @@ IUSE=""
DEPEND=""
RDEPEND="!<dev-lang/python-2.3.6-r2
+ dev-lang/python
>=sys-apps/portage-2.1.2"
-src_install()
-{
+src_install() {
dosbin ${PN} || die "dosbin failed"
doman ${PN}.1 || die "doman failed"
dodoc AUTHORS ChangeLog || die "dodoc failed"
diff --git a/app-admin/python-updater/python-updater-0.8.ebuild b/app-admin/python-updater/python-updater-0.8.ebuild
index c0f62fd837c5..0780787b3885 100644
--- a/app-admin/python-updater/python-updater-0.8.ebuild
+++ b/app-admin/python-updater/python-updater-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.8.ebuild,v 1.1 2010/01/29 17:17:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.8.ebuild,v 1.2 2010/03/07 17:51:03 arfrever Exp $
DESCRIPTION="Script used to remerge python packages when changing Python version."
HOMEPAGE="http://www.gentoo.org/proj/en/Python"
@@ -13,10 +13,10 @@ IUSE=""
DEPEND=""
RDEPEND="!<dev-lang/python-2.3.6-r2
+ dev-lang/python
|| ( >=sys-apps/portage-2.1.2 sys-apps/paludis )"
-src_install()
-{
+src_install() {
dosbin ${PN} || die "dosbin failed"
doman ${PN}.1 || die "doman failed"
dodoc AUTHORS ChangeLog || die "dodoc failed"
diff --git a/app-admin/python-updater/python-updater-9999.ebuild b/app-admin/python-updater/python-updater-9999.ebuild
index 74a5d6e32dd9..a06b03c704da 100644
--- a/app-admin/python-updater/python-updater-9999.ebuild
+++ b/app-admin/python-updater/python-updater-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v 1.1 2008/06/20 17:56:02 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v 1.2 2010/03/07 17:51:03 arfrever Exp $
inherit subversion
@@ -16,15 +16,15 @@ IUSE=""
DEPEND="sys-apps/help2man"
RDEPEND="!<dev-lang/python-2.3.6-r2
+ dev-lang/python
|| ( >=sys-apps/portage-2.1.2 sys-apps/pkgcore sys-apps/paludis )"
src_compile() {
- emake ${PN}.1 || die "couldn't generate manpage"
+ emake ${PN}.1 || die "Generation of man page failed"
}
-src_install()
-{
- doman ${PN}.1
- dosbin ${PN}
- dodoc AUTHORS ChangeLog
+src_install() {
+ dosbin ${PN} || die "dosbin failed"
+ doman ${PN}.1 || die "doman failed"
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
}