summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-27 12:41:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-27 12:41:48 +0000
commit0f7c08a37e76f47bf5186de8d0a94dbe13d9b948 (patch)
tree303087f675424281d744cd1cd1c2d0bc1b5a40c5 /app-admin/rudy/rudy-0.9.8.016.ebuild
parentpunt libjingle, doesn't compile with stable openssl or coreutils, not of any ... (diff)
downloadgentoo-2-0f7c08a37e76f47bf5186de8d0a94dbe13d9b948.tar.gz
gentoo-2-0f7c08a37e76f47bf5186de8d0a94dbe13d9b948.tar.bz2
gentoo-2-0f7c08a37e76f47bf5186de8d0a94dbe13d9b948.zip
Version bump, cleanup old.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/rudy/rudy-0.9.8.016.ebuild')
-rw-r--r--app-admin/rudy/rudy-0.9.8.016.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-admin/rudy/rudy-0.9.8.016.ebuild b/app-admin/rudy/rudy-0.9.8.016.ebuild
new file mode 100644
index 000000000000..808aa8b17207
--- /dev/null
+++ b/app-admin/rudy/rudy-0.9.8.016.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rudy/rudy-0.9.8.016.ebuild,v 1.1 2010/10/27 12:41:48 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RESTRICT=test
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc examples/authorize.rb examples/gem-test.rb
+ examples/solaris.rb examples/windows.rb"
+
+RUBY_FAKEGEM_EXTRAINSTALL="Rudyfile"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="Not your grandparents' EC2 deployment tool"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+if [[ "$(get_version_component_range 4)" == "001" ]]; then
+ MY_PV="$(get_version_component_range 1-3)"
+else
+ MY_PV="${PV}"
+fi
+
+SRC_URI="http://github.com/solutious/${PN}/tarball/v${MY_PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/solutious-${PN}-*"
+
+ruby_add_rdepend '
+ >=dev-ruby/amazon-ec2-0.9.10
+ >=dev-ruby/highline-1.5.1
+ >=dev-ruby/aws-s3-0.6.1
+ >=dev-ruby/storable-0.7.1
+ >=dev-ruby/gibbler-0.7.7
+ >=dev-ruby/sysinfo-0.7.3
+ >=dev-ruby/caesars-0.7.4
+ >=dev-ruby/drydock-0.6.9
+ >=dev-ruby/annoy-0.5.6
+ >=dev-ruby/attic-0.5.2
+ >=dev-ruby/rye-0.9.2'