summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-04-28 17:22:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-04-28 17:22:44 +0000
commitaf3feaec0115b2e44483d4eaee95a8be0f112581 (patch)
treeb3c15127dd64a25398c7ae8605e5c5b44074720f /app-admin/sudo/sudo-1.6.7_p5-r3.ebuild
parentCleaning (diff)
downloadgentoo-2-af3feaec0115b2e44483d4eaee95a8be0f112581.tar.gz
gentoo-2-af3feaec0115b2e44483d4eaee95a8be0f112581.tar.bz2
gentoo-2-af3feaec0115b2e44483d4eaee95a8be0f112581.zip
Added new revision which depends on virtual/pam and uses the include notation so that it works on non-linux-pam systems.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'app-admin/sudo/sudo-1.6.7_p5-r3.ebuild')
-rw-r--r--app-admin/sudo/sudo-1.6.7_p5-r3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/sudo/sudo-1.6.7_p5-r3.ebuild b/app-admin/sudo/sudo-1.6.7_p5-r3.ebuild
new file mode 100644
index 000000000000..2ba234f2a977
--- /dev/null
+++ b/app-admin/sudo/sudo-1.6.7_p5-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.6.7_p5-r3.ebuild,v 1.1 2005/04/28 17:22:44 flameeyes Exp $
+
+inherit eutils
+
+#
+# TODO: Fix support for krb4 and krb5
+#
+
+DESCRIPTION="Allows certain users/groups to run commands as root"
+HOMEPAGE="http://www.sudo.ws/"
+SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${P/_/}.tar.gz"
+
+LICENSE="Sudo"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="pam skey"
+
+DEPEND="pam? ( virtual/pam )
+ skey? ( >=app-admin/skey-1.1.5-r1 )"
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+ use skey && epatch ${FILESDIR}/${PN}-skeychallengeargs.diff
+ epatch ${FILESDIR}/${P}-strip-bash-functions.diff
+}
+
+src_compile() {
+ econf \
+ --with-all-insults \
+ --disable-path-info \
+ --with-env-editor \
+ $(use_with pam) \
+ $(use_with skey) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc BUGS CHANGES HISTORY PORTING README RUNSON TODO \
+ TROUBLESHOOTING UPGRADE sample.*
+
+ newpamd ${FILESDIR}/sudo_include sudo
+
+ insinto /etc
+ doins ${FILESDIR}/sudoers
+ fperms 0440 /etc/sudoers
+}
+
+pkg_postinst() {
+ use skey && use pam && {
+ ewarn "sudo will not use skey authentication when compiled with"
+ ewarn "pam support. to allow users to authenticate with one time"
+ ewarn "passwords, you should unset the pam USE flag for sudo."
+ }
+}