summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeath Caldwell <hncaldwell@gentoo.org>2008-12-02 20:46:54 +0000
committerHeath Caldwell <hncaldwell@gentoo.org>2008-12-02 20:46:54 +0000
commit23826be503254dc551bbe8f0616aa7e068afd9f4 (patch)
tree4be6305316a05e6c19c41dd820b5311429414493 /app-admin/tenshi/tenshi-0.10-r3.ebuild
parentstable ppc64, bug 245096 (diff)
downloadgentoo-2-23826be503254dc551bbe8f0616aa7e068afd9f4.tar.gz
gentoo-2-23826be503254dc551bbe8f0616aa7e068afd9f4.tar.bz2
gentoo-2-23826be503254dc551bbe8f0616aa7e068afd9f4.zip
Add tenshi-0.10-r3 with solo-queue-escalation and warn-logfile patches (fixes bug #243082)
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.25-gentoo-r6-grey01 x86_64)
Diffstat (limited to 'app-admin/tenshi/tenshi-0.10-r3.ebuild')
-rw-r--r--app-admin/tenshi/tenshi-0.10-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/tenshi/tenshi-0.10-r3.ebuild b/app-admin/tenshi/tenshi-0.10-r3.ebuild
new file mode 100644
index 000000000000..a73588d72ec4
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.10-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/tenshi-0.10-r3.ebuild,v 1.1 2008/12/02 20:46:54 hncaldwell Exp $
+
+inherit eutils
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="http://dev.inversepath.com/trac/tenshi"
+SRC_URI="http://dev.inversepath.com/tenshi/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/IO-BufferedSelect
+ sys-apps/coreutils"
+
+pkg_setup() {
+ enewgroup tenshi
+ enewuser tenshi -1 -1 /var/lib/tenshi tenshi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-create-mandir.patch"
+ # Fix for bug #218042
+ epatch "${FILESDIR}/${PN}-openrc-init.patch"
+ # Fix for bug #217000
+ epatch "${FILESDIR}/${PN}-remove-timezone-cache.patch"
+
+ # Fixes for bug #243082
+ epatch "${FILESDIR}/${PN}-0.10-solo-queue-escalation.patch"
+ epatch "${FILESDIR}/${PN}-0.10-warn-logfile.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ fowners tenshi:root /etc/tenshi/tenshi.conf
+ dodir /var/lib/tenshi
+ fowners tenshi:root /var/lib/tenshi
+ doman tenshi.8
+ newinitd tenshi.gentoo-init tenshi
+ keepdir /var/lib/tenshi
+}