summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-10 05:28:20 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-10 05:28:20 +0000
commitc957c4d185cf57525799fa4173741cb6810677e4 (patch)
tree7fec70525b7a45d77edaa7370c6509cef96a64b9 /app-admin/testdisk/testdisk-6.14.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c957c4d185cf57525799fa4173741cb6810677e4.tar.gz
gentoo-2-c957c4d185cf57525799fa4173741cb6810677e4.tar.bz2
gentoo-2-c957c4d185cf57525799fa4173741cb6810677e4.zip
Version bump.
(Portage version: 2.2.0_alpha195/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-admin/testdisk/testdisk-6.14.ebuild')
-rw-r--r--app-admin/testdisk/testdisk-6.14.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/testdisk/testdisk-6.14.ebuild b/app-admin/testdisk/testdisk-6.14.ebuild
new file mode 100644
index 000000000000..36bcdf9f2261
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.14.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.14.ebuild,v 1.1 2013/08/10 05:28:20 radhermit Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="jpeg ntfs reiserfs static"
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND="
+ sys-apps/util-linux
+ >=sys-libs/ncurses-5.2
+ jpeg? ( virtual/jpeg )
+ ntfs? ( sys-fs/ntfs3g )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35
+ sys-libs/zlib"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_configure() {
+ local myconf
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf+=" --without-reiserfs"
+ use ntfs || myconf+=" --without-ntfs"
+ use jpeg || myconf+=" --without-jpeg"
+
+ econf \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --without-ewf \
+ --enable-sudo \
+ ${myconf}
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}