summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-07-05 08:37:27 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-07-05 08:37:27 +0000
commit056fd0dbc2d51f86a47e617a78c85505fe8d636c (patch)
treea259edf8a6c94b939bb491e666410a06538037e1 /app-admin
parentinitial commit (diff)
downloadgentoo-2-056fd0dbc2d51f86a47e617a78c85505fe8d636c.tar.gz
gentoo-2-056fd0dbc2d51f86a47e617a78c85505fe8d636c.tar.bz2
gentoo-2-056fd0dbc2d51f86a47e617a78c85505fe8d636c.zip
initial commit
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/cpu/ChangeLog10
-rw-r--r--app-admin/cpu/Manifest5
-rw-r--r--app-admin/cpu/cpu-1.3.100.ebuild49
-rw-r--r--app-admin/cpu/files/cpu-1.3.100-fixup.patch47
-rw-r--r--app-admin/cpu/files/digest-cpu-1.3.1001
5 files changed, 110 insertions, 2 deletions
diff --git a/app-admin/cpu/ChangeLog b/app-admin/cpu/ChangeLog
new file mode 100644
index 000000000000..e62bceffae4f
--- /dev/null
+++ b/app-admin/cpu/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-admin/cpu
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/ChangeLog,v 1.1 2003/07/05 08:37:21 robbat2 Exp $
+
+*cpu-1.3.100 (05 Jul 2003)
+
+ 05 Jul 2003; Robin H. Johnson <robbat2@gentoo.org> cpu-1.3.100.ebuild,
+ files/cpu-1.3.100-fixup.patch:
+ Initial commit
+
diff --git a/app-admin/cpu/Manifest b/app-admin/cpu/Manifest
index 6bf7a0c23a73..4733369283eb 100644
--- a/app-admin/cpu/Manifest
+++ b/app-admin/cpu/Manifest
@@ -1,3 +1,4 @@
-MD5 f9d75eccfdcc38ff678bb4faaa0264fd cpu-1.3.100.ebuild 5889
-MD5 f9d75eccfdcc38ff678bb4faaa0264fd cpu-1.3.100.ebuild~ 5889
+MD5 de8af5ea169800650a3cad777819f975 cpu-1.3.100.ebuild 1219
+MD5 78295c707175436f046723a50cc2fb3b ChangeLog 361
MD5 021b5afd2ac0d086a3400da75c9ce5db files/digest-cpu-1.3.100 64
+MD5 d46da8966e987eb912de530bfb0c8ab8 files/cpu-1.3.100-fixup.patch 1726
diff --git a/app-admin/cpu/cpu-1.3.100.ebuild b/app-admin/cpu/cpu-1.3.100.ebuild
new file mode 100644
index 000000000000..8e42bd3ad735
--- /dev/null
+++ b/app-admin/cpu/cpu-1.3.100.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.3.100.ebuild,v 1.1 2003/07/05 08:37:21 robbat2 Exp $
+
+DESCRIPTION="CPU is an LDAP user management tool written in C and loosely based on FreeBSD's pw(8)."
+HOMEPAGE="http://cpu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="net-nds/openldap
+ sys-libs/cracklib"
+
+DEPEND="${DEPEND}
+ >=sys-devel/autoconf-2.52"
+
+S=${WORKDIR}/${P}
+
+WANT_AUTOCONF_2_5=1
+
+src_compile() {
+
+ # The package has a history of bad configure files...
+ epatch ${FILESDIR}/${P}-fixup.patch
+ autoconf
+
+ local myconf
+
+ # provide PASSWD support as well
+ # It's broken in the application at the moment, so lets not...
+ # myconf="${myconf} --with-passwd"
+
+ # Tell it where to find LDAP
+ myconf="${myconf} --with-ldap=/usr"
+ # Tell it where to find CRACKLIB
+ myconf="${myconf} --with-libcrack=/usr"
+
+ # cache our config!
+ myconf="${myconf} --cache-file=${S}/config.cache"
+
+ econf ${myconf} || die "Configure failure"
+
+ emake || die "Make failure"
+}
+
+src_install() {
+ einstall || die "Einstall failure"
+}
diff --git a/app-admin/cpu/files/cpu-1.3.100-fixup.patch b/app-admin/cpu/files/cpu-1.3.100-fixup.patch
new file mode 100644
index 000000000000..c0ca4d174d61
--- /dev/null
+++ b/app-admin/cpu/files/cpu-1.3.100-fixup.patch
@@ -0,0 +1,47 @@
+--- cpu-1.3.100.orig/configure.ac 2003-07-05 01:23:05.000000000 -0700
++++ cpu-1.3.100/configure.ac 2003-07-05 01:24:27.000000000 -0700
+@@ -63,7 +63,7 @@
+ AC_MSG_CHECKING(whether to compile with debugging malloc)
+ AC_ARG_WITH(dmalloc,
+ [ --with-dmalloc Debug using dmalloc (default is no)],
+- [AC_MSG_RESULT("$with_dmalloc")
++ [AC_MSG_RESULT($with_dmalloc)
+ AC_CHECK_LIB(dmalloc, dmalloc_debug)],
+ [AC_MSG_RESULT(no)]
+ )
+@@ -71,7 +71,7 @@
+ AC_MSG_CHECKING(whether builder is a developer)
+ AC_ARG_WITH(developer,
+ [ --with-developer Developers should use this],
+- [AC_MSG_RESULT("$with_developer")
++ [AC_MSG_RESULT($with_developer)
+ AC_DEFINE_UNQUOTED(DEVELOPER, 1, [Are you in?])],
+ [AC_MSG_RESULT(no)]
+ )
+@@ -79,7 +79,7 @@
+ AC_MSG_CHECKING(whether to compile with cracklib)
+ AC_ARG_WITH(libcrack,
+ [ --with-libcrack=Prefix Try to use libcrack],
+- [AC_MSG_RESULT("$with_libcrack")
++ [AC_MSG_RESULT($with_libcrack)
+ AC_CHECK_LIB(crack, FascistCheck)
+ AC_CHECK_HEADERS(crack.h,,AC_MSG_ERROR(Could not find crack.h))],
+ [AC_MSG_RESULT(no)]
+@@ -88,7 +88,7 @@
+ AC_MSG_CHECKING(where ldap development files are)
+ AC_ARG_WITH(ldap,
+ [ --with-ldap=Prefix Base of ldap files],
+- [AC_MSG_RESULT("$with_ldap")
++ [AC_MSG_RESULT($with_ldap)
+ if test "$with_ldap" != "yes"; then
+ LDFLAGS="$LDFLAGS -L$with_ldap/lib"
+ CPPFLAGS="$CPPFLAGS -I$with_ldap/include"
+@@ -104,7 +104,7 @@
+ AC_MSG_CHECKING(whether to build passwd plugin)
+ AC_ARG_WITH(passwd,
+ [ --with-passwd Compile passwd plugin],
+- [AC_MSG_RESULT("$with_passwd")],
++ [AC_MSG_RESULT($with_passwd)],
+ [AC_MSG_RESULT(no)
+ without_passwd=true]
+ )
diff --git a/app-admin/cpu/files/digest-cpu-1.3.100 b/app-admin/cpu/files/digest-cpu-1.3.100
new file mode 100644
index 000000000000..f404819397a9
--- /dev/null
+++ b/app-admin/cpu/files/digest-cpu-1.3.100
@@ -0,0 +1 @@
+MD5 c3edaade7f975779b40ae80e40fccb98 cpu-1.3.100.tar.bz2 214614