summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2005-10-25 17:12:47 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2005-10-25 17:12:47 +0000
commit1350b2a539c7f097202496393da8c6bcc2dc7e05 (patch)
tree718e9310848570bb77e7a7c17cf31bce396b1e31 /app-admin
parentstable on x86, #110454 (diff)
downloadgentoo-2-1350b2a539c7f097202496393da8c6bcc2dc7e05.tar.gz
gentoo-2-1350b2a539c7f097202496393da8c6bcc2dc7e05.tar.bz2
gentoo-2-1350b2a539c7f097202496393da8c6bcc2dc7e05.zip
Bump to fix bug #109642
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gamin/ChangeLog8
-rw-r--r--app-admin/gamin/Manifest3
-rw-r--r--app-admin/gamin/files/digest-gamin-0.1.6-r11
-rw-r--r--app-admin/gamin/files/gamin-0.1.6-doublefree.patch29
-rw-r--r--app-admin/gamin/gamin-0.1.6-r1.ebuild59
5 files changed, 99 insertions, 1 deletions
diff --git a/app-admin/gamin/ChangeLog b/app-admin/gamin/ChangeLog
index 88d987bc6cd0..88e416bcaa82 100644
--- a/app-admin/gamin/ChangeLog
+++ b/app-admin/gamin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/gamin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.37 2005/10/24 17:30:48 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.38 2005/10/25 17:12:47 dang Exp $
+
+*gamin-0.1.6-r1 (25 Oct 2005)
+
+ 25 Oct 2005; <dang@gentoo.org> +files/gamin-0.1.6-doublefree.patch,
+ +gamin-0.1.6-r1.ebuild:
+ Bump to fix bug #109642
24 Oct 2005; Tobias Scherbaum <dertobi123@gentoo.org> gamin-0.1.6.ebuild:
Marked ppc stable, bug #109154
diff --git a/app-admin/gamin/Manifest b/app-admin/gamin/Manifest
index 5de1a0f6c98b..46f6ab644e79 100644
--- a/app-admin/gamin/Manifest
+++ b/app-admin/gamin/Manifest
@@ -1,9 +1,12 @@
MD5 4e08d325b05dc57e0be88f571d62e6df ChangeLog 6340
MD5 20a4a3c7c4794dfac0d00d75ef58fb96 files/digest-gamin-0.1.5 63
MD5 4c4877b9719b0d721cdb582cd290454a files/digest-gamin-0.1.6 63
+MD5 4c4877b9719b0d721cdb582cd290454a files/digest-gamin-0.1.6-r1 63
MD5 510d70d44de83d7822311077a39621c8 files/gamin-0.1.3-freebsd.patch 3857
MD5 84f3255901e8fa0574b40df22ee54cea files/gamin-0.1.5-inotify-legacy-backend.patch 27609
MD5 ac0a6ced64a702a7d8cc11cc3437687c files/gamin-0.1.5-noinotify.patch 1180
+MD5 44c921abd1a5d8fd8a6bb523dde8e680 files/gamin-0.1.6-doublefree.patch 1012
MD5 56d0a147e3d52d29bdfac13e2f2a1952 gamin-0.1.5.ebuild 1929
+MD5 70fe2305fb186c33e9f533ede52abd9a gamin-0.1.6-r1.ebuild 1374
MD5 a7fc377bb4a8b373ee9964977491758b gamin-0.1.6.ebuild 1436
MD5 875135e8740bafa4dab79ee592cf9744 metadata.xml 279
diff --git a/app-admin/gamin/files/digest-gamin-0.1.6-r1 b/app-admin/gamin/files/digest-gamin-0.1.6-r1
new file mode 100644
index 000000000000..08d8c38a9bee
--- /dev/null
+++ b/app-admin/gamin/files/digest-gamin-0.1.6-r1
@@ -0,0 +1 @@
+MD5 9c306b964ca95044a19c273dffd24001 gamin-0.1.6.tar.gz 538720
diff --git a/app-admin/gamin/files/gamin-0.1.6-doublefree.patch b/app-admin/gamin/files/gamin-0.1.6-doublefree.patch
new file mode 100644
index 000000000000..edef11c9a17f
--- /dev/null
+++ b/app-admin/gamin/files/gamin-0.1.6-doublefree.patch
@@ -0,0 +1,29 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN gamin-0.1.6.orig/server/gam_connection.c gamin-0.1.6/server/gam_connection.c
+--- gamin-0.1.6.orig/server/gam_connection.c 2005-09-08 06:18:13.000000000 -0400
++++ gamin-0.1.6/server/gam_connection.c 2005-10-25 12:46:18.000000000 -0400
+@@ -387,8 +387,13 @@
+ gam_listener_remove_subscription(conn->listener, sub);
+ gam_remove_subscription(sub);
+ #ifdef ENABLE_INOTIFY
+- if (gam_inotify_is_running())
+- gam_subscription_free(sub);
++ if ((gam_inotify_is_running()) && (!gam_exclude_check(path))) {
++ gam_fs_mon_type type;
++
++ type = gam_fs_get_mon_type (path);
++ if (type != GFS_MT_POLL)
++ gam_subscription_free(sub);
++ }
+ #endif
+
+ if (gam_send_ack(conn, req->seq, path, pathlen) < 0) {
+@@ -396,7 +401,8 @@
+ gam_connection_get_pid(conn));
+ }
+ g_free(path);
+- } break;
++ break;
++ }
+ case GAM_REQ_DEBUG:
+ #ifdef GAMIN_DEBUG_API
+ gam_debug_add(conn, req->path, options);
diff --git a/app-admin/gamin/gamin-0.1.6-r1.ebuild b/app-admin/gamin/gamin-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..28985771a2f8
--- /dev/null
+++ b/app-admin/gamin/gamin-0.1.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.6-r1.ebuild,v 1.1 2005/10/25 17:12:47 dang Exp $
+
+inherit autotools eutils libtool
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~s390 ~sh ~x86"
+IUSE="debug doc"
+
+RDEPEND="virtual/libc
+ >=dev-libs/glib-2
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix doublefree bug #109642
+ epatch ${FILESDIR}/${P}-doublefree.patch
+
+ # Do not remove
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug) \
+ $(use_enable debug debug-api) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+ use doc && dohtml doc/*
+}
+
+pkg_postinst() {
+ if use kernel_linux; then
+ einfo "It is strongly suggested you use Gamin with an inotify enabled"
+ einfo "kernel for best performance. For this release of gamin you need"
+ einfo "at least gentoo-sources-2.6.13 or later."
+ fi
+}