summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-14 02:52:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-14 02:52:20 +0000
commit7cecbebc78ac02d819f77ed9f286e3d3af539fa0 (patch)
treeebf91f3684a7541febc24ee4da4f42c2a527908e /app-admin
parentResurrect megactl for infra, as we want megasasctl; fixes in the next commit. (diff)
downloadgentoo-2-7cecbebc78ac02d819f77ed9f286e3d3af539fa0.tar.gz
gentoo-2-7cecbebc78ac02d819f77ed9f286e3d3af539fa0.tar.bz2
gentoo-2-7cecbebc78ac02d819f77ed9f286e3d3af539fa0.zip
Revert switch to opencl-1.2 headers, needs proper switching logic. Fixes #512680
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-opencl/ChangeLog9
-rw-r--r--app-admin/eselect-opencl/eselect-opencl-1.1.0-r3.ebuild61
2 files changed, 69 insertions, 1 deletions
diff --git a/app-admin/eselect-opencl/ChangeLog b/app-admin/eselect-opencl/ChangeLog
index 1a7c8a8df7bd..2c9ab3e581a4 100644
--- a/app-admin/eselect-opencl/ChangeLog
+++ b/app-admin/eselect-opencl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/eselect-opencl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opencl/ChangeLog,v 1.11 2014/06/06 03:23:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opencl/ChangeLog,v 1.12 2014/07/14 02:52:20 patrick Exp $
+
+*eselect-opencl-1.1.0-r3 (14 Jul 2014)
+
+ 14 Jul 2014; Patrick Lauer <patrick@gentoo.org>
+ +eselect-opencl-1.1.0-r3.ebuild:
+ Revert switch to opencl-1.2 headers, needs proper switching logic. Fixes
+ #512680
06 Jun 2014; Patrick Lauer <patrick@gentoo.org>
eselect-opencl-1.1.0-r2.ebuild:
diff --git a/app-admin/eselect-opencl/eselect-opencl-1.1.0-r3.ebuild b/app-admin/eselect-opencl/eselect-opencl-1.1.0-r3.ebuild
new file mode 100644
index 000000000000..8a5df9f4ae07
--- /dev/null
+++ b/app-admin/eselect-opencl/eselect-opencl-1.1.0-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opencl/eselect-opencl-1.1.0-r3.ebuild,v 1.1 2014/07/14 02:52:20 patrick Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Utility to change the OpenCL implementation being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+# Source:
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/opencl.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_platform.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_ext.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_gl.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_gl_ext.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl.hpp
+
+# Using copy by Mario Kicherer #496418
+
+#MIRROR="http://dev.gentoo.org/~xarthisius/distfiles/"
+SRC_URI="https://github.com/anyc/opencl-headers/archive/opencl-headers-1.2.tar.gz
+ http://dev.gentoo.org/~xarthisius/distfiles/${P}-r1.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-admin/eselect-1.2.4"
+
+pkg_postinst() {
+ local impl="$(eselect opencl show)"
+ if [[ -n "${impl}" && "${impl}" != '(none)' ]] ; then
+ eselect opencl set "${impl}"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins opencl.eselect
+ #doman opencl.eselect.5
+
+ local headers=( opencl.h cl_platform.h cl.h cl_ext.h cl_gl.h cl_gl_ext.h cl.hpp )
+
+ # We install all versions of OpenCL headers
+ cd "${WORKDIR}/opencl-headers-opencl-headers-1.2"
+ for CL_ABI in 1.0 1.1 1.2; do
+ mkdir -p "${D}/usr/$(get_libdir)/OpenCL/global/include/CL-${CL_ABI}"
+ for f in ${headers[@]}; do
+ cp OpenCL-${CL_ABI}/${f} "${D}/usr/$(get_libdir)/OpenCL/global/include/CL-${CL_ABI}/${f}"
+ done
+ done
+ # Create symlinks to newest. Maybe this should be switchable?
+ for f in ${headers[@]}; do
+ dosym "${D}/usr/$(get_libdir)/OpenCL/global/include/CL-1.1/${f}" "/usr/$(get_libdir)/OpenCL/global/include/CL/${f}"
+ done
+}