summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-01-21 21:51:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-01-21 21:51:52 +0000
commit95e30a1563a3a66af0b57ca55c21134b7230048d (patch)
treee7375dbcba4225ed27a71483fd788233b39caa7a /app-admin
parentversion bump (diff)
downloadgentoo-2-95e30a1563a3a66af0b57ca55c21134b7230048d.tar.gz
gentoo-2-95e30a1563a3a66af0b57ca55c21134b7230048d.tar.bz2
gentoo-2-95e30a1563a3a66af0b57ca55c21134b7230048d.zip
masked 3.3 series version bump
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/syslog-ng/ChangeLog12
-rw-r--r--app-admin/syslog-ng/files/syslog-ng-3.3.1-filter.patch76
-rw-r--r--app-admin/syslog-ng/files/syslog-ng-3.3.1-ssl.patch85
-rw-r--r--app-admin/syslog-ng/files/syslog-ng-3.3.4-compile.patch10
-rw-r--r--app-admin/syslog-ng/syslog-ng-3.3.1.ebuild122
-rw-r--r--app-admin/syslog-ng/syslog-ng-3.3.4.ebuild (renamed from app-admin/syslog-ng/syslog-ng-3.3.3.ebuild)8
6 files changed, 24 insertions, 289 deletions
diff --git a/app-admin/syslog-ng/ChangeLog b/app-admin/syslog-ng/ChangeLog
index cd5c90c1403c..fb8c17343247 100644
--- a/app-admin/syslog-ng/ChangeLog
+++ b/app-admin/syslog-ng/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/syslog-ng
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/ChangeLog,v 1.317 2011/12/18 16:02:31 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/ChangeLog,v 1.318 2012/01/21 21:51:52 mr_bones_ Exp $
+
+*syslog-ng-3.3.4 (21 Jan 2012)
+
+ 21 Jan 2012; Michael Sterrett <mr_bones_@gentoo.org> -syslog-ng-3.3.1.ebuild,
+ -files/syslog-ng-3.3.1-filter.patch, -files/syslog-ng-3.3.1-ssl.patch,
+ -syslog-ng-3.3.3.ebuild, +syslog-ng-3.3.4.ebuild,
+ +files/syslog-ng-3.3.4-compile.patch:
+ masked 3.3 series version bump
18 Dec 2011; Raúl Porcel <armin76@gentoo.org> syslog-ng-3.2.5.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #394621
diff --git a/app-admin/syslog-ng/files/syslog-ng-3.3.1-filter.patch b/app-admin/syslog-ng/files/syslog-ng-3.3.1-filter.patch
deleted file mode 100644
index bc09406b8824..000000000000
--- a/app-admin/syslog-ng/files/syslog-ng-3.3.1-filter.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-commit 4b438115f6387eb52b6c39c1f751ecf0c4a5ac5f
-Author: Balazs Scheidler <bazsi@balabit.hu>
-Date: Sun Oct 23 20:19:58 2011 +0200
-
- filters: fixed filter() evaluation when embedded as an AND/OR subexpression
-
- When introducing the "init" method for filters one case was omitted: even
- though AND and OR expressions don't want to do anything on init, their
- subexpressions might, so this patch adds an init function to AND and OR
- which does nothing but calls the same for its "left" and "right"
- subexpression.
-
- This patch fixes filter("xxx") expression evaluation when that is
- not a single expression, but rather included in an AND or OR.
-
- Reported-By: Leonid Isaev <lisaev@umail.iu.edu>
- Cc: <syslog-ng-stable@balabit.hu>
- Signed-off-by: Balazs Scheidler <bazsi@balabit.hu>
-
---- a/lib/filter.c
-+++ b/lib/filter.c
-@@ -84,6 +84,17 @@ typedef struct _FilterOp
- } FilterOp;
-
- static void
-+fop_init(FilterExprNode *s, GlobalConfig *cfg)
-+{
-+ FilterOp *self = (FilterOp *) s;
-+
-+ if (self->left && self->left->init)
-+ self->left->init(self->left, cfg);
-+ if (self->right && self->right->init)
-+ self->right->init(self->right, cfg);
-+}
-+
-+static void
- fop_free(FilterExprNode *s)
- {
- FilterOp *self = (FilterOp *) s;
-@@ -92,6 +103,14 @@ fop_free(FilterExprNode *s)
- filter_expr_unref(self->right);
- }
-
-+static void
-+fop_init_instance(FilterOp *self)
-+{
-+ filter_expr_node_init(&self->super);
-+ self->super.init = fop_init;
-+ self->super.free_fn = fop_free;
-+}
-+
- static gboolean
- fop_or_eval(FilterExprNode *s, LogMessage *msg)
- {
-@@ -105,9 +124,8 @@ fop_or_new(FilterExprNode *e1, FilterExprNode *e2)
- {
- FilterOp *self = g_new0(FilterOp, 1);
-
-- filter_expr_node_init(&self->super);
-+ fop_init_instance(self);
- self->super.eval = fop_or_eval;
-- self->super.free_fn = fop_free;
- self->super.modify = e1->modify || e2->modify;
- self->left = e1;
- self->right = e2;
-@@ -128,9 +146,8 @@ fop_and_new(FilterExprNode *e1, FilterExprNode *e2)
- {
- FilterOp *self = g_new0(FilterOp, 1);
-
-- filter_expr_node_init(&self->super);
-+ fop_init_instance(self);
- self->super.eval = fop_and_eval;
-- self->super.free_fn = fop_free;
- self->super.modify = e1->modify || e2->modify;
- self->left = e1;
- self->right = e2;
diff --git a/app-admin/syslog-ng/files/syslog-ng-3.3.1-ssl.patch b/app-admin/syslog-ng/files/syslog-ng-3.3.1-ssl.patch
deleted file mode 100644
index f269ee254d97..000000000000
--- a/app-admin/syslog-ng/files/syslog-ng-3.3.1-ssl.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-While most places where OpenSSL was used were guarded by ENABLE_SSL
-ifs, some were not. This patch adds those guards to lib/crypto.c,
-modules/afsql/afsql.c and tests/loggen/loggen.c.
-
-It also makes sure that OPENSSL_LIBS gets emptied when enable_ssl is
-set to no.
-
-Signed-off-by: Gergely Nagy <algernon@balabit.hu>
----
- configure.in | 4 ++++
- lib/crypto.c | 4 ++++
- modules/afsql/afsql.c | 3 +++
- tests/loggen/loggen.c | 3 +++
- 4 files changed, 14 insertions(+), 0 deletions(-)
-
---- a/configure.in
-+++ b/configure.in
-@@ -679,6 +679,10 @@ else
- enable_ssl="no"
- fi
-
-+if test "x$enable_ssl" = "xno"; then
-+ OPENSSL_LIBS=""
-+fi
-+
- dnl
- dnl Right now, openssl is never linked statically as it is only used by the
- dnl TLS build of the afsocket plugin which is loaded dynamically anyway.
---- a/lib/crypto.c
-+++ b/lib/crypto.c
-@@ -29,6 +29,8 @@
- #include "crypto.h"
- #include "apphook.h"
-
-+#if ENABLE_SSL
-+
- #include <openssl/rand.h>
- #include <openssl/ssl.h>
- #include <stdio.h>
-@@ -124,3 +126,5 @@ crypto_init(void)
- }
-
- /* the crypto options (seed) are handled in main.c */
-+
-+#endif
---- a/modules/afsql/afsql.c
-+++ b/modules/afsql/afsql.c
-@@ -35,7 +35,10 @@
-
- #include <dbi/dbi.h>
- #include <string.h>
-+
-+#if ENABLE_SSL
- #include <openssl/md5.h>
-+#endif
-
- /* field flags */
- enum
---- a/tests/loggen/loggen.c
-+++ b/tests/loggen/loggen.c
-@@ -14,11 +14,14 @@
- #include <glib.h>
- #include <signal.h>
-
-+#if ENABLE_SSL
- #include <openssl/crypto.h>
- #include <openssl/x509.h>
- #include <openssl/pem.h>
- #include <openssl/ssl.h>
- #include <openssl/err.h>
-+#endif
-+
- #include <unistd.h>
-
- #define MAX_MESSAGE_LENGTH 8192
---
-1.7.0.4
-
-
-______________________________________________________________________________
-Member info: https://lists.balabit.hu/mailman/listinfo/syslog-ng
-Documentation: http://www.balabit.com/support/documentation/?product=syslog-ng
-FAQ: http://www.balabit.com/wiki/syslog-ng-faq
-
-
diff --git a/app-admin/syslog-ng/files/syslog-ng-3.3.4-compile.patch b/app-admin/syslog-ng/files/syslog-ng-3.3.4-compile.patch
new file mode 100644
index 000000000000..a2ad347722d2
--- /dev/null
+++ b/app-admin/syslog-ng/files/syslog-ng-3.3.4-compile.patch
@@ -0,0 +1,10 @@
+--- ./lib/scratch-buffers.c.orig 2012-01-20 17:44:43.871103296 -0500
++++ ./lib/scratch-buffers.c 2012-01-20 17:44:56.313552034 -0500
+@@ -24,6 +24,7 @@
+
+ #include "tls-support.h"
+ #include "scratch-buffers.h"
++#include "misc.h"
+
+ TLS_BLOCK_START
+ {
diff --git a/app-admin/syslog-ng/syslog-ng-3.3.1.ebuild b/app-admin/syslog-ng/syslog-ng-3.3.1.ebuild
deleted file mode 100644
index 8d03f849601a..000000000000
--- a/app-admin/syslog-ng/syslog-ng-3.3.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/syslog-ng-3.3.1.ebuild,v 1.6 2011/11/09 17:36:10 mr_bones_ Exp $
-
-EAPI=2
-inherit autotools fixheadtails eutils multilib
-
-MY_PV=${PV/_/}
-DESCRIPTION="syslog replacement with advanced filtering features"
-HOMEPAGE="http://www.balabit.com/products/syslog_ng/"
-SRC_URI="http://www.balabit.com/downloads/files/syslog-ng/sources/${MY_PV}/source/syslog-ng_${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="caps hardened ipv6 json mongodb +pcre selinux spoof-source sql ssl static tcpd"
-RESTRICT="test"
-
-LIBS_DEPEND="
- spoof-source? ( net-libs/libnet )
- ssl? ( dev-libs/openssl )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- !static? ( >=dev-libs/eventlog-0.2.12 )
- >=dev-libs/glib-2.10.1:2
- json? ( >=dev-libs/json-glib-0.12 )
- caps? ( sys-libs/libcap )
- sql? ( >=dev-db/libdbi-0.8.3 )"
-RDEPEND="
- !static? (
- pcre? ( dev-libs/libpcre )
- ${LIBS_DEPEND}
- )"
-DEPEND="${RDEPEND}
- ${LIBS_DEPEND}
- static? ( >=dev-libs/eventlog-0.2.12[static-libs] )
- dev-util/pkgconfig
- sys-devel/flex"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-ssl.patch \
- "${FILESDIR}"/${P}-filter.patch
- ht_fix_file configure.in
- eautoreconf
-}
-
-src_configure() {
- local myconf
-
- if use static ; then
- myconf="${myconf} --enable-static-linking"
- else
- myconf="${myconf} --enable-dynamic-linking"
- fi
- econf \
- --disable-dependency-tracking \
- --disable-systemd \
- --with-ivykis=internal \
- --sysconfdir=/etc/syslog-ng \
- --localstatedir=/var/lib/misc \
- --with-pidfile-dir=/var/run \
- --with-module-dir=/usr/$(get_libdir)/syslog-ng \
- $(use_enable caps linux-caps) \
- $(use_enable ipv6) \
- $(use_enable json) \
- $(use_with json json-glib) \
- $(use_enable mongodb) \
- $(use_enable pcre) \
- $(use_enable spoof-source) \
- $(use_enable sql) \
- $(use_enable ssl) \
- $(use_enable tcpd tcp-wrapper) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS \
- contrib/syslog-ng.conf* \
- contrib/syslog2ng "${FILESDIR}/syslog-ng.conf."*
-
- # Install default configuration
- insinto /etc/syslog-ng
- if use hardened || use selinux ; then
- newins "${FILESDIR}/syslog-ng.conf.gentoo.hardened.${PV%.*}" syslog-ng.conf || die
- elif use userland_BSD ; then
- newins "${FILESDIR}/syslog-ng.conf.gentoo.fbsd.${PV%.*}" syslog-ng.conf || die
- else
- newins "${FILESDIR}/syslog-ng.conf.gentoo.${PV%.*}" syslog-ng.conf || die
- fi
-
- insinto /etc/logrotate.d
- # Install snippet for logrotate, which may or may not be installed
- if use hardened || use selinux ; then
- newins "${FILESDIR}/syslog-ng.logrotate.hardened" syslog-ng || die
- else
- newins "${FILESDIR}/syslog-ng.logrotate" syslog-ng || die
- fi
-
- newinitd "${FILESDIR}/syslog-ng.rc6.${PV%.*}" syslog-ng || die
- newconfd "${FILESDIR}/syslog-ng.confd" syslog-ng || die
- keepdir /etc/syslog-ng/patterndb.d
- find "${D}" -type f -name '*.la' -exec rm {} + || die
- rmdir "${D}"/usr/libexec
-}
-
-pkg_postinst() {
- elog "For detailed documentation please see the upstream website:"
- elog "http://www.balabit.com/sites/default/files/documents/syslog-ng-ose-3.3-guides/syslog-ng-ose-v3.3-guide-admin-en.html/index.html"
-
- # bug #355257
- if ! has_version app-admin/logrotate ; then
- echo
- elog "It is highly recommended that app-admin/logrotate be emerged to"
- elog "manage the log files. ${PN} installs a file in /etc/logrotate.d"
- elog "for logrotate to use."
- echo
- fi
-}
diff --git a/app-admin/syslog-ng/syslog-ng-3.3.3.ebuild b/app-admin/syslog-ng/syslog-ng-3.3.4.ebuild
index 4713232f576a..ead900010186 100644
--- a/app-admin/syslog-ng/syslog-ng-3.3.3.ebuild
+++ b/app-admin/syslog-ng/syslog-ng-3.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/syslog-ng-3.3.3.ebuild,v 1.1 2011/11/28 21:24:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/syslog-ng-3.3.4.ebuild,v 1.1 2012/01/21 21:51:52 mr_bones_ Exp $
EAPI=2
-inherit autotools fixheadtails eutils multilib
+inherit autotools eutils multilib
MY_PV=${PV/_/}
DESCRIPTION="syslog replacement with advanced filtering features"
@@ -39,7 +39,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-${MY_PV}
src_prepare() {
- ht_fix_file configure.in
+ epatch "${FILESDIR}"/${P}-compile.patch
eautoreconf
}