summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-11-27 07:20:03 +0000
committerDonny Davies <woodchip@gentoo.org>2001-11-27 07:20:03 +0000
commitd32ef69a7120115df1c8754a528af354f541f56a (patch)
tree012c1fcdb25c3e619e897f26bc8a5345b5190d7c /app-admin
parentadded header (diff)
downloadgentoo-2-d32ef69a7120115df1c8754a528af354f541f56a.tar.gz
gentoo-2-d32ef69a7120115df1c8754a528af354f541f56a.tar.bz2
gentoo-2-d32ef69a7120115df1c8754a528af354f541f56a.zip
Update to latest release version available: fcron-2.0.0. See CHANGES
for details. I added a patch to eliminate the nasty /etc check in ./configure. Also made sure all the manpages get installed.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/fcron/fcron-2.0.0.ebuild59
-rw-r--r--app-admin/fcron/files/digest-fcron-2.0.01
-rw-r--r--app-admin/fcron/files/fcron-2.0.0-gentoo.diff22
-rw-r--r--app-admin/fcron/files/fcron.rc626
4 files changed, 95 insertions, 13 deletions
diff --git a/app-admin/fcron/fcron-2.0.0.ebuild b/app-admin/fcron/fcron-2.0.0.ebuild
new file mode 100644
index 000000000000..a84255c74919
--- /dev/null
+++ b/app-admin/fcron/fcron-2.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry A! <jerry@gentoo.org>, Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fcron/fcron-2.0.0.ebuild,v 1.1 2001/11/27 07:20:03 woodchip Exp $
+
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://fcron.free.fr/${P}.src.tar.gz"
+
+DEPEND="virtual/glibc virtual/mta"
+
+src_unpack() {
+
+ unpack ${A} ; cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die "bad patchfile"
+ autoconf || die "autoconf problem"
+}
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --with-username=cron \
+ --with-groupname=cron \
+ --with-piddir=/var/run \
+ --with-etcdir=/etc/fcron \
+ --with-spooldir=/var/spool/fcron \
+ --with-sendmail=/usr/sbin/sendmail \
+ --with-cflags="${CFLAGS}" --host=${CHOST} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ diropts -m 755 -o root -g root ; dodir /var/spool
+ diropts -m 770 -o cron -g cron ; dodir /var/spool/fcron
+
+ insinto /usr/sbin
+ insopts -o root -g root -m 0110 ; doins fcron
+
+ insinto /usr/bin
+ insopts -o cron -g cron -m 6111 ; doins fcrontab
+ insopts -o root -g root -m 6111 ; doins fcronsighup
+
+ doman doc/*.{1,3,5,8}
+
+ dodoc MANIFEST VERSION doc/{CHANGES,README,LICENSE,FAQ,INSTALL,THANKS}
+ docinto html ; dodoc doc/*.html
+ newdoc files/fcron.conf fcron.conf.sample
+
+ insinto /etc/fcron
+ insopts -m 640 -o root -g cron ; doins files/{fcron.allow,fcron.deny}
+ newins files/fcron.conf fcron.conf.sample
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/fcron.rc6 fcron
+}
diff --git a/app-admin/fcron/files/digest-fcron-2.0.0 b/app-admin/fcron/files/digest-fcron-2.0.0
new file mode 100644
index 000000000000..9e67f7d7dcdd
--- /dev/null
+++ b/app-admin/fcron/files/digest-fcron-2.0.0
@@ -0,0 +1 @@
+MD5 b20c6bc5d9435a790e5500ecb7990df8 fcron-2.0.0.src.tar.gz 147456
diff --git a/app-admin/fcron/files/fcron-2.0.0-gentoo.diff b/app-admin/fcron/files/fcron-2.0.0-gentoo.diff
new file mode 100644
index 000000000000..aa6c0362f6e1
--- /dev/null
+++ b/app-admin/fcron/files/fcron-2.0.0-gentoo.diff
@@ -0,0 +1,22 @@
+--- configure.in.orig Sun Jul 8 07:32:17 2001
++++ configure.in Sat Aug 25 14:36:05 2001
+@@ -201,13 +201,13 @@
+ fi
+ ;;
+ *)
+- if test -d "$withval"; then
++# if test -d "$withval"; then
+ etcdir="$withval"
+- AC_MSG_RESULT($withval)
+- else
+- AC_MSG_ERROR([
+-Directory $withval does not exist])
+- fi
++# AC_MSG_RESULT($withval)
++# else
++# AC_MSG_ERROR([
++#Directory $withval does not exist])
++# fi
+ ;;
+ esac ],
+ if test -d "/etc"; then
diff --git a/app-admin/fcron/files/fcron.rc6 b/app-admin/fcron/files/fcron.rc6
index a273efc054e9..5a735375df18 100644
--- a/app-admin/fcron/files/fcron.rc6
+++ b/app-admin/fcron/files/fcron.rc6
@@ -1,26 +1,26 @@
#!/sbin/runscript
depend() {
- need clock
+ need clock
}
checkconfig() {
- if [ ! -e /etc/fcron/fcron.conf ] ; then
- eerror "You will need an /etc/fcron/fcron.conf first"
- eerror "There is a sample in /usr/share/doc/fcron"
- return 1
- fi
+ if [ ! -e /etc/fcron/fcron.conf ] ; then
+ eerror "You will need an /etc/fcron/fcron.conf first"
+ eerror "There is a sample in /usr/share/doc/fcron"
+ return 1
+ fi
}
start() {
- checkconfig || return 1
- ebegin "Starting fcron"
- start-stop-daemon --start --quiet --exec /usr/sbin/fcron
- eend $?
+ checkconfig || return 1
+ ebegin "Starting fcron"
+ start-stop-daemon --start --quiet --exec /usr/sbin/fcron
+ eend $?
}
stop() {
- ebegin "Stopping fcron"
- start-stop-daemon --stop --quiet --pidfile /var/run/fcron.pid
- eend $?
+ ebegin "Stopping fcron"
+ start-stop-daemon --stop --quiet --pidfile /var/run/fcron.pid
+ eend $?
}