summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-07-23 22:53:12 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-07-23 22:53:12 +0000
commite0420761fb378e5349f92c8815d0f56bca5f1279 (patch)
treecbb6c7a8199122221243e4acbb993f7a627c8f52 /app-admin
parentsigning, also, previous commit fixed bug 555624 (diff)
downloadgentoo-2-e0420761fb378e5349f92c8815d0f56bca5f1279.tar.gz
gentoo-2-e0420761fb378e5349f92c8815d0f56bca5f1279.tar.bz2
gentoo-2-e0420761fb378e5349f92c8815d0f56bca5f1279.zip
bup
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/ChangeLog8
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.2.2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/app-admin/puppet-agent/ChangeLog b/app-admin/puppet-agent/ChangeLog
index 2c2b96d90c77..a2099fa5f1d3 100644
--- a/app-admin/puppet-agent/ChangeLog
+++ b/app-admin/puppet-agent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/puppet-agent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet-agent/ChangeLog,v 1.6 2015/07/20 04:51:23 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet-agent/ChangeLog,v 1.7 2015/07/23 22:53:12 prometheanfire Exp $
+
+*puppet-agent-1.2.2 (23 Jul 2015)
+
+ 23 Jul 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +puppet-agent-1.2.2.ebuild:
+ bup
20 Jul 2015; Matthew Thode <prometheanfire@gentoo.org> metadata.xml,
puppet-agent-1.2.1.ebuild:
diff --git a/app-admin/puppet-agent/puppet-agent-1.2.2.ebuild b/app-admin/puppet-agent/puppet-agent-1.2.2.ebuild
new file mode 100644
index 000000000000..4afefc7beaa8
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.2.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet-agent/puppet-agent-1.2.2.ebuild,v 1.1 2015/07/23 22:53:12 prometheanfire Exp $
+
+EAPI=5
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb"
+RESTRICT="strip"
+
+DEPEND="
+ ${DEPEND}
+ !app-admin/puppet
+ !app-admin/mcollective
+ !dev-ruby/hiera
+ !dev-ruby/facter"
+RDEPEND="puppetdb? ( >=dev-ruby/puppetdb-termini-3.0.1-r2 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+}