summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-10 08:25:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-10 08:25:08 +0000
commitb886701c89b33ca5fcaa79ab566c720d8692d32b (patch)
tree7b0f264305c56e741a3a824daaf985e64d271358 /app-arch/afio
parentversion bump (diff)
downloadgentoo-2-b886701c89b33ca5fcaa79ab566c720d8692d32b.tar.gz
gentoo-2-b886701c89b33ca5fcaa79ab566c720d8692d32b.tar.bz2
gentoo-2-b886701c89b33ca5fcaa79ab566c720d8692d32b.zip
add eutils for epatch; add patch for Makefile for bug 33094; more error checking/messages; tidy
Diffstat (limited to 'app-arch/afio')
-rw-r--r--app-arch/afio/ChangeLog5
-rw-r--r--app-arch/afio/Manifest5
-rw-r--r--app-arch/afio/afio-2.4.7.ebuild24
-rw-r--r--app-arch/afio/files/Makefile.patch25
4 files changed, 49 insertions, 10 deletions
diff --git a/app-arch/afio/ChangeLog b/app-arch/afio/ChangeLog
index a0043105a895..ef01a632ddc9 100644
--- a/app-arch/afio/ChangeLog
+++ b/app-arch/afio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/afio
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+ 10 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> afio-2.4.7.ebuild,
+ files/Makefile.patch:
+ add eutils for epatch; add patch for Makefile for bug 33094; more error
+ checking/messages; tidy
+
*afio-2.4.7 (26 May 2002)
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/app-arch/afio/Manifest b/app-arch/afio/Manifest
index 0e228ea5e24b..aea0f35087e5 100644
--- a/app-arch/afio/Manifest
+++ b/app-arch/afio/Manifest
@@ -1,3 +1,4 @@
-MD5 1f0fa762842691cfba9385dc70218550 ChangeLog 435
-MD5 8a77e1a5df6669accfdf436ff774931b afio-2.4.7.ebuild 772
+MD5 d41869ee204cd60cec8c7d902160c5c1 ChangeLog 634
+MD5 8c54c70af0f4db607b2e04fd1417d935 afio-2.4.7.ebuild 1047
+MD5 f66820d09ee18bc1250763fa4f3cdfd5 files/Makefile.patch 350
MD5 220e2947e5808d60df6546914dee1d07 files/digest-afio-2.4.7 58
diff --git a/app-arch/afio/afio-2.4.7.ebuild b/app-arch/afio/afio-2.4.7.ebuild
index edc5433af8f6..37ffcb80c8e7 100644
--- a/app-arch/afio/afio-2.4.7.ebuild
+++ b/app-arch/afio/afio-2.4.7.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/afio/afio-2.4.7.ebuild,v 1.14 2003/02/13 05:52:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/afio/afio-2.4.7.ebuild,v 1.15 2003/11/10 08:25:06 mr_bones_ Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="makes cpio-format archives and deals somewhat gracefully with input data corruption."
SRC_URI="http://www.ibiblio.org/pub/linux/system/backup/${P}.tgz"
HOMEPAGE="http://freshmeat.net/projects/afio/"
@@ -13,17 +14,24 @@ KEYWORDS="x86 ppc sparc "
DEPEND="sys-apps/gzip"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/Makefile.patch
+}
+
src_compile() {
- emake || die
+ emake CFLAGS1="${CFLAGS}" || die "emake failed"
}
src_install() {
- dobin afio
- dodoc README SCRIPTS HISTORY INSTALLATION PORTING
+ local i
+
+ dobin afio || die "dobin failed"
+ dodoc README SCRIPTS HISTORY INSTALLATION || die "dodoc failed"
for i in 1 2 3 4 5 ; do
insinto /usr/share/doc/${P}/script$i
- doins script$i/*
+ doins script$i/* || die "doins failed (${i})"
done
- #prepalldocs
- doman afio.1
+ doman afio.1 || die "doman failed"
}
diff --git a/app-arch/afio/files/Makefile.patch b/app-arch/afio/files/Makefile.patch
new file mode 100644
index 000000000000..537c29939fa2
--- /dev/null
+++ b/app-arch/afio/files/Makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile.orig 2003-11-10 00:11:50.000000000 -0800
++++ Makefile 2003-11-10 00:13:47.000000000 -0800
+@@ -1,4 +1,22 @@
+ SHELL=/bin/sh
++1=
++2=
++3=
++4=
++5=
++6=
++7=
++8=
++9=
++a=
++b=
++c=
++d=
++e=
++f=
++g=
++M=
++I=
+ ##
+ ## I wrote this Makefile, based on comments in the source. -rich $alz.
+ ## Define INDEX to use index() in place of strchr() (v7, BSD).