summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-06-17 13:19:57 +0000
committerSven Wegener <swegener@gentoo.org>2007-06-17 13:19:57 +0000
commita554ac8e89c3c7716a7b338986bb7a311da28c25 (patch)
tree72d06c9f4f4d4021a04986fc5cc785741f444c77 /app-arch/cfv/cfv-1.18.1.ebuild
parentStable on amd64 wrt bug 181721 (diff)
downloadgentoo-2-a554ac8e89c3c7716a7b338986bb7a311da28c25.tar.gz
gentoo-2-a554ac8e89c3c7716a7b338986bb7a311da28c25.tar.bz2
gentoo-2-a554ac8e89c3c7716a7b338986bb7a311da28c25.zip
Add a patch to make cfv work with bittorrent-5. Thanks to Kalidarn in bug #169228.
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'app-arch/cfv/cfv-1.18.1.ebuild')
-rw-r--r--app-arch/cfv/cfv-1.18.1.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/app-arch/cfv/cfv-1.18.1.ebuild b/app-arch/cfv/cfv-1.18.1.ebuild
index f5f237ef279e..b1505acd381b 100644
--- a/app-arch/cfv/cfv-1.18.1.ebuild
+++ b/app-arch/cfv/cfv-1.18.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.1.ebuild,v 1.7 2006/11/27 22:28:24 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cfv/cfv-1.18.1.ebuild,v 1.8 2007/06/17 13:19:57 swegener Exp $
+
+inherit eutils
DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
HOMEPAGE="http://cfv.sourceforge.net/"
@@ -15,6 +17,17 @@ DEPEND=""
RDEPEND="dev-lang/python
dev-python/python-fchksum"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-modulefix.patch
+}
+
+src_compile() {
+ true
+}
+
src_install() {
dobin cfv || die "dobin failed"
doman cfv.1 || die "doman failed"