summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:38:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-23 02:38:38 +0000
commitcbc32961656c456be7dcc259f7d437f0ec5004a4 (patch)
treee20beed790af679df3d55e4c88f4d52b0da5c3ab /app-arch/funzix/funzix-1.0.ebuild
parentRespect CFLAGS, LDFLAGS and CC. (diff)
downloadgentoo-2-cbc32961656c456be7dcc259f7d437f0ec5004a4.tar.gz
gentoo-2-cbc32961656c456be7dcc259f7d437f0ec5004a4.tar.bz2
gentoo-2-cbc32961656c456be7dcc259f7d437f0ec5004a4.zip
Respect CC.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-arch/funzix/funzix-1.0.ebuild')
-rw-r--r--app-arch/funzix/funzix-1.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-arch/funzix/funzix-1.0.ebuild b/app-arch/funzix/funzix-1.0.ebuild
index a29c115fed4b..29dc2b29d89f 100644
--- a/app-arch/funzix/funzix-1.0.ebuild
+++ b/app-arch/funzix/funzix-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/funzix/funzix-1.0.ebuild,v 1.3 2008/04/20 06:07:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/funzix/funzix-1.0.ebuild,v 1.4 2008/10/23 02:38:38 flameeyes Exp $
+
+inherit toolchain-funcs
DESCRIPTION="unpacker for the bogus ZIX format"
HOMEPAGE="http://funzix.sourceforge.net/"
@@ -11,6 +13,10 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
src_install() {
dobin funzix || die
dodoc README