summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-16 02:30:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-16 02:30:36 +0000
commit93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4 (patch)
tree74bbe5c94c70ad4ba2678b6cea7624213f05a47f /app-arch/gzip-x86
parentuse toolchain-funcs eclass not gcc (diff)
downloadgentoo-2-93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4.tar.gz
gentoo-2-93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4.tar.bz2
gentoo-2-93a0c5d5dcfb36a1fb96e9a0daa938216b9771f4.zip
dont use gcc eclass
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-arch/gzip-x86')
-rw-r--r--app-arch/gzip-x86/files/digest-gzip-x86-0.901
-rw-r--r--app-arch/gzip-x86/gzip-x86-0.90.ebuild21
-rw-r--r--app-arch/gzip-x86/gzip-x86-0.91.ebuild12
3 files changed, 6 insertions, 28 deletions
diff --git a/app-arch/gzip-x86/files/digest-gzip-x86-0.90 b/app-arch/gzip-x86/files/digest-gzip-x86-0.90
deleted file mode 100644
index d7827dad29de..000000000000
--- a/app-arch/gzip-x86/files/digest-gzip-x86-0.90
+++ /dev/null
@@ -1 +0,0 @@
-MD5 518fb583a96c335f5bd5a94675a15eeb gzip_x86-0.90.tgz 333860
diff --git a/app-arch/gzip-x86/gzip-x86-0.90.ebuild b/app-arch/gzip-x86/gzip-x86-0.90.ebuild
deleted file mode 100644
index 8be759fcc530..000000000000
--- a/app-arch/gzip-x86/gzip-x86-0.90.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip-x86/gzip-x86-0.90.ebuild,v 1.6 2005/01/01 11:46:02 eradicator Exp $
-
-MY_P=${PN/-/_}-${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="gzip_x86 is an optimized gzip for x86 arch"
-HOMEPAGE="ftp://spruce.he.net/pub/jreiser"
-SRC_URI="ftp://spruce.he.net/pub/jreiser/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* x86 amd64"
-IUSE=""
-
-DEPEND="virtual/libc"
-PROVIDE="virtual/gzip"
-
-src_install() {
- make DESTDIR=${D} install || die
-}
diff --git a/app-arch/gzip-x86/gzip-x86-0.91.ebuild b/app-arch/gzip-x86/gzip-x86-0.91.ebuild
index b2047cd34dc0..5588e1521856 100644
--- a/app-arch/gzip-x86/gzip-x86-0.91.ebuild
+++ b/app-arch/gzip-x86/gzip-x86-0.91.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip-x86/gzip-x86-0.91.ebuild,v 1.2 2005/01/01 11:46:02 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip-x86/gzip-x86-0.91.ebuild,v 1.3 2005/05/16 02:26:51 vapier Exp $
-inherit gcc
+inherit toolchain-funcs
MY_P=${PN/-/_}-${PV}
S=${WORKDIR}/${MY_P}
@@ -12,10 +12,10 @@ SRC_URI="http://www.BitWagon.com/ftp/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~x86 ~amd64"
+KEYWORDS="-* amd64 x86"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
PROVIDE="virtual/gzip"
src_unpack() {
@@ -27,10 +27,10 @@ src_unpack() {
src_compile() {
econf --bindir=/bin || die
- emake CCAS="$(gcc-getCC)" || die
+ emake CCAS="$(tc-getCC)" || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
}