summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-27 09:48:28 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-27 09:48:28 +0000
commit56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33 (patch)
tree6851ba68b28390d394e5cd42105b934e37947b15 /app-arch/lbzip2
parentFix tests, bug 288689 (diff)
downloadgentoo-2-56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33.tar.gz
gentoo-2-56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33.tar.bz2
gentoo-2-56b5e97ef6f0ae413f0d42a02756a1ef76c9bf33.zip
Add support for symlink decompression #309683
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/ChangeLog8
-rw-r--r--app-arch/lbzip2/files/0.23-s_isreg.patch11
-rw-r--r--app-arch/lbzip2/lbzip2-0.20.ebuild5
-rw-r--r--app-arch/lbzip2/lbzip2-0.22.ebuild5
-rw-r--r--app-arch/lbzip2/lbzip2-0.23-r1.ebuild58
-rw-r--r--app-arch/lbzip2/lbzip2-0.23.ebuild5
6 files changed, 82 insertions, 10 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index b242d93c7a22..337d4a4195fc 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.4 2010/03/04 07:17:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.5 2010/03/27 09:48:27 jlec Exp $
+
+*lbzip2-0.23-r1 (27 Mar 2010)
+
+ 27 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/0.23-s_isreg.patch, +lbzip2-0.23-r1.ebuild:
+ Add support for symlink decompression #309683
*lbzip2-0.23 (04 Mar 2010)
diff --git a/app-arch/lbzip2/files/0.23-s_isreg.patch b/app-arch/lbzip2/files/0.23-s_isreg.patch
new file mode 100644
index 000000000000..aab683244d73
--- /dev/null
+++ b/app-arch/lbzip2/files/0.23-s_isreg.patch
@@ -0,0 +1,11 @@
+--- main.c.orig 2010-03-03 02:12:45.000000000 +0100
++++ main.c 2010-03-15 10:20:19.562892780 +0100
+@@ -1252,7 +1252,7 @@
+ return -1;
+ }
+
+- if (!S_ISREG(sbuf->st_mode)) {
++ if (!decompress && !S_ISREG(sbuf->st_mode)) {
+ log_warning("%s: skipping \"%s\": not a regular file\n", pname,
+ operand->val);
+ return -1;
diff --git a/app-arch/lbzip2/lbzip2-0.20.ebuild b/app-arch/lbzip2/lbzip2-0.20.ebuild
index 3c58a84ba727..84692a073e83 100644
--- a/app-arch/lbzip2/lbzip2-0.20.ebuild
+++ b/app-arch/lbzip2/lbzip2-0.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.20.ebuild,v 1.1 2010/02/09 20:19:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.20.ebuild,v 1.2 2010/03/27 09:48:27 jlec Exp $
EAPI="3"
@@ -52,7 +52,6 @@ src_install() {
doins corr-perf.sh malloc_trace.pl || die
if use symlink; then
- dosym /usr/bin/${PN} /usr/bin/gzip || die
- dosym /usr/bin/un${PN} /usr/bin/gunzip || die
+ dosym ${PN} /usr/bin/bzip2 || die
fi
}
diff --git a/app-arch/lbzip2/lbzip2-0.22.ebuild b/app-arch/lbzip2/lbzip2-0.22.ebuild
index 760ea05634e5..c10b81905fc5 100644
--- a/app-arch/lbzip2/lbzip2-0.22.ebuild
+++ b/app-arch/lbzip2/lbzip2-0.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.22.ebuild,v 1.1 2010/02/19 09:20:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.22.ebuild,v 1.2 2010/03/27 09:48:27 jlec Exp $
EAPI="3"
@@ -52,7 +52,6 @@ src_install() {
doins corr-perf.sh malloc_trace.pl || die
if use symlink; then
- dosym ${PN} /usr/bin/gzip || die
- dosym un${PN} /usr/bin/gunzip || die
+ dosym ${PN} /usr/bin/bzip2 || die
fi
}
diff --git a/app-arch/lbzip2/lbzip2-0.23-r1.ebuild b/app-arch/lbzip2/lbzip2-0.23-r1.ebuild
new file mode 100644
index 000000000000..10d65dcb8c88
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-0.23-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23-r1.ebuild,v 1.1 2010/03/27 09:48:27 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Pthreads-based parallel bzip2/bunzip2 filter, passable to GNU tar"
+HOMEPAGE="http://lacos.hu/"
+SRC_URI="http://lacos.web.elte.hu/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink test"
+
+RDEPEND="app-arch/bzip2"
+DEPEND="${REDEPEND}
+ test? (
+ app-shells/dash
+ sys-process/time
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-s_isreg.patch
+ epatch "${FILESDIR}"/0.22-Makefile.patch
+}
+
+src_compile() {
+ append-lfs-flags
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_test() {
+ if [ -t 0 ] || return; then
+ rm -rf "${T}/scratch" "${T}/results" "${T}/rnd"
+ hexdump -n 10485760 /dev/urandom > "${T}/rnd"
+ emake -j1 SHELL="${EPREFIX}"/bin/dash PATH="${S}:${PATH}" TESTFILE="${T}/rnd" check \
+ || die "make check failed"
+ else
+ ewarn "make check must be run attached to a terminal"
+ fi
+}
+
+src_install() {
+ dobin ${PN} || die "Installation of ${PN} failed"
+ dodoc ChangeLog README || die "no docs"
+ doman ${PN}.1 || die "no man"
+ insinto /usr/share/${PN}
+ doins corr-perf.sh malloc_trace.pl || die
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2 || die
+ fi
+}
diff --git a/app-arch/lbzip2/lbzip2-0.23.ebuild b/app-arch/lbzip2/lbzip2-0.23.ebuild
index 780508098233..984a29253bf7 100644
--- a/app-arch/lbzip2/lbzip2-0.23.ebuild
+++ b/app-arch/lbzip2/lbzip2-0.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23.ebuild,v 1.1 2010/03/04 07:17:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23.ebuild,v 1.2 2010/03/27 09:48:27 jlec Exp $
EAPI="3"
@@ -53,7 +53,6 @@ src_install() {
doins corr-perf.sh malloc_trace.pl || die
if use symlink; then
- dosym ${PN} /usr/bin/gzip || die
- dosym un${PN} /usr/bin/gunzip || die
+ dosym ${PN} /usr/bin/bzip2 || die
fi
}