summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-26 21:44:56 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-26 21:44:56 +0000
commit28dc2e194e15929cab302b9965b55cda6f79b908 (patch)
tree3392393ed3dbb4d0894ecc7904d515d9f517883e /app-arch/rzip/files
parentApply patch from upstream which fixes compilation with -dbus. Bug #334533 (diff)
downloadgentoo-2-28dc2e194e15929cab302b9965b55cda6f79b908.tar.gz
gentoo-2-28dc2e194e15929cab302b9965b55cda6f79b908.tar.bz2
gentoo-2-28dc2e194e15929cab302b9965b55cda6f79b908.zip
Clean up patch. Respect LDFLAGS (bug #334589).
(Portage version: 2.2_rc69/cvs/Linux i686)
Diffstat (limited to 'app-arch/rzip/files')
-rw-r--r--app-arch/rzip/files/rzip-2.1-darwin.patch90
1 files changed, 44 insertions, 46 deletions
diff --git a/app-arch/rzip/files/rzip-2.1-darwin.patch b/app-arch/rzip/files/rzip-2.1-darwin.patch
index b62a1d404051..b07aa1712309 100644
--- a/app-arch/rzip/files/rzip-2.1-darwin.patch
+++ b/app-arch/rzip/files/rzip-2.1-darwin.patch
@@ -1,6 +1,5 @@
-diff -r -uN rzip-2.1/configure.in rzip-2.1-patched/configure.in
---- rzip-2.1/configure.in 2003-11-03 09:19:11.000000000 +0100
-+++ rzip-2.1-patched/configure.in 2008-07-27 21:59:45.774740303 +0200
+--- a/configure.in 2003-11-03 09:19:11.000000000 +0100
++++ b/configure.in 2008-07-27 21:59:45.774740303 +0200
@@ -2,6 +2,12 @@
AC_INIT(main.c)
AC_CONFIG_HEADER(config.h)
@@ -41,9 +40,8 @@ diff -r -uN rzip-2.1/configure.in rzip-2.1-patched/configure.in
+AC_CHECK_FUNCS(strndup)
AC_OUTPUT(Makefile)
-diff -r -uN rzip-2.1/main.c rzip-2.1-patched/main.c
---- rzip-2.1/main.c 2006-02-14 01:38:23.000000000 +0100
-+++ rzip-2.1-patched/main.c 2008-07-27 22:00:28.298071207 +0200
+--- a/main.c 2006-02-14 01:38:23.000000000 +0100
++++ b/main.c 2008-07-27 22:00:28.298071207 +0200
@@ -18,6 +18,7 @@
/* rzip compression - main program */
@@ -52,40 +50,8 @@ diff -r -uN rzip-2.1/main.c rzip-2.1-patched/main.c
static void usage(void)
{
-diff -r -uN rzip-2.1/Makefile.in rzip-2.1-patched/Makefile.in
---- rzip-2.1/Makefile.in 2006-02-14 01:38:23.000000000 +0100
-+++ rzip-2.1-patched/Makefile.in 2008-07-27 21:58:08.201419790 +0200
-@@ -3,8 +3,8 @@
-
- prefix=@prefix@
- exec_prefix=@exec_prefix@
--INSTALL_BIN=$(exec_prefix)/bin
--INSTALL_MAN=$(prefix)/man
-+INSTALL_BIN=$(DESTDIR)/@bindir@
-+INSTALL_MAN=$(DESTDIR)/@mandir@
-
- LIBS=@LIBS@
- CC=@CC@
-@@ -20,7 +20,7 @@
- .SUFFIXES:
- .SUFFIXES: .c .o
-
--OBJS= rzip.o runzip.o main.o stream.o util.o crc32.o
-+OBJS= rzip.o runzip.o strutils.o main.o stream.o util.o crc32.o
-
- # note that the -I. is needed to handle config.h when using VPATH
- .c.o:
-@@ -35,6 +35,7 @@
- ${INSTALLCMD} -m 755 rzip ${INSTALL_BIN}
- -mkdir -p ${INSTALL_MAN}/man1
- ${INSTALLCMD} -m 644 $(srcdir)/rzip.1 ${INSTALL_MAN}/man1/
-+ ln -s rzip $(INSTALL_BIN)/runzip
-
- rzip: $(OBJS)
- $(CC) $(CFLAGS) -o rzip $(OBJS) $(LIBS)
-diff -r -uN rzip-2.1/rzip.h rzip-2.1-patched/rzip.h
---- rzip-2.1/rzip.h 2006-02-14 01:38:23.000000000 +0100
-+++ rzip-2.1-patched/rzip.h 2008-07-27 21:58:08.204752617 +0200
+--- a/rzip.h 2006-02-14 01:38:23.000000000 +0100
++++ b/rzip.h 2008-07-27 21:58:08.204752617 +0200
@@ -94,7 +94,7 @@
#define strerror(i) sys_errlist[i]
#endif
@@ -95,9 +61,8 @@ diff -r -uN rzip-2.1/rzip.h rzip-2.1-patched/rzip.h
extern int errno;
#endif
-diff -r -uN rzip-2.1/strutils.c rzip-2.1-patched/strutils.c
---- rzip-2.1/strutils.c 1970-01-01 01:00:00.000000000 +0100
-+++ rzip-2.1-patched/strutils.c 2008-07-27 21:58:08.204752617 +0200
+--- a/strutils.c 1970-01-01 01:00:00.000000000 +0100
++++ b/strutils.c 2008-07-27 21:58:08.204752617 +0200
@@ -0,0 +1,29 @@
+/*
+ Copyright (C) 2005 Gentoo Foundation
@@ -128,9 +93,8 @@ diff -r -uN rzip-2.1/strutils.c rzip-2.1-patched/strutils.c
+ return(memcpy(ret, s, n));
+}
+#endif
-diff -r -uN rzip-2.1/strutils.h rzip-2.1-patched/strutils.h
---- rzip-2.1/strutils.h 1970-01-01 01:00:00.000000000 +0100
-+++ rzip-2.1-patched/strutils.h 2008-07-27 21:58:08.204752617 +0200
+--- a/strutils.h 1970-01-01 01:00:00.000000000 +0100
++++ b/strutils.h 2008-07-27 21:58:08.204752617 +0200
@@ -0,0 +1,31 @@
+/*
+ Copyright (C) 2005 Gentoo Foundation
@@ -163,3 +127,37 @@ diff -r -uN rzip-2.1/strutils.h rzip-2.1-patched/strutils.h
+# endif
+
+#endif
+--- a/Makefile.in 2006-02-14 01:38:23.000000000 +0100
++++ b/Makefile.in 2010-08-26 23:34:38.000000000 +0200
+@@ -3,8 +3,8 @@
+
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-INSTALL_BIN=$(exec_prefix)/bin
+-INSTALL_MAN=$(prefix)/man
++INSTALL_BIN=$(DESTDIR)/@bindir@
++INSTALL_MAN=$(DESTDIR)/@mandir@
+
+ LIBS=@LIBS@
+ CC=@CC@
+@@ -20,7 +20,7 @@
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+
+-OBJS= rzip.o runzip.o main.o stream.o util.o crc32.o
++OBJS= rzip.o runzip.o strutils.o main.o stream.o util.o crc32.o
+
+ # note that the -I. is needed to handle config.h when using VPATH
+ .c.o:
+@@ -35,9 +35,10 @@
+ ${INSTALLCMD} -m 755 rzip ${INSTALL_BIN}
+ -mkdir -p ${INSTALL_MAN}/man1
+ ${INSTALLCMD} -m 644 $(srcdir)/rzip.1 ${INSTALL_MAN}/man1/
++ ln -s rzip $(INSTALL_BIN)/runzip
+
+ rzip: $(OBJS)
+- $(CC) $(CFLAGS) -o rzip $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o rzip $(OBJS) $(LIBS)
+
+ rzip.1: rzip.yo
+ yodl2man -o rzip.1 rzip.yo