summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-09-12 18:47:06 +0000
committerPeter Volkov <pva@gentoo.org>2007-09-12 18:47:06 +0000
commitb85885ad9a9bda2ed822010f1e00c17eaf9792e7 (patch)
tree7cc82fbbe787db39ed2add3749f5fc765ed14cbd /app-arch/star
parentupdate entry for app-text/poppler (diff)
downloadgentoo-2-b85885ad9a9bda2ed822010f1e00c17eaf9792e7.tar.gz
gentoo-2-b85885ad9a9bda2ed822010f1e00c17eaf9792e7.tar.bz2
gentoo-2-b85885ad9a9bda2ed822010f1e00c17eaf9792e7.zip
Version bump, ebuild cleanups, fixes security bug #189690. Thank Robert Buchholz <rbu AT gentoo.org> for report.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-arch/star')
-rw-r--r--app-arch/star/ChangeLog9
-rw-r--r--app-arch/star/files/digest-star-1.5_alpha843
-rw-r--r--app-arch/star/files/star-1.5_alpha84-data-change-warn.patch31
-rw-r--r--app-arch/star/star-1.5_alpha84.ebuild82
4 files changed, 124 insertions, 1 deletions
diff --git a/app-arch/star/ChangeLog b/app-arch/star/ChangeLog
index b3388b6d93d0..ea547869e32f 100644
--- a/app-arch/star/ChangeLog
+++ b/app-arch/star/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/star
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/star/ChangeLog,v 1.44 2007/06/25 05:51:11 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/star/ChangeLog,v 1.45 2007/09/12 18:47:05 pva Exp $
+
+*star-1.5_alpha84 (12 Sep 2007)
+
+ 12 Sep 2007; <pva@gentoo.org>
+ +files/star-1.5_alpha84-data-change-warn.patch, +star-1.5_alpha84.ebuild:
+ Version bump, ebuild cleanups, fixes security bug #189690. Thank Robert
+ Buchholz <rbu AT gentoo.org> for report.
25 Jun 2007; Joshua Kinard <kumba@gentoo.org> star-1.5_alpha74.ebuild:
Stable on mips, per #146750.
diff --git a/app-arch/star/files/digest-star-1.5_alpha84 b/app-arch/star/files/digest-star-1.5_alpha84
new file mode 100644
index 000000000000..8ef1aa1a50cd
--- /dev/null
+++ b/app-arch/star/files/digest-star-1.5_alpha84
@@ -0,0 +1,3 @@
+MD5 7b3860592468e46396fe34157f338d42 star-1.5a84.tar.bz2 813262
+RMD160 fcb0679760e9f4f64f146ac1a41a28ca6175f8ef star-1.5a84.tar.bz2 813262
+SHA256 874555cb63475a0fc582480481a82be49b7685dd92885744f5032d16cc2ca53b star-1.5a84.tar.bz2 813262
diff --git a/app-arch/star/files/star-1.5_alpha84-data-change-warn.patch b/app-arch/star/files/star-1.5_alpha84-data-change-warn.patch
new file mode 100644
index 000000000000..d60fa06521a7
--- /dev/null
+++ b/app-arch/star/files/star-1.5_alpha84-data-change-warn.patch
@@ -0,0 +1,31 @@
+--- ./star/checkerr.c.orig 2007-09-12 14:22:33.000000000 +0400
++++ ./star/checkerr.c 2007-09-12 14:21:51.000000000 +0400
+@@ -188,13 +188,10 @@
+ {
+ register char *p = eflag;
+ char *ef = _endword(eflag);
+- char ec;
+ register struct eflags *ep;
+ register int slen;
+ register UInt32_t nflags = 0;
+
+- ec = *ef;
+- *ef = '\0';
+ do {
+ for (ep = eflags; ep->fname; ep++) {
+ slen = strlen(ep->fname);
+@@ -208,13 +205,11 @@
+ if (ep->fname == NULL) {
+ if (doexit)
+ comerrno(EX_BAD, "Bad flag '%s'\n", p);
+- *ef = ec; /* Restore old character */
+ return (0);
+ }
+ p = strchr(p, '|');
+- } while (p && *p++ == '|');
++ } while (p < ef && p && *p++ == '|');
+
+- *ef = ec; /* Restore old character */
+ if ((nflags & ~(UInt32_t)(E_ABORT|E_WARN)) == 0) {
+ if (doexit)
+ comerrno(EX_BAD, "Bad error condition '%s'.\n", eflag);
diff --git a/app-arch/star/star-1.5_alpha84.ebuild b/app-arch/star/star-1.5_alpha84.ebuild
new file mode 100644
index 000000000000..3a1827d0d69c
--- /dev/null
+++ b/app-arch/star/star-1.5_alpha84.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/star/star-1.5_alpha84.ebuild,v 1.1 2007/09/12 18:47:05 pva Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
+HOMEPAGE="http://cdrecord.berlios.de/old/private/star.html"
+SRC_URI="ftp://ftp.berlios.de/pub/${PN}/alpha/${PN}-${PV/_alpha/a}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+S="${WORKDIR}"/${P/_alpha[0-9][0-9]}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-data-change-warn.patch
+
+ cd "${S}"/DEFAULTS
+ sed -i \
+ -e 's:/opt/schily:/usr:g' \
+ -e 's:bin:root:g' \
+ -e 's:/usr/src/linux/include:/usr/include:' \
+ Defaults.linux
+
+ if use amd64 ; then
+ cd "${S}"/RULES
+ cp i386-linux-cc.rul x86_64-linux-cc.rul
+ cp i386-linux-gcc.rul x86_64-linux-gcc.rul
+ fi
+
+ if use ppc64 ; then
+ cd "${S}"/RULES
+ cp ppc-linux-cc.rul ppc64-linux-cc.rul
+ cp ppc-linux-gcc.rul ppc64-linux-gcc.rul
+ fi
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" COPTX="${CFLAGS}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die
+}
+
+src_install() {
+ # Joerg Schilling suggested to integrate star into the main OS using call:
+ # make INS_BASE=/usr DESTDIR="${D}" install
+
+ dobin star/OBJ/*-*-cc/star || die "dobin star failed"
+ dobin tartest/OBJ/*-*-cc/tartest || die "dobin tartest failed"
+ dobin star_sym/OBJ/*-*-cc/star_sym || die "dobin star_sym failed"
+ dobin mt/OBJ/*-*-cc/smt || die "dobin smt failed"
+
+ newsbin rmt/OBJ/*-*-cc/rmt rmt.star
+ newman rmt/rmt.1 rmt.star.1
+
+ # Note that we should never install gnutar, tar or rmt in this package.
+ # tar and rmt are provided by app-arch/tar. gnutar is not compatible with
+ # GNU tar and breakes compilation, or init scripts. bug #33119
+ dosym /usr/bin/{star,ustar}
+ dosym /usr/bin/{star,spax}
+ dosym /usr/bin/{star,scpio}
+ dosym /usr/bin/{star,suntar}
+
+ # match is needed to understand the pattern matcher, if you wondered why ;)
+ mv star/{star.4,star.5}
+ doman man/man1/match.1 tartest/tartest.1 \
+ star/{star.5,star.1,spax.1,scpio.1,suntar.1}
+
+ insinto /etc/default
+ newins star/star.dfl star
+ newins rmt/rmt.dfl rmt
+
+ dodoc star/{README.ACL,README.crash,README.largefiles,README.otherbugs} \
+ star/{README.pattern,README.pax,README.posix-2001,README,STARvsGNUTAR} \
+ rmt/default-rmt.sample TODO AN-* Changelog CONTRIBUTING
+}