summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-26 23:46:28 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-26 23:46:28 +0000
commit9134cae0c7358d94a11f8330d6931c2d60f9c7c8 (patch)
tree86b9cde72bdd7893ca335524a91ce5d63a8335e5 /app-arch/tar/tar-1.25-r1.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-9134cae0c7358d94a11f8330d6931c2d60f9c7c8.tar.gz
gentoo-2-9134cae0c7358d94a11f8330d6931c2d60f9c7c8.tar.bz2
gentoo-2-9134cae0c7358d94a11f8330d6931c2d60f9c7c8.zip
Add fixes from upstream for incremental #349164 by Robin Johnson and verify #349155 by Navid Zamani.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/tar/tar-1.25-r1.ebuild')
-rw-r--r--app-arch/tar/tar-1.25-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-arch/tar/tar-1.25-r1.ebuild b/app-arch/tar/tar-1.25-r1.ebuild
new file mode 100644
index 000000000000..51081271d51e
--- /dev/null
+++ b/app-arch/tar/tar-1.25-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.25-r1.ebuild,v 1.1 2010/12/26 23:46:28 vapier Exp $
+
+EAPI="3"
+
+inherit flag-o-matic
+
+DESCRIPTION="Use this to make tarballs :)"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="http://ftp.gnu.org/gnu/tar/${P}.tar.bz2
+ ftp://alpha.gnu.org/gnu/tar/${P}.tar.bz2
+ mirror://gnu/tar/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static userland_GNU"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-incremental-fix.patch #349164
+ epatch "${FILESDIR}"/${P}-verify-fix.patch #349155
+ epatch "${FILESDIR}"/${P}-verify-check.patch
+ if ! use userland_GNU ; then
+ sed -i \
+ -e 's:/backup\.sh:/gbackup.sh:' \
+ scripts/{backup,dump-remind,restore}.in \
+ || die "sed non-GNU"
+ fi
+}
+
+src_configure() {
+ local myconf
+ use static && append-ldflags -static
+ use userland_GNU || myconf="--program-prefix=g"
+ # Work around bug in sandbox #67051
+ gl_cv_func_chown_follows_symlink=yes \
+ FORCE_UNSAFE_CONFIGURE=1 \
+ econf \
+ --enable-backup-scripts \
+ --bindir="${EPREFIX}"/bin \
+ --libexecdir="${EPREFIX}"/usr/sbin \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ local p=""
+ use userland_GNU || p=g
+
+ emake DESTDIR="${D}" install || die
+
+ if [[ -z ${p} ]] ; then
+ # a nasty yet required piece of baggage
+ exeinto /etc
+ doexe "${FILESDIR}"/rmt || die
+ fi
+
+ # autoconf looks for gtar before tar (in configure scripts), hence
+ # in Prefix it is important that it is there, otherwise, a gtar from
+ # the host system (FreeBSD, Solaris, Darwin) will be found instead
+ # of the Prefix provided (GNU) tar
+ if use prefix ; then
+ dosym tar /bin/gtar
+ fi
+
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS
+ newman "${FILESDIR}"/tar.1 ${p}tar.1
+ mv "${ED}"/usr/sbin/${p}backup{,-tar}
+ mv "${ED}"/usr/sbin/${p}restore{,-tar}
+}