summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 07:37:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 07:37:07 +0000
commit9977fd2ce7f9fbfe175b645cae2586c6a0e87873 (patch)
treee2ef9793e3dee9c3843f06a6e1f10c93d5d4921c /app-arch/tar
parentcreate_global_tags patch to use a shebang for bug #46824 (Manifest recommit) (diff)
downloadgentoo-2-9977fd2ce7f9fbfe175b645cae2586c6a0e87873.tar.gz
gentoo-2-9977fd2ce7f9fbfe175b645cae2586c6a0e87873.tar.bz2
gentoo-2-9977fd2ce7f9fbfe175b645cae2586c6a0e87873.zip
don't assign default to S; "`use foo`" -> use foo
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/ChangeLog6
-rw-r--r--app-arch/tar/tar-1.13.25-r3.ebuild42
-rw-r--r--app-arch/tar/tar-1.13.92-r3.ebuild41
3 files changed, 40 insertions, 49 deletions
diff --git a/app-arch/tar/ChangeLog b/app-arch/tar/ChangeLog
index 6abae04673a7..8cde5aea8c8e 100644
--- a/app-arch/tar/ChangeLog
+++ b/app-arch/tar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/tar
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.8 2004/03/12 15:17:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.9 2004/04/10 07:37:07 mr_bones_ Exp $
+
+ 10 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> tar-1.13.25-r3.ebuild,
+ tar-1.13.92-r3.ebuild:
+ don't assign default to S; "`use foo`" -> use foo
12 Mar 2004; Daniel Ahlberg <aliz@gentoo.org> tar-1.13.92-r3.ebuild:
amd64 unmask.
diff --git a/app-arch/tar/tar-1.13.25-r3.ebuild b/app-arch/tar/tar-1.13.25-r3.ebuild
index 589160db76de..926a8a3899a8 100644
--- a/app-arch/tar/tar-1.13.25-r3.ebuild
+++ b/app-arch/tar/tar-1.13.25-r3.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.25-r3.ebuild,v 1.6 2004/02/17 08:43:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.25-r3.ebuild,v 1.7 2004/04/10 07:37:07 mr_bones_ Exp $
inherit eutils gnuconfig
-IUSE="nls static build"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Use this to try make tarballs :)"
HOMEPAGE="http://www.gnu.org/software/tar/"
SRC_URI="mirror://gentoo/${P}.tar.gz
mirror://gnu/tar/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 amd64 alpha mips hppa ppc ia64 sparc ppc64"
+IUSE="nls static build"
DEPEND="app-arch/gzip
app-arch/bzip2
@@ -25,46 +23,40 @@ RDEPEND="nls? ( >=sys-devel/gettext-0.10.35 )"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${PF}.gentoo.diff
-}
-
-src_compile() {
-
+ epatch "${FILESDIR}/${PF}.gentoo.diff"
# Fix configure scripts to support linux-mips targets
gnuconfig_update
+}
- local myconf
- [ -z "`use nls`" ] && myconf="--disable-nls"
+src_compile() {
econf \
--bindir=/bin \
--libexecdir=/usr/lib/misc \
- ${myconf} || die
+ $(use_enable nls) || die
- if [ -z "`use static`" ]
- then
- emake || die
+ if use static ; then
+ emake LDFLAGS=-static || die "emake failed"
else
- emake LDFLAGS=-static || die
+ emake || die "emake failed"
fi
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
#FHS 2.1 stuff
dodir /usr/sbin
- cd ${D}
+ cd "${D}"
mv usr/lib/misc/rmt usr/sbin/rmt.gnu
dosym rmt.gnu /usr/sbin/rmt
# a nasty yet required symlink:
dodir /etc
dosym /usr/sbin/rmt /etc/rmt
- cd ${S}
- if [ -z "`use build`" ]
- then
- dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
- doman ${FILESDIR}/tar.1
+ cd "${S}"
+ if use build ; then
+ rm -rf "${D}/usr/share"
else
- rm -rf ${D}/usr/share
+ dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
+ doman "${FILESDIR}/tar.1"
fi
}
diff --git a/app-arch/tar/tar-1.13.92-r3.ebuild b/app-arch/tar/tar-1.13.92-r3.ebuild
index ba65d57807c6..833ee965965b 100644
--- a/app-arch/tar/tar-1.13.92-r3.ebuild
+++ b/app-arch/tar/tar-1.13.92-r3.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.92-r3.ebuild,v 1.4 2004/03/12 15:17:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.92-r3.ebuild,v 1.5 2004/04/10 07:37:07 mr_bones_ Exp $
inherit eutils gnuconfig
-IUSE="nls static build"
-S="${WORKDIR}/${P}"
DESCRIPTION="Use this to try make tarballs :)"
HOMEPAGE="http://www.gnu.org/software/tar/"
SRC_URI="ftp://alpha.gnu.org/pub/pub/gnu/${PN}/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa amd64 ~ia64 ~ppc64 s390"
+IUSE="nls static build"
DEPEND="app-arch/gzip
app-arch/bzip2
@@ -26,45 +25,41 @@ src_unpack() {
cd ${S}
# Do not strip './' in path elements, as they are valid, bug #37132
- epatch ${FILESDIR}/${P}-dont-strip-dot_slash.patch
+ epatch "${FILESDIR}/${P}-dont-strip-dot_slash.patch"
# Fix -l, --one-file-system option to actually work.
- epatch ${FILESDIR}/${P}-fix-one_file_system.patch
-}
-
-src_compile() {
-
+ epatch "${FILESDIR}/${P}-fix-one_file_system.patch"
# Fix configure scripts to support linux-mips targets
gnuconfig_update
+}
+src_compile() {
econf \
--bindir=/bin \
--libexecdir=/usr/lib/misc \
- `use_enable nls` || die
+ $(use_enable nls) || die
- if [ -z "`use static`" ]
- then
- emake || die
+ if use static ; then
+ emake LDFLAGS=-static || die "emake failed"
else
- emake LDFLAGS=-static || die
+ emake || die "emake failed"
fi
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
#FHS 2.1 stuff
dodir /usr/sbin
- cd ${D}
+ cd "${D}"
mv usr/lib/misc/rmt usr/sbin/rmt.gnu
dosym rmt.gnu /usr/sbin/rmt
# a nasty yet required symlink:
dodir /etc
dosym /usr/sbin/rmt /etc/rmt
- cd ${S}
- if [ -z "`use build`" ]
- then
- dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
- doman ${FILESDIR}/tar.1
+ cd "${S}"
+ if use build ; then
+ rm -rf "${D}/usr/share"
else
- rm -rf ${D}/usr/share
+ dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
+ doman "${FILESDIR}/tar.1"
fi
}