summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-04 03:36:39 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-04 03:36:39 +0000
commit18726bc8de39ef1ed3f10ef3e7c69082f47a5fca (patch)
treec0850fadb1afcff7dd9ec0939c8a4d500186c424 /app-arch/tardy/tardy-1.24.ebuild
parentMarked ppc/ppc64 stable for bug #329693. (diff)
downloadgentoo-2-18726bc8de39ef1ed3f10ef3e7c69082f47a5fca.tar.gz
gentoo-2-18726bc8de39ef1ed3f10ef3e7c69082f47a5fca.tar.bz2
gentoo-2-18726bc8de39ef1ed3f10ef3e7c69082f47a5fca.zip
Version bump.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/tardy/tardy-1.24.ebuild')
-rw-r--r--app-arch/tardy/tardy-1.24.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/tardy/tardy-1.24.ebuild b/app-arch/tardy/tardy-1.24.ebuild
new file mode 100644
index 000000000000..48277e2cc89f
--- /dev/null
+++ b/app-arch/tardy/tardy-1.24.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tardy/tardy-1.24.ebuild,v 1.1 2011/10/04 03:36:39 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tar post-processor"
+HOMEPAGE="http://tardy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tardy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libexplain
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's/$(CXX) .* $(CXXFLAGS) -I./\0 -o $@/' \
+ -e '/mv \(.*\)\.o \(.*\)\/\1\.o/d' \
+ -e '/@sleep 1/d' \
+ -e 's#^\(install-man: $(mandir)/man1/tardy.1\).*#\1#' \
+ Makefile.in || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}