summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-27 07:39:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-27 07:39:52 +0000
commit14e2d3dfacf14ebd0572e890a311e41927638c66 (patch)
tree18a48f324647549fab58a562d68f6371f1c7539c /app-arch
parentmedia-sound/lastfm-desktop: Backport patch for missing cast, #494190 (diff)
downloadgentoo-2-14e2d3dfacf14ebd0572e890a311e41927638c66.tar.gz
gentoo-2-14e2d3dfacf14ebd0572e890a311e41927638c66.tar.bz2
gentoo-2-14e2d3dfacf14ebd0572e890a311e41927638c66.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unrar/ChangeLog7
-rw-r--r--app-arch/unrar/unrar-5.1.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-arch/unrar/ChangeLog b/app-arch/unrar/ChangeLog
index f391991cbb26..a74bd02112c7 100644
--- a/app-arch/unrar/ChangeLog
+++ b/app-arch/unrar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/unrar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.209 2014/02/08 07:03:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/ChangeLog,v 1.210 2014/03/27 07:39:52 ssuominen Exp $
+
+*unrar-5.1.1 (27 Mar 2014)
+
+ 27 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +unrar-5.1.1.ebuild:
+ Version bump.
*unrar-5.0.14 (08 Feb 2014)
diff --git a/app-arch/unrar/unrar-5.1.1.ebuild b/app-arch/unrar/unrar-5.1.1.ebuild
new file mode 100644
index 000000000000..d7f0fffe1b46
--- /dev/null
+++ b/app-arch/unrar/unrar-5.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-5.1.1.ebuild,v 1.1 2014/03/27 07:39:52 ssuominen Exp $
+
+EAPI=5
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_PN=${PN}src
+
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="http://www.rarlab.com/rar_add.htm"
+SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="!<=app-arch/unrar-gpl-0.0.1_p20080417"
+
+S=${WORKDIR}/unrar
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.2-build.patch
+ sed -i \
+ -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" \
+ -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" \
+ makefile || die
+}
+
+src_compile() {
+ unrar_make() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
+ }
+
+ unrar_make CXXFLAGS+=" -fPIC" lib
+ ln -s libunrar$(get_libname ${PV%.*.*}) libunrar$(get_libname)
+ ln -s libunrar$(get_libname ${PV%.*.*}) libunrar$(get_libname ${PV})
+
+ # The stupid code compiles a lot of objects differently if
+ # they're going into a lib (-DRARDLL) or into the main app.
+ # So for now, we can't link the main app against the lib.
+ unrar_make clean
+ unrar_make
+}
+
+src_install() {
+ dobin unrar
+ dodoc readme.txt
+
+ dolib.so libunrar*
+
+ insinto /usr/include/libunrar${PV%.*.*}
+ doins *.hpp
+ dosym libunrar${PV%.*.*} /usr/include/libunrar
+}