summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-04 23:19:48 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-04 23:19:48 +0000
commit4a58b94cee9474ec51d9ccee1b79b15c84fb9121 (patch)
tree0c72a6de0b8f9e9f3d566bbfcb29f3aa5c286832 /app-arch
parentfix the libdir on non-multilib systems for bug #350511. (diff)
downloadgentoo-2-4a58b94cee9474ec51d9ccee1b79b15c84fb9121.tar.gz
gentoo-2-4a58b94cee9474ec51d9ccee1b79b15c84fb9121.tar.bz2
gentoo-2-4a58b94cee9474ec51d9ccee1b79b15c84fb9121.zip
Importing zpaq archiver from Sunrise as per bug #278021. The ebuild was updated to install latest libzpaq & zpaq. It also patches in an autotools-based build system to avoid build difficulties.
(Portage version: 2.2.0_alpha12_p8/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zpaq/ChangeLog12
-rw-r--r--app-arch/zpaq/files/0001-Add-autotools-files.patch77
-rw-r--r--app-arch/zpaq/metadata.xml9
-rw-r--r--app-arch/zpaq/zpaq-2.04.ebuild38
4 files changed, 136 insertions, 0 deletions
diff --git a/app-arch/zpaq/ChangeLog b/app-arch/zpaq/ChangeLog
new file mode 100644
index 000000000000..044b60dca2fb
--- /dev/null
+++ b/app-arch/zpaq/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-arch/zpaq
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/ChangeLog,v 1.1 2011/01/04 23:19:48 mgorny Exp $
+
+*zpaq-2.04 (04 Jan 2011)
+
+ 04 Jan 2011; Michał Górny <mgorny@gentoo.org>
+ +files/0001-Add-autotools-files.patch, +zpaq-2.04.ebuild, +metadata.xml:
+ Importing zpaq archiver from Sunrise as per bug #278021. The ebuild was
+ updated to install latest libzpaq & zpaq. It also patches in an
+ autotools-based build system to avoid build difficulties.
+
diff --git a/app-arch/zpaq/files/0001-Add-autotools-files.patch b/app-arch/zpaq/files/0001-Add-autotools-files.patch
new file mode 100644
index 000000000000..12ba5a44315b
--- /dev/null
+++ b/app-arch/zpaq/files/0001-Add-autotools-files.patch
@@ -0,0 +1,77 @@
+From 518123ca0f682ec617c2bab16bdb953380b5352c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 4 Jan 2011 21:04:53 +0100
+Subject: [PATCH] Add autotools files.
+
+---
+ Makefile.am | 22 ++++++++++++++++++++++
+ configure.ac | 28 ++++++++++++++++++++++++++++
+ 2 files changed, 50 insertions(+), 0 deletions(-)
+ create mode 100644 Makefile.am
+ create mode 100644 configure.ac
+
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+index 0000000..3c71e01
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,22 @@
++bin_PROGRAMS = zpaq
++lib_LIBRARIES = libzpaq.a libzpaqstub.a
++include_HEADERS = libzpaq.h
++
++if HAVE_POD2MAN
++man1_MANS = zpaq.1
++
++zpaq.1: zpaq.1.pod
++ $(POD2MAN) $< > $@
++endif
++
++libzpaq_a_SOURCES = libzpaq.cpp libzpaqo.cpp libzpaq.h
++libzpaqstub_a_SOURCES = libzpaq.cpp zpaq.cpp libzpaq.h
++
++zpaq_SOURCES = zpaq.cpp libzpaq.h
++zpaq_LDADD = libzpaq.a
++zpaq_CPPFLAGS = $(AM_CPPFLAGS) -DOPT='"$(CXX) $(CXXFLAGS) zpaqopt.cpp $(LDFLAGS) @RUNTIME_LDFLAGS@ -o zpaqopt.exe -lzpaqstub"'
++
++AM_CPPFLAGS = -DNDEBUG
++
++MOSTLYCLEANFILES = zpaq.1
++EXTRA_DIST = zpaq.1.pod libzpaq.txt
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+index 0000000..d3565e2
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,28 @@
++AC_PREREQ([2.60])
++AC_INIT([zpaq], [2.04])
++AC_CONFIG_AUX_DIR([build-aux])
++AM_INIT_AUTOMAKE([1.6 foreign no-dependencies])
++
++AC_LANG([C++])
++AC_PROG_CXX
++AC_PROG_RANLIB
++
++runtime_LDFLAGS='-Wl,--strip-all'
++AC_MSG_CHECKING([whether the linker supports $runtime_LDFLAGS])
++save_LDFLAGS=$LDFLAGS
++LDFLAGS="$LDFLAGS $runtime_LDFLAGS"
++AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM([], [])],
++ [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no])
++runtime_LDFLAGS=])
++LDFLAGS=$save_LDFLAGS
++AC_SUBST([RUNTIME_LDFLAGS], [$runtime_LDFLAGS])
++
++AC_CHECK_PROG([POD2MAN], [pod2man], [pod2man])
++AM_CONDITIONAL([HAVE_POD2MAN], [test x"$POD2MAN" != x""])
++AS_IF([test "x$POD2MAN" = x], [
++ AC_MSG_WARN([Unable to find pod2man, manpage will not be generated])
++])
++
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
+--
+1.7.3.4
+
diff --git a/app-arch/zpaq/metadata.xml b/app-arch/zpaq/metadata.xml
new file mode 100644
index 000000000000..af81389004c1
--- /dev/null
+++ b/app-arch/zpaq/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/zpaq/zpaq-2.04.ebuild b/app-arch/zpaq/zpaq-2.04.ebuild
new file mode 100644
index 000000000000..5c2dcb80da9f
--- /dev/null
+++ b/app-arch/zpaq/zpaq-2.04.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/zpaq-2.04.ebuild,v 1.1 2011/01/04 23:19:48 mgorny Exp $
+
+EAPI=3
+
+inherit autotools autotools-utils
+
+LIB_PV=202
+PROG_PV=${PV/./}
+
+DESCRIPTION="A unified compressor for PAQ algorithms"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${PN}.${PROG_PV}.zip
+ http://mattmahoney.net/dc/lib${PN}.${LIB_PV}.zip"
+
+LICENSE="GPL-3 ISOC-rfc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+DOCS=( libzpaq.txt )
+
+src_prepare() {
+ EPATCH_OPTS+=-p1 epatch "${FILESDIR}"/0001-Add-autotools-files.patch
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog "You may also want to install app-arch/zpaq-extras package which provides"
+ elog "few additional configs and preprocessors for use with zpaq."
+}