summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 02:26:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 02:26:12 +0000
commit54e77b567f7e0ced64193454bf57df934e55707a (patch)
treebdd6d7565d111a62291918601f77fe85c8c33def /app-arch
parentmetadata (Manifest recommit) (diff)
downloadgentoo-2-54e77b567f7e0ced64193454bf57df934e55707a.tar.gz
gentoo-2-54e77b567f7e0ced64193454bf57df934e55707a.tar.bz2
gentoo-2-54e77b567f7e0ced64193454bf57df934e55707a.zip
Version bump. Magically fixes #74841 by lison.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/cpio/ChangeLog10
-rw-r--r--app-arch/cpio/cpio-2.6.ebuild (renamed from app-arch/cpio/cpio-2.5.90.ebuild)7
-rw-r--r--app-arch/cpio/files/2.5.90-gnulib.patch99
-rw-r--r--app-arch/cpio/files/2.5.90-makepath.patch17
-rw-r--r--app-arch/cpio/files/2.6-rili-big-files.patch (renamed from app-arch/cpio/files/2.5.90-rili-big-files.patch)1
-rw-r--r--app-arch/cpio/files/digest-cpio-2.5.901
-rw-r--r--app-arch/cpio/files/digest-cpio-2.61
7 files changed, 13 insertions, 123 deletions
diff --git a/app-arch/cpio/ChangeLog b/app-arch/cpio/ChangeLog
index 958b50cd0f7c..454dcbb810f1 100644
--- a/app-arch/cpio/ChangeLog
+++ b/app-arch/cpio/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/cpio
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.7 2005/01/01 11:43:05 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.8 2005/01/04 02:26:12 vapier Exp $
+
+*cpio-2.6 (03 Jan 2005)
+
+ 03 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ -files/2.5.90-gnulib.patch, -files/2.5.90-makepath.patch,
+ -files/2.5.90-rili-big-files.patch, +files/2.6-rili-big-files.patch,
+ -cpio-2.5.90.ebuild, +cpio-2.6.ebuild:
+ Version bump. Magically fixes #74841 by lison.
*cpio-2.5.90 (17 Dec 2004)
diff --git a/app-arch/cpio/cpio-2.5.90.ebuild b/app-arch/cpio/cpio-2.6.ebuild
index 7bc37f1b4642..6e0c9d41b6a2 100644
--- a/app-arch/cpio/cpio-2.5.90.ebuild
+++ b/app-arch/cpio/cpio-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.5.90.ebuild,v 1.2 2005/01/01 11:43:05 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6.ebuild,v 1.1 2005/01/04 02:26:12 vapier Exp $
inherit eutils
@@ -11,20 +11,19 @@ SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh ~sparc ~x86"
-IUSE=""
+IUSE="nls"
DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${PV}-gnulib.patch
- epatch ${FILESDIR}/${PV}-makepath.patch
epatch ${FILESDIR}/${PV}-rili-big-files.patch
}
src_compile() {
econf \
+ $(use_enable nls) \
--bindir=/bin \
--with-rmt=/usr/sbin/rmt \
|| die
diff --git a/app-arch/cpio/files/2.5.90-gnulib.patch b/app-arch/cpio/files/2.5.90-gnulib.patch
deleted file mode 100644
index 44cce2704f35..000000000000
--- a/app-arch/cpio/files/2.5.90-gnulib.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-Index: argp.h
-===================================================================
-RCS file: /cvsroot/gnulib/gnulib/lib/argp.h,v
-retrieving revision 1.5
-retrieving revision 1.8
-diff -u -b -B -r1.5 -r1.8
---- lib/argp.h 4 Oct 2003 12:28:07 -0000 1.5
-+++ lib/argp.h 30 Sep 2004 16:41:57 -0000 1.8
-@@ -1,5 +1,5 @@
- /* Hierarchial argument parsing, layered over getopt.
-- Copyright (C) 1995,1996,1997,1998,1999,2003 Free Software Foundation, Inc.
-+ Copyright (C) 1995-1999,2003,2004 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Written by Miles Bader <miles@gnu.ai.mit.edu>.
-
-@@ -34,6 +34,9 @@
- #ifndef __THROW
- # define __THROW
- #endif
-+#ifndef __NTH
-+# define __NTH(fct) fct __THROW
-+#endif
-
- #ifndef __attribute__
- /* This feature is available in gcc versions 2.5 and later. */
-@@ -48,6 +51,18 @@
- # endif
- #endif
-
-+/* GCC 2.95 and later have "__restrict"; C99 compilers have
-+ "restrict", and "configure" may have defined "restrict". */
-+#ifndef __restrict
-+# if ! (2 < __GNUC__ || (2 == __GNUC__ && 95 <= __GNUC_MINOR__))
-+# if defined restrict || 199901L <= __STDC_VERSION__
-+# define __restrict restrict
-+# else
-+# define __restrict
-+# endif
-+# endif
-+#endif
-+
- #ifndef __error_t_defined
- typedef int error_t;
- # define __error_t_defined
-@@ -111,11 +126,12 @@
- should be displayed in much the same manner as the options. If this flag
- is set, then the option NAME field is displayed unmodified (e.g., no `--'
- prefix is added) at the left-margin (where a *short* option would normally
-- be displayed), and the documentation string in the normal place. For
-- purposes of sorting, any leading whitespace and punctuation is ignored,
-- except that if the first non-whitespace character is not `-', this entry
-- is displayed after all options (and OPTION_DOC entries with a leading `-')
-- in the same group. */
-+ be displayed), and the documentation string in the normal place. The NAME
-+ field will be translated using gettext, unless OPTION_NO_TRANS is set (see
-+ below). For purposes of sorting, any leading whitespace and punctuation is
-+ ignored, except that if the first non-whitespace character is not `-', this
-+ entry is displayed after all options (and OPTION_DOC entries with a leading
-+ `-') in the same group. */
- #define OPTION_DOC 0x8
-
- /* This option shouldn't be included in `long' usage messages (but is still
-@@ -127,6 +143,11 @@
- OPTION_NO_USAGE. */
- #define OPTION_NO_USAGE 0x10
-
-+/* Valid only in conjunction with OPTION_DOC. This option disables translation
-+ of option name. */
-+#define OPTION_NO_TRANS 0x20
-+
-+
- struct argp; /* fwd declare this type */
- struct argp_state; /* " */
- struct argp_child; /* " */
-@@ -545,13 +566,13 @@
- # endif
-
- ARGP_EI void
--__argp_usage (__const struct argp_state *__state) __THROW
-+__NTH (__argp_usage (__const struct argp_state *__state))
- {
- __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
- }
-
- ARGP_EI int
--__option_is_short (__const struct argp_option *__opt) __THROW
-+__NTH (__option_is_short (__const struct argp_option *__opt))
- {
- if (__opt->flags & OPTION_DOC)
- return 0;
-@@ -563,7 +584,7 @@
- }
-
- ARGP_EI int
--__option_is_end (__const struct argp_option *__opt) __THROW
-+__NTH (__option_is_end (__const struct argp_option *__opt))
- {
- return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
- }
diff --git a/app-arch/cpio/files/2.5.90-makepath.patch b/app-arch/cpio/files/2.5.90-makepath.patch
deleted file mode 100644
index 525264e4cbd3..000000000000
--- a/app-arch/cpio/files/2.5.90-makepath.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: src/makepath.c
-===================================================================
-RCS file: /cvsroot/cpio/cpio/src/makepath.c,v
-retrieving revision 1.3
-retrieving revision 1.4
-diff -u -r1.3 -r1.4
---- src/makepath.c 6 Sep 2004 14:04:53 -0000 1.3
-+++ src/makepath.c 14 Oct 2004 09:41:17 -0000 1.4
-@@ -64,8 +64,6 @@
- #include <strings.h>
- #endif
-
--void error ();
--
- /* Ensure that the directory ARGPATH exists.
- Remove any trailing slashes from ARGPATH before calling this function.
-
diff --git a/app-arch/cpio/files/2.5.90-rili-big-files.patch b/app-arch/cpio/files/2.6-rili-big-files.patch
index d6d3a4c5128b..a08515ca2075 100644
--- a/app-arch/cpio/files/2.5.90-rili-big-files.patch
+++ b/app-arch/cpio/files/2.6-rili-big-files.patch
@@ -1,4 +1,3 @@
-? big-gigs.patch
Index: src/extern.h
===================================================================
RCS file: /cvsroot/cpio/cpio/src/extern.h,v
diff --git a/app-arch/cpio/files/digest-cpio-2.5.90 b/app-arch/cpio/files/digest-cpio-2.5.90
deleted file mode 100644
index 8d5afee0a3c4..000000000000
--- a/app-arch/cpio/files/digest-cpio-2.5.90
+++ /dev/null
@@ -1 +0,0 @@
-MD5 26fac3e733171c5ab20928151f582fee cpio-2.5.90.tar.bz2 444639
diff --git a/app-arch/cpio/files/digest-cpio-2.6 b/app-arch/cpio/files/digest-cpio-2.6
new file mode 100644
index 000000000000..822d7f4e46f3
--- /dev/null
+++ b/app-arch/cpio/files/digest-cpio-2.6
@@ -0,0 +1 @@
+MD5 25e0e8725bc60ed3460c9cde92752674 cpio-2.6.tar.bz2 448452