summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2006-02-23 21:39:23 +0000
committerJonathan Smith <smithj@gentoo.org>2006-02-23 21:39:23 +0000
commit5d9f6f62da923acb07b39ac81df274ac0eba2aad (patch)
treeda971e18d36a77b370554ff484cfd6f8e9ac90eb /app-arch
parentMarked ~alpha (bug #122726) (diff)
downloadgentoo-2-5d9f6f62da923acb07b39ac81df274ac0eba2aad.tar.gz
gentoo-2-5d9f6f62da923acb07b39ac81df274ac0eba2aad.tar.bz2
gentoo-2-5d9f6f62da923acb07b39ac81df274ac0eba2aad.zip
bugzy #123782: patches security hole; x86 stable
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zoo/ChangeLog10
-rw-r--r--app-arch/zoo/files/digest-zoo-2.102
-rw-r--r--app-arch/zoo/files/digest-zoo-2.10-r13
-rw-r--r--app-arch/zoo/files/zoo-security-fix.patch19
-rw-r--r--app-arch/zoo/zoo-2.10-r1.ebuild31
-rw-r--r--app-arch/zoo/zoo-2.10.ebuild5
6 files changed, 66 insertions, 4 deletions
diff --git a/app-arch/zoo/ChangeLog b/app-arch/zoo/ChangeLog
index c30d88b144c4..55c63b2f58c5 100644
--- a/app-arch/zoo/ChangeLog
+++ b/app-arch/zoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/zoo
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/ChangeLog,v 1.13 2005/02/06 18:20:31 corsair Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/ChangeLog,v 1.14 2006/02/23 21:39:23 smithj Exp $
+
+*zoo-2.10-r1 (23 Feb 2006)
+
+ 23 Feb 2006; <smithj@gentoo.org> +files/zoo-security-fix.patch,
+ -zoo-2.10.ebuild, +zoo-2.10-r1.ebuild:
+ bugzy #123782: patches security hole; x86 stable
06 Feb 2005; Markus Rothe <corsair@gentoo.org> zoo-2.10.ebuild:
Stable on ppc64
diff --git a/app-arch/zoo/files/digest-zoo-2.10 b/app-arch/zoo/files/digest-zoo-2.10
index dac46dcd22ca..ef7498d9a261 100644
--- a/app-arch/zoo/files/digest-zoo-2.10
+++ b/app-arch/zoo/files/digest-zoo-2.10
@@ -1 +1,3 @@
MD5 70a0a785ecc8f7f747be1421e495d837 zoo-2.10pl1.tar.gz 172096
+RMD160 971d388b8cb29def1e4e31011463563e91c3d700 zoo-2.10pl1.tar.gz 172096
+SHA256 ad8d8fee5e524aca0e1e9a1e431c21cd59943d8373d5dffe4edca03a7e4284f4 zoo-2.10pl1.tar.gz 172096
diff --git a/app-arch/zoo/files/digest-zoo-2.10-r1 b/app-arch/zoo/files/digest-zoo-2.10-r1
new file mode 100644
index 000000000000..ef7498d9a261
--- /dev/null
+++ b/app-arch/zoo/files/digest-zoo-2.10-r1
@@ -0,0 +1,3 @@
+MD5 70a0a785ecc8f7f747be1421e495d837 zoo-2.10pl1.tar.gz 172096
+RMD160 971d388b8cb29def1e4e31011463563e91c3d700 zoo-2.10pl1.tar.gz 172096
+SHA256 ad8d8fee5e524aca0e1e9a1e431c21cd59943d8373d5dffe4edca03a7e4284f4 zoo-2.10pl1.tar.gz 172096
diff --git a/app-arch/zoo/files/zoo-security-fix.patch b/app-arch/zoo/files/zoo-security-fix.patch
new file mode 100644
index 000000000000..2cfd2c24b645
--- /dev/null
+++ b/app-arch/zoo/files/zoo-security-fix.patch
@@ -0,0 +1,19 @@
+--- misc.c.old 2006-02-23 15:10:26.000000000 -0500
++++ misc.c 2006-02-23 15:10:29.000000000 -0500
+@@ -135,11 +135,15 @@
+ char *fullpath (direntry)
+ struct direntry *direntry;
+ {
+- static char result[PATHSIZE];
++ static char result[PATHSIZE+PATHSIZE+12]; // Room for enough space
+ combine (result,
+ direntry->dirlen != 0 ? direntry->dirname : "",
+ (direntry->namlen != 0) ? direntry->lfname : direntry->fname
+ );
++ if (strlen (result) >= PATHSIZE) {
++ prterror ('f', "Combined dirname and filename too long\n");
++ }
++
+ return (result);
+ }
+
diff --git a/app-arch/zoo/zoo-2.10-r1.ebuild b/app-arch/zoo/zoo-2.10-r1.ebuild
new file mode 100644
index 000000000000..47dbea696d44
--- /dev/null
+++ b/app-arch/zoo/zoo-2.10-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/zoo-2.10-r1.ebuild,v 1.1 2006/02/23 21:39:23 smithj Exp $
+
+inherit eutils
+
+DESCRIPTION="Manipulate archives of files in compressed form."
+SRC_URI="ftp://ftp.kiarchive.ru/pub/unix/arcers/${P}pl1.tar.gz"
+HOMEPAGE="ftp://ftp.kiarchive.ru/pub/unix/arcers"
+
+SLOT="0"
+LICENSE="zoo"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc x86"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${P}pl1.tar.gz
+ epatch ${FILESDIR}/${P}-gcc33-issues-fix.patch
+ epatch ${FILESDIR}/${PN}-security-fix.patch
+}
+
+src_compile() {
+ emake linux || die
+}
+
+src_install() {
+ dobin zoo fiz
+ doman zoo.1 fiz.1
+}
diff --git a/app-arch/zoo/zoo-2.10.ebuild b/app-arch/zoo/zoo-2.10.ebuild
index 664163e33c04..85d0034cd922 100644
--- a/app-arch/zoo/zoo-2.10.ebuild
+++ b/app-arch/zoo/zoo-2.10.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/zoo-2.10.ebuild,v 1.22 2005/11/29 03:02:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zoo/zoo-2.10.ebuild,v 1.23 2006/02/23 21:39:23 smithj Exp $
inherit eutils
DESCRIPTION="Manipulate archives of files in compressed form."
SRC_URI="ftp://ftp.kiarchive.ru/pub/unix/arcers/${P}pl1.tar.gz"
+HOMEPAGE="ftp://ftp.kiarchive.ru/pub/unix/arcers"
SLOT="0"
LICENSE="zoo"