summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-24 11:39:12 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-24 11:39:12 +0000
commit6889792f05431a5abb276f9c6a1911acfc4351a9 (patch)
tree92ace9e27a889c695f11c1f9c9fd5d46a93b73c8 /app-arch
parentVersion bump #203161 by Nebojsa Trpkovic. (diff)
downloadgentoo-2-6889792f05431a5abb276f9c6a1911acfc4351a9.tar.gz
gentoo-2-6889792f05431a5abb276f9c6a1911acfc4351a9.tar.bz2
gentoo-2-6889792f05431a5abb276f9c6a1911acfc4351a9.zip
Version bump #192113 which includes zlib fix #166437 by Thilo Bangert. Also make nls stuff optional #192819 by Natanael Copa.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog9
-rw-r--r--app-arch/dpkg/dpkg-1.14.12.ebuild46
-rw-r--r--app-arch/dpkg/files/digest-dpkg-1.14.123
-rw-r--r--app-arch/dpkg/files/dpkg-1.14.12-nls.patch18
4 files changed, 75 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 0121cf2d0432..9752e2f38e97 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.49 2007/10/26 02:21:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.50 2007/12/24 11:39:11 vapier Exp $
+
+*dpkg-1.14.12 (24 Dec 2007)
+
+ 24 Dec 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/dpkg-1.14.12-nls.patch, +dpkg-1.14.12.ebuild:
+ Version bump #192113 which includes zlib fix #166437 by Thilo Bangert. Also
+ make nls stuff optional #192819 by Natanael Copa.
26 Oct 2007; Jeroen Roovers <jer@gentoo.org> dpkg-1.13.25.ebuild:
Stable for HPPA too.
diff --git a/app-arch/dpkg/dpkg-1.14.12.ebuild b/app-arch/dpkg/dpkg-1.14.12.ebuild
new file mode 100644
index 000000000000..dfc117447f19
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.14.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.14.12.ebuild,v 1.1 2007/12/24 11:39:11 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/dpkg/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="bzip2 nls selinux zlib"
+
+RDEPEND=">=dev-lang/perl-5.6.0
+ >=sys-libs/ncurses-5.2-r7
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ nls? ( app-text/po4a )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-nls.patch #192819
+}
+
+src_compile() {
+ econf \
+ $(use_with bzip2 bz2lib) \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(use_with zlib) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm "${D}"/usr/sbin/{install-info,start-stop-daemon}
+ rm "${D}"/usr/share/man/man?/{install-info,start-stop-daemon}.?
+ dodoc ChangeLog INSTALL THANKS TODO
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/files/digest-dpkg-1.14.12 b/app-arch/dpkg/files/digest-dpkg-1.14.12
new file mode 100644
index 000000000000..1baffeb95246
--- /dev/null
+++ b/app-arch/dpkg/files/digest-dpkg-1.14.12
@@ -0,0 +1,3 @@
+MD5 76bf280f2af1711d159ba33e3024d84a dpkg_1.14.12.tar.gz 6294479
+RMD160 a0b4e7260c5394d6ec8beee973fe87672dccec08 dpkg_1.14.12.tar.gz 6294479
+SHA256 4b53972170dab48ea387f2af950cfad4793bc97539f6f315a41f239282122a7b dpkg_1.14.12.tar.gz 6294479
diff --git a/app-arch/dpkg/files/dpkg-1.14.12-nls.patch b/app-arch/dpkg/files/dpkg-1.14.12-nls.patch
new file mode 100644
index 000000000000..cae1beab2924
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.14.12-nls.patch
@@ -0,0 +1,18 @@
+respect the configure nls flag
+
+http://bugs.gentoo.org/192819
+
+--- man/Makefile.in
++++ man/Makefile.in
+@@ -223,7 +223,11 @@
+ top_srcdir = @top_srcdir@
+
+ # Extract the list of languages from the po4a config file.
++ifeq ($(USE_NLS),yes)
+ LINGUAS = $(shell sed -ne 's/^.*\[po4a_langs\] \(.*\)$$/\1/p' $(srcdir)/po/po4a.cfg)
++else
++LINGUAS = C
++endif
+ dist_man_MANS = \
+ 822-date.1 \
+ cleanup-info.8 \