summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-10-13 12:13:49 +0000
committerRichard Yao <ryao@gentoo.org>2013-10-13 12:13:49 +0000
commitd3b572dc6861e5669f7d562fcc95f871fb5557de (patch)
treea464fba03ab7b305c9aa0d80be80a0bececb1db0 /app-arch
parentAdd missing depend (#476134) (diff)
downloadgentoo-2-d3b572dc6861e5669f7d562fcc95f871fb5557de.tar.gz
gentoo-2-d3b572dc6861e5669f7d562fcc95f871fb5557de.tar.bz2
gentoo-2-d3b572dc6861e5669f7d562fcc95f871fb5557de.zip
Introduce app-arch/lz4-0_p106-r1 to replace short-lived app-arch/lz4-0_p106: Path issues are fixed; app-arch/lz4-9999 has been synchronized with app-arch/lz4-0_p106-r1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lz4/ChangeLog11
-rw-r--r--app-arch/lz4/files/lz4-0_p106-install-to-bindir.patch51
-rw-r--r--app-arch/lz4/lz4-0_p106-r1.ebuild61
-rw-r--r--app-arch/lz4/lz4-9999.ebuild15
4 files changed, 132 insertions, 6 deletions
diff --git a/app-arch/lz4/ChangeLog b/app-arch/lz4/ChangeLog
index 1a404729a4fa..eea2ea0b1691 100644
--- a/app-arch/lz4/ChangeLog
+++ b/app-arch/lz4/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-arch/lz4
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.7 2013/10/13 11:33:59 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.8 2013/10/13 12:13:49 ryao Exp $
+
+*lz4-0_p106-r1 (13 Oct 2013)
+
+ 13 Oct 2013; Richard Yao <ryao@gentoo.org>
+ +files/lz4-0_p106-install-to-bindir.patch, +lz4-0_p106-r1.ebuild,
+ lz4-9999.ebuild:
+ Introduce app-arch/lz4-0_p106-r1 to replace short-lived app-arch/lz4-0_p106:
+ Path issues are fixed; app-arch/lz4-9999 has been synchronized with app-
+ arch/lz4-0_p106-r1
13 Oct 2013; Richard Yao <ryao@gentoo.org> -lz4-0_p106.ebuild,
lz4-9999.ebuild:
diff --git a/app-arch/lz4/files/lz4-0_p106-install-to-bindir.patch b/app-arch/lz4/files/lz4-0_p106-install-to-bindir.patch
new file mode 100644
index 000000000000..521b1bfc58d2
--- /dev/null
+++ b/app-arch/lz4/files/lz4-0_p106-install-to-bindir.patch
@@ -0,0 +1,51 @@
+diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
+index 496c076..ce3fab1 100644
+--- a/cmake/CMakeLists.txt
++++ b/cmake/CMakeLists.txt
+@@ -41,11 +41,11 @@ endif()
+ if (CMAKE_SYSTEM_PROCESSOR STREQUAL "64bit")
+ message(STATUS "Build 64bit executable binary")
+ add_executable(lz4c64 ${LZ4_SRCS})
+- install(TARGETS lz4c64 RUNTIME DESTINATION "./")
++ install(TARGETS lz4c64 RUNTIME DESTINATION "bin/")
+ if(NOT BUILD_SHARED_LIBS)
+ message(STATUS "Build 32bit executable binary")
+ add_executable(lz4c32 ${LZ4_SRCS})
+- install(TARGETS lz4c32 RUNTIME DESTINATION "./")
++ install(TARGETS lz4c32 RUNTIME DESTINATION "bin/")
+
+ SET_TARGET_PROPERTIES(lz4c32 PROPERTIES
+ COMPILE_FLAGS PROPERTIES COMPILE_FLAGS "-m32" LINK_FLAGS "-m32")
+@@ -53,7 +53,7 @@ if (CMAKE_SYSTEM_PROCESSOR STREQUAL "64bit")
+ else()
+ message(STATUS "Build 32bit executable binary")
+ add_executable(lz4c32 ${LZ4_SRCS})
+- install(TARGETS lz4c32 RUNTIME DESTINATION "./")
++ install(TARGETS lz4c32 RUNTIME DESTINATION "bin/")
+ endif()
+
+ if(BUILD_SHARED_LIBS)
+diff --git a/cmake/pack/CMakeLists.txt b/cmake/pack/CMakeLists.txt
+index a9b0557..e85416e 100644
+--- a/cmake/pack/CMakeLists.txt
++++ b/cmake/pack/CMakeLists.txt
+@@ -48,16 +48,16 @@ set(FUZZER_SRCS ${SRC_DIR}lz4.c ${SRC_DIR}lz4hc.c ${SRC_DIR}lz4.h ${SRC_DIR}fuzz
+ # EXECUTABLES FOR 32 Bit and 64 versions
+ if(CMAKE_SYSTEM_PROCESSOR STREQUAL "64bit")
+ add_executable(lz4c32 ${LZ4_SRCS})
+- install(TARGETS lz4c32 RUNTIME DESTINATION "./")
++ install(TARGETS lz4c32 RUNTIME DESTINATION "bin/")
+ SET_TARGET_PROPERTIES(lz4c32 PROPERTIES
+ COMPILE_FLAGS PROPERTIES COMPILE_FLAGS "-m32 -Os" LINK_FLAGS "-m32")
+ endif()
+
+ add_executable(lz4c ${LZ4_SRCS})
+-install(TARGETS lz4c RUNTIME DESTINATION "./")
++install(TARGETS lz4c RUNTIME DESTINATION "bin/")
+
+ add_executable(fuzzer ${FUZZER_SRCS})
+-install(TARGETS fuzzer RUNTIME DESTINATION "./")
++install(TARGETS fuzzer RUNTIME DESTINATION "bin/")
+
+ #target_link_libraries(lz4 ${LZ4_SRCS_LIB})
+ ####################### CPACK PACKAGING ###################
diff --git a/app-arch/lz4/lz4-0_p106-r1.ebuild b/app-arch/lz4/lz4-0_p106-r1.ebuild
new file mode 100644
index 000000000000..648622f33092
--- /dev/null
+++ b/app-arch/lz4/lz4-0_p106-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-0_p106-r1.ebuild,v 1.1 2013/10/13 12:13:49 ryao Exp $
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+CMAKE_USE_DIR="${S}/cmake"
+
+if [ ${PV} == "9999" ] ; then
+ inherit subversion
+ ESVN_REPO_URI="http://lz4.googlecode.com/svn/trunk/"
+ ESVN_PROJECT="lz4-read-only"
+else
+ SRC_URI="http://dev.gentoo.org/~ryao/dist/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://code.google.com/p/lz4/"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if [ ${PV} == "9999" ]
+ then
+ subversion_src_prepare
+ else
+ epatch "${FILESDIR}/${P}-install-to-bindir.patch"
+ fi
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(-DBUILD_SHARED_LIBS=ON)
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dodir /usr
+ dodir "/usr/$(get_libdir)"
+ ln -s "$(get_libdir)" "${ED}usr/lib" || \
+ die "Cannot create temporary symlink from usr/lib to usr/$(get_libdir)"
+
+ cmake-utils_src_install
+
+ rm "${ED}usr/lib"
+
+ if [ -f "${ED}usr/bin/lz4c64" ]
+ then
+ dosym lz4c64 /usr/bin/lz4c
+ else
+ dosym lz4c32 /usr/bin/lz4c
+ fi
+}
diff --git a/app-arch/lz4/lz4-9999.ebuild b/app-arch/lz4/lz4-9999.ebuild
index ed4bd3bbf2fa..40a2cd2c29da 100644
--- a/app-arch/lz4/lz4-9999.ebuild
+++ b/app-arch/lz4/lz4-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-9999.ebuild,v 1.7 2013/10/13 11:33:59 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-9999.ebuild,v 1.8 2013/10/13 12:13:49 ryao Exp $
EAPI=5
@@ -28,7 +28,12 @@ DEPEND=""
RDEPEND="${DEPEND}"
src_prepare() {
- [ ${PV} == "9999" ] && subversion_src_prepare
+ if [ ${PV} == "9999" ]
+ then
+ subversion_src_prepare
+ else
+ epatch "${FILESDIR}/${P}-install-to-bindir.patch"
+ fi
cmake-utils_src_prepare
}
@@ -40,7 +45,7 @@ src_configure() {
src_install() {
dodir /usr
dodir "/usr/$(get_libdir)"
- ln -s "${ED}/usr/$(get_libdir)" "${ED}usr/lib" || \
+ ln -s "$(get_libdir)" "${ED}usr/lib" || \
die "Cannot create temporary symlink from usr/lib to usr/$(get_libdir)"
cmake-utils_src_install
@@ -49,8 +54,8 @@ src_install() {
if [ -f "${ED}usr/bin/lz4c64" ]
then
- dosym /usr/bin/{lz4c64,lz4c}
+ dosym lz4c64 /usr/bin/lz4c
else
- dosym /usr/bin/{lz4c32,lz4c}
+ dosym lz4c32 /usr/bin/lz4c
fi
}