summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-05 04:52:53 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-05 04:52:53 +0000
commite98431a0b3ecab8d86834d08e9f8c7a62dbd18db (patch)
treec63d6cccb98d3250371dd29675168ce588cc3200 /app-arch
parentMarked ~mips for bug #232245. Remove old (diff)
downloadgentoo-2-e98431a0b3ecab8d86834d08e9f8c7a62dbd18db.tar.gz
gentoo-2-e98431a0b3ecab8d86834d08e9f8c7a62dbd18db.tar.bz2
gentoo-2-e98431a0b3ecab8d86834d08e9f8c7a62dbd18db.zip
Version bump thanks to Mario Fetka (geos_one, bug #339721). Remove empty DEPEND. Merge epatch calls. Make sed die.
(Portage version: 2.2_rc88/cvs/Linux i686)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/arc/ChangeLog8
-rw-r--r--app-arch/arc/arc-5.21p.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/app-arch/arc/ChangeLog b/app-arch/arc/ChangeLog
index 41a68200eec6..4bf1b25d7729 100644
--- a/app-arch/arc/ChangeLog
+++ b/app-arch/arc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/arc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/ChangeLog,v 1.35 2010/02/17 06:50:49 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/ChangeLog,v 1.36 2010/10/05 04:52:53 jer Exp $
+
+*arc-5.21p (05 Oct 2010)
+
+ 05 Oct 2010; Jeroen Roovers <jer@gentoo.org> +arc-5.21p.ebuild:
+ Version bump thanks to Mario Fetka (geos_one, bug #339721). Remove empty
+ DEPEND. Merge epatch calls. Make sed die.
17 Feb 2010; Jonathan Callen <abcd@gentoo.org>
+files/arc-5.21m-darwin.patch, arc-5.21o.ebuild,
diff --git a/app-arch/arc/arc-5.21p.ebuild b/app-arch/arc/arc-5.21p.ebuild
new file mode 100644
index 000000000000..51e5bea85692
--- /dev/null
+++ b/app-arch/arc/arc-5.21p.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/arc-5.21p.ebuild,v 1.1 2010/10/05 04:52:53 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Create & extract files from DOS .ARC files"
+HOMEPAGE="http://arc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P/p/m}-darwin.patch \
+ "${FILESDIR}"/${P/p/m}-gentoo-fbsd.patch \
+ "${FILESDIR}"/${P/p/o}-interix.patch
+ sed -i Makefile \
+ -e 's/CFLAGS = $(OPT) $(SYSTEM)/CFLAGS += $(SYSTEM)/' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin arc marc
+ doman arc.1
+ dodoc Arc521.doc Arcinfo Changelog Readme
+}