summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-10-21 17:06:28 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-10-21 17:06:28 +0000
commitf63acaa94b74058c1007ebd5cf955ba37f479279 (patch)
tree0d77aa33c4ae153a798e3bde15fe7db96006e8e3 /app-arch
parentVersion bump (diff)
downloadgentoo-2-f63acaa94b74058c1007ebd5cf955ba37f479279.tar.gz
gentoo-2-f63acaa94b74058c1007ebd5cf955ba37f479279.tar.bz2
gentoo-2-f63acaa94b74058c1007ebd5cf955ba37f479279.zip
version bump, fixes #150498 #137579 #150766
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/p7zip/ChangeLog7
-rw-r--r--app-arch/p7zip/files/digest-p7zip-4.433
-rw-r--r--app-arch/p7zip/p7zip-4.43.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index d728cec4dd13..38494df939df 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.46 2006/09/04 17:49:48 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.47 2006/10/21 17:06:28 radek Exp $
+
+*p7zip-4.43 (21 Oct 2006)
+
+ 21 Oct 2006; Radoslaw Stachowiak <radek@gentoo.org> +p7zip-4.43.ebuild:
+ version bump, fixes #150498 #137579 #150766
04 Sep 2006; Saleem Abdulrasool <compnerd@gentoo.org> p7zip-4.42.ebuild:
stable on x86 (bug #145282)
diff --git a/app-arch/p7zip/files/digest-p7zip-4.43 b/app-arch/p7zip/files/digest-p7zip-4.43
new file mode 100644
index 000000000000..e680ce6de351
--- /dev/null
+++ b/app-arch/p7zip/files/digest-p7zip-4.43
@@ -0,0 +1,3 @@
+MD5 9fb8982262f66b4ec0377a67c171cfcb p7zip_4.43_src_all.tar.bz2 1482271
+RMD160 227741c37e1c69260898ef7a4aa827835cac8a6c p7zip_4.43_src_all.tar.bz2 1482271
+SHA256 736a1c301d95ed2d5ce917a859d6fca3f378345e8253a1143bd26f7333a7fb5c p7zip_4.43_src_all.tar.bz2 1482271
diff --git a/app-arch/p7zip/p7zip-4.43.ebuild b/app-arch/p7zip/p7zip-4.43.ebuild
new file mode 100644
index 000000000000..e718ba689bf3
--- /dev/null
+++ b/app-arch/p7zip/p7zip-4.43.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.43.ebuild,v 1.1 2006/10/21 17:06:28 radek Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Port of 7-Zip archiver for Unix"
+HOMEPAGE="http://p7zip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ~ppc-macos ~sparc x86"
+IUSE="static doc"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CXX=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
+ -e 's:-s ::' \
+ makefile* || die "changing makefiles"
+
+ if use amd64; then
+ ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
+ cp -f makefile.linux_amd64 makefile.machine
+ elif use ppc-macos; then
+ # Mac OS X needs this special makefile, because it has a non-GNU linker
+ cp -f makefile.macosx makefile.machine
+ elif use x86-fbsd; then
+ # FreeBSD needs this special makefile, because it hasn't -ldl
+ sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
+ fi
+ use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
+}
+
+src_compile() {
+ emake all3 || die "compilation error"
+}
+
+src_install() {
+ # this wrappers can not be symlinks, p7zip should be called with full path
+ make_wrapper 7zr "/usr/lib/${PN}/7zr"
+ make_wrapper 7za "/usr/lib/${PN}/7za"
+ make_wrapper 7z "/usr/lib/${PN}/7z"
+
+ dobin ${FILESDIR}/p7zip
+
+ # gzip introduced in 4.42, so beware :)
+ # mv needed just as rename, because dobin installs using old name
+ mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg
+ dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
+ exeinto /usr/$(get_libdir)/${PN}/Codecs
+ doexe bin/Codecs/* || die "doexe Codecs"
+ exeinto /usr/$(get_libdir)/${PN}/Formats
+ doexe bin/Formats/* || die "doexe Formats"
+
+ doman man1/7z.1 man1/7za.1 man1/7zr.1
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dodoc DOCS/*.txt
+ dohtml -r DOCS/MANUAL/*
+ fi
+}