summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-04 05:21:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-04 05:21:17 +0000
commitb18f1462a8192d63b2a20dd5f169736dfa32e2b1 (patch)
treec58055bc4e91b4c5b359505c0d49f547b41244d9 /app-backup/tob/tob-0.26-r1.ebuild
parentMoved app-arch/pdumpfs to app-backup/pdumpfs (diff)
downloadgentoo-2-b18f1462a8192d63b2a20dd5f169736dfa32e2b1.tar.gz
gentoo-2-b18f1462a8192d63b2a20dd5f169736dfa32e2b1.tar.bz2
gentoo-2-b18f1462a8192d63b2a20dd5f169736dfa32e2b1.zip
Moved from app-arch/tob to app-backup/tob.
Diffstat (limited to 'app-backup/tob/tob-0.26-r1.ebuild')
-rw-r--r--app-backup/tob/tob-0.26-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-backup/tob/tob-0.26-r1.ebuild b/app-backup/tob/tob-0.26-r1.ebuild
new file mode 100644
index 000000000000..55f66e6cd877
--- /dev/null
+++ b/app-backup/tob/tob-0.26-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/tob/tob-0.26-r1.ebuild,v 1.1 2005/07/04 05:21:17 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="A general driver for making and maintaining backups."
+HOMEPAGE="http://tinyplanet.ca/projects/tob/"
+SRC_URI="http://tinyplanet.ca/projects/tob/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="app-arch/afio"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-no-maketemp-warn.diff || die
+ epatch ${FILESDIR}/${P}-nice.patch || die
+ epatch ${FILESDIR}/${P}-scsi-tape.diff || die
+}
+
+src_compile() {
+ # no compilation required, only a perl-script
+ einfo "No compilation necessary..."
+}
+
+src_install() {
+ # simply install all the parts into the correct places
+ dosbin tob || die
+ dodir /etc/tob/volumes
+ cp tob.rc ${D}/etc/tob/tob.rc
+ cp example.* ${D}/etc/tob/volumes
+ doman tob.8
+ dodoc README
+ docinto doc
+ dodoc doc/*
+ docinto sample-rc
+ dodoc sample-rc/*
+ einfo "creating the TOBLISTS directory ..."
+ dodir /var/lib/tob
+}
+