summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-11 07:59:15 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-11 07:59:15 +0000
commit58f9bc694a67668204c0e01707517151a43601e6 (patch)
treed06c280102736f6a1bf923c3e14f86048acd2132 /app-backup
parentfix manifest entry for ChangeLog (diff)
downloadgentoo-2-58f9bc694a67668204c0e01707517151a43601e6.tar.gz
gentoo-2-58f9bc694a67668204c0e01707517151a43601e6.tar.bz2
gentoo-2-58f9bc694a67668204c0e01707517151a43601e6.zip
Add patch to respect LINGUAS (bug #402677, thanks to Piotr Szymaniak for reporting); with this patch, the nls USE flag no longer needed. Do not install static libraries and .la files.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/deja-dup/ChangeLog10
-rw-r--r--app-backup/deja-dup/deja-dup-21.2-r1.ebuild64
-rw-r--r--app-backup/deja-dup/files/deja-dup-21.2-linguas.patch65
3 files changed, 138 insertions, 1 deletions
diff --git a/app-backup/deja-dup/ChangeLog b/app-backup/deja-dup/ChangeLog
index d1357e37ca2f..a70d44001cd1 100644
--- a/app-backup/deja-dup/ChangeLog
+++ b/app-backup/deja-dup/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-backup/deja-dup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/deja-dup/ChangeLog,v 1.6 2012/01/29 11:44:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/deja-dup/ChangeLog,v 1.7 2012/02/11 07:59:15 tetromino Exp $
+
+*deja-dup-21.2-r1 (11 Feb 2012)
+
+ 11 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +deja-dup-21.2-r1.ebuild, +files/deja-dup-21.2-linguas.patch:
+ Add patch to respect LINGUAS (bug #402677, thanks to Piotr Szymaniak for
+ reporting); with this patch, the nls USE flag no longer needed. Do not
+ install static libraries and .la files.
29 Jan 2012; Justin Lecher <jlec@gentoo.org> deja-dup-21.2.ebuild:
Correct gtk dependency, #401045
diff --git a/app-backup/deja-dup/deja-dup-21.2-r1.ebuild b/app-backup/deja-dup/deja-dup-21.2-r1.ebuild
new file mode 100644
index 000000000000..f168ac83f04e
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-21.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/deja-dup/deja-dup-21.2-r1.ebuild,v 1.1 2012/02/11 07:59:15 tetromino Exp $
+
+EAPI=4
+
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://launchpad.net/deja-dup/"
+SRC_URI="http://launchpad.net/${PN}/22/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.26:2
+ x11-libs/gtk+:3
+ >=x11-libs/libnotify-0.7.1
+
+ app-backup/duplicity
+ dev-libs/dbus-glib
+ dev-libs/libunique:1
+ gnome-base/gnome-keyring
+
+ nautilus? ( >=gnome-base/nautilus-3 )"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs[fuse]"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-lang/vala:0.14
+ dev-perl/Locale-gettext
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17"
+
+pkg_setup() {
+ DOCS="NEWS AUTHORS"
+ G2CONF="${G2CONF}
+ $(use_with nautilus)
+ --without-ccpanel
+ --without-unity
+ --disable-schemas-compile
+ --disable-static"
+ export VALAC=$(type -p valac-0.14)
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-prll.patch \
+ "${FILESDIR}"/${P}-test.patch \
+ "${FILESDIR}"/${P}-linguas.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ domenu data/deja-dup.desktop
+}
diff --git a/app-backup/deja-dup/files/deja-dup-21.2-linguas.patch b/app-backup/deja-dup/files/deja-dup-21.2-linguas.patch
new file mode 100644
index 000000000000..bc5539a28a68
--- /dev/null
+++ b/app-backup/deja-dup/files/deja-dup-21.2-linguas.patch
@@ -0,0 +1,65 @@
+From 45e4b91bc7a987dc784c18564c9f8d2585befb0d Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 11 Feb 2012 02:43:18 -0500
+Subject: [PATCH] Use intltool's LINGUAS handling code for man pages
+
+LINGUAS needs to be handled the same way in man/ and po/.
+
+Otherwise, if building with LINGUAS set, the build system tries to
+generate man pages for languages for which localization messages
+had not been generated, resulting in build failure:
+
+ make[2]: Entering directory
+ `/var/tmp/portage/app-backup/deja-dup-21.2-r1/work/deja-dup-21.2/man'
+ make[2]: Nothing to be done for `install-exec-am'.
+ make[2]: *** No rule to make target `ar/stamp', needed by `man'. Stop.
+---
+ man/Makefile.am | 17 +++++++++++++----
+ 1 files changed, 13 insertions(+), 4 deletions(-)
+
+diff --git a/man/Makefile.am b/man/Makefile.am
+index 4aab2b1..cd837ed 100644
+--- a/man/Makefile.am
++++ b/man/Makefile.am
+@@ -17,9 +17,18 @@
+ # along with Déjà Dup. If not, see <http://www.gnu.org/licenses/>.
+
+ # Here's a bunch of translation support. Some stolen from dpkg
++# and intltool.
++
++ALL_LINGUAS = @ALL_LINGUAS@
++
++PO_LINGUAS=$(shell if test -r $(top_srcdir)/po/LINGUAS; then grep -v "^\#" $(top_srcdir)/po/LINGUAS; else echo "$(ALL_LINGUAS)"; fi)
++
++USER_LINGUAS=$(shell if test -n "$(LINGUAS)"; then LLINGUAS="$(LINGUAS)"; ALINGUAS="$(ALL_LINGUAS)"; for lang in $$LLINGUAS; do if test -n "`grep \^$$lang$$ $(top_srcdir)/po/LINGUAS 2>/dev/null`" -o -n "`echo $$ALINGUAS|tr ' ' '\n'|grep \^$$lang$$`"; then printf "$$lang "; fi; done; fi)
++
++USE_LINGUAS=$(shell if test -n "$(USER_LINGUAS)" -o -n "$(LINGUAS)"; then LLINGUAS="$(USER_LINGUAS)"; else if test -n "$(PO_LINGUAS)"; then LLINGUAS="$(PO_LINGUAS)"; else LLINGUAS="$(ALL_LINGUAS)"; fi; fi; for lang in $$LLINGUAS; do printf "$$lang "; done)
++
++MAN_LINGUAS = C $(USE_LINGUAS)
+
+-POLINGUAS = $(shell grep -v "^\#" $(top_srcdir)/po/LINGUAS)
+-MAN_LINGUAS = C $(POLINGUAS)
+
+ PAGES = deja-dup.1 deja-dup-preferences.1
+
+@@ -52,7 +61,7 @@ clean-local-yes:
+ install-data-local: install-data-local-@USE_NLS@
+ install-data-local-no:
+ install-data-local-yes: man
+- for lang in $(POLINGUAS); do \
++ for lang in $(USE_LINGUAS); do \
+ $(mkinstalldirs) "$(DESTDIR)$(mandir)/$$lang/man1"; \
+ $(INSTALL_DATA) $$lang/*.1 "$(DESTDIR)$(mandir)/$$lang/man1"; \
+ done
+@@ -62,7 +71,7 @@ install-data-local-yes: man
+ uninstall-local: uninstall-local-@USE_NLS@
+ uninstall-local-no:
+ uninstall-local-yes: man
+- for lang in $(POLINGUAS); do \
++ for lang in $(USE_LINGUAS); do \
+ for file in $(PAGES); do \
+ rm -f "$(DESTDIR)$(mandir)/$$lang/man1/$$file"; \
+ done \
+--
+1.7.8.4
+