summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-06 23:28:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-06 23:28:23 +0000
commit6e174854e5660c152314d5bd1c425a738d6a6872 (patch)
treeef87402a08ce06bb39b1194766b5d168f164f930 /app-benchmarks/acovea
parentFix building with recent glibc wrt #336260 by Diego E. Pettenò. (diff)
downloadgentoo-2-6e174854e5660c152314d5bd1c425a738d6a6872.tar.gz
gentoo-2-6e174854e5660c152314d5bd1c425a738d6a6872.tar.bz2
gentoo-2-6e174854e5660c152314d5bd1c425a738d6a6872.zip
clean cruft
(Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/acovea')
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1.ebuild15
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch8
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch4
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch5
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch4
5 files changed, 21 insertions, 15 deletions
diff --git a/app-benchmarks/acovea/acovea-5.1.1.ebuild b/app-benchmarks/acovea/acovea-5.1.1.ebuild
index 1cdf45e1adbd..6c38340c1cf8 100644
--- a/app-benchmarks/acovea/acovea-5.1.1.ebuild
+++ b/app-benchmarks/acovea/acovea-5.1.1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.9 2010/09/06 23:22:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.10 2010/09/06 23:28:23 ssuominen Exp $
EAPI=2
-
WANT_AUTOMAKE=1.9
-
inherit autotools eutils
DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm"
@@ -15,7 +13,7 @@ SRC_URI="http://www.coyotegulch.com/distfiles/lib${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+IUSE="static-libs"
RDEPEND=">=dev-libs/libcoyotl-3.1.0
>=dev-libs/libevocosm-3.1.0
@@ -29,13 +27,22 @@ src_prepare() {
"${FILESDIR}"/${P}-free-fix.patch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-glibc-212.patch
+
if has_version ">=dev-libs/libevocosm-3.3.0"; then
epatch ${FILESDIR}"/${P}-libevocosm.patch"
fi
+
eautomake
}
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
src_install() {
emake DESTDIR="${D}" install || die
dodoc ChangeLog NEWS README
+ find "${D}" -name '*.la' -exec rm -f '{}' +
}
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
index f3620be7f4b6..8bfb8a175550 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
@@ -1,13 +1,13 @@
---- cmdline/Makefile.am.old 2006-06-28 00:48:31.069459287 +0200
-+++ cmdline/Makefile.am 2006-06-28 00:48:40.917331263 +0200
+--- cmdline/Makefile.am
++++ cmdline/Makefile.am
@@ -7,4 +7,4 @@
runacovea_SOURCES = runacovea.cpp
-LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lexpat
+LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
---- libacovea/Makefile.am.old 2006-06-28 00:48:10.959720717 +0200
-+++ libacovea/Makefile.am 2006-06-28 00:48:53.436168516 +0200
+--- libacovea/Makefile.am
++++ libacovea/Makefile.am
@@ -16,3 +16,5 @@
library_include_HEADERS = $(h_sources)
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
index c64a0af7ac8a..55b3b00e8897 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
@@ -1,5 +1,5 @@
---- benchmarks/treebench.c.old 2006-06-28 01:08:11.190117519 +0200
-+++ benchmarks/treebench.c 2006-06-28 01:08:22.124975364 +0200
+--- benchmarks/treebench.c
++++ benchmarks/treebench.c
@@ -201,8 +201,8 @@
if (page->m_links[n] != NULL)
recursive_destroy_page(page->m_links[n]);
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch b/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
index ee95724d1070..c5e5392b2f99 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
@@ -1,6 +1,5 @@
-diff -NrU5 libacovea-5.1.1.original/libacovea/acovea.cpp libacovea-5.1.1/libacovea/acovea.cpp
---- libacovea-5.1.1.original/libacovea/acovea.cpp 2009-06-07 23:53:01.000000000 -0600
-+++ libacovea-5.1.1/libacovea/acovea.cpp 2009-06-07 23:53:51.000000000 -0600
+--- libacovea/acovea.cpp
++++ libacovea/acovea.cpp
@@ -44,10 +44,11 @@
#include <unistd.h>
#include <sys/types.h>
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
index ec30ce644925..f801b8c68bcb 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
@@ -1,5 +1,5 @@
---- - 2008-05-30 21:03:16.545065718 -0600
-+++ libacovea-5.1.1/libacovea/acovea.cpp 2008-05-30 20:55:48.000000000 -0600
+--- libacovea/acovea.cpp
++++ libacovea/acovea.cpp
@@ -86,7 +86,7 @@
// randomize settings of this option
void option::randomize()