summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-27 07:45:55 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-27 07:45:55 +0000
commit20aa274353cb7b891649298980c4c76809ae02fa (patch)
treeac56476d8621afce0f90b0fc0052892841c2d001 /app-benchmarks/i7z
parentRevert only change between .10 and .11.1, which completely broke the whole thing (diff)
downloadgentoo-2-20aa274353cb7b891649298980c4c76809ae02fa.tar.gz
gentoo-2-20aa274353cb7b891649298980c4c76809ae02fa.tar.bz2
gentoo-2-20aa274353cb7b891649298980c4c76809ae02fa.zip
Fix for gcc46
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/i7z')
-rw-r--r--app-benchmarks/i7z/ChangeLog6
-rw-r--r--app-benchmarks/i7z/files/0.26-gcc46.patch19
-rw-r--r--app-benchmarks/i7z/i7z-0.26.ebuild6
3 files changed, 28 insertions, 3 deletions
diff --git a/app-benchmarks/i7z/ChangeLog b/app-benchmarks/i7z/ChangeLog
index 412c32582d43..9d00f59cb0e1 100644
--- a/app-benchmarks/i7z/ChangeLog
+++ b/app-benchmarks/i7z/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-benchmarks/i7z
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/i7z/ChangeLog,v 1.2 2011/02/08 17:55:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/i7z/ChangeLog,v 1.3 2011/04/27 07:45:55 jlec Exp $
+
+ 27 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/0.26-gcc46.patch,
+ i7z-0.26.ebuild:
+ Fix for gcc46
08 Feb 2011; Justin Lecher <jlec@gentoo.org> i7z-0.26.ebuild:
Do not install outside EPREFIX
diff --git a/app-benchmarks/i7z/files/0.26-gcc46.patch b/app-benchmarks/i7z/files/0.26-gcc46.patch
new file mode 100644
index 000000000000..08ad216566b4
--- /dev/null
+++ b/app-benchmarks/i7z/files/0.26-gcc46.patch
@@ -0,0 +1,19 @@
+--- /tmp/GUI_i7z-50.cpp
++++ i7z/GUI/GUI_i7z.cpp
+@@ -48,10 +48,14 @@
+ void Construct_Socket_Information_in_GUI(unsigned int *numCPUs) {
+ socket_0.max_cpu=0;
+ socket_0.socket_num=0;
+- socket_0.processor_num={-1,-1,-1,-1,-1,-1,-1,-1};
++ int i;
++ for(i=0;i < 8; i++)
++ socket_0.processor_num[i]=-1;
+ socket_1.max_cpu=0;
+ socket_1.socket_num=1;
+- socket_1.processor_num={-1,-1,-1,-1,-1,-1,-1,-1};
++
++ for(i=0;i < 8; i++)
++ socket_1.processor_num[i]=-1;
+
+ construct_CPU_Heirarchy_info(&chi);
+ construct_sibling_list(&chi);
diff --git a/app-benchmarks/i7z/i7z-0.26.ebuild b/app-benchmarks/i7z/i7z-0.26.ebuild
index 2bc38f87496e..08ffe3305de4 100644
--- a/app-benchmarks/i7z/i7z-0.26.ebuild
+++ b/app-benchmarks/i7z/i7z-0.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/i7z/i7z-0.26.ebuild,v 1.2 2011/02/08 17:55:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/i7z/i7z-0.26.ebuild,v 1.3 2011/04/27 07:45:55 jlec Exp $
EAPI="3"
@@ -21,7 +21,9 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+ epatch \
+ "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${PV}-gcc46.patch
tc-export CC
}