summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-05-18 10:03:39 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-05-18 10:03:39 +0000
commit9dbd66d19bb80e8b0071665cc9da43ca4cec6dd6 (patch)
treed5b16eb8f840ffa275d62aea40f3c27b36c0daf5 /app-benchmarks/ltp
parentStable for amd64 wrt bug #469728 (diff)
downloadgentoo-2-9dbd66d19bb80e8b0071665cc9da43ca4cec6dd6.tar.gz
gentoo-2-9dbd66d19bb80e8b0071665cc9da43ca4cec6dd6.tar.bz2
gentoo-2-9dbd66d19bb80e8b0071665cc9da43ca4cec6dd6.zip
Version bump
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-benchmarks/ltp')
-rw-r--r--app-benchmarks/ltp/ChangeLog7
-rw-r--r--app-benchmarks/ltp/ltp-20130503.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/app-benchmarks/ltp/ChangeLog b/app-benchmarks/ltp/ChangeLog
index 097cb16d09b7..7a168edda985 100644
--- a/app-benchmarks/ltp/ChangeLog
+++ b/app-benchmarks/ltp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/ltp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.22 2013/03/25 20:51:50 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.23 2013/05/18 10:03:39 hwoarang Exp $
+
+*ltp-20130503 (18 May 2013)
+
+ 18 May 2013; Markos Chandras <hwoarang@gentoo.org> +ltp-20130503.ebuild:
+ Version bump
*ltp-20130109 (25 Mar 2013)
diff --git a/app-benchmarks/ltp/ltp-20130503.ebuild b/app-benchmarks/ltp/ltp-20130503.ebuild
new file mode 100644
index 000000000000..75272054dbb7
--- /dev/null
+++ b/app-benchmarks/ltp/ltp-20130503.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20130503.ebuild,v 1.1 2013/05/18 10:03:39 hwoarang Exp $
+
+EAPI="4"
+
+inherit autotools eutils readme.gentoo
+
+MY_PN="${PN}-full"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A testsuite for the linux kernel"
+HOMEPAGE="http://ltp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ltp/LTP%20Source/${P}/${MY_P}.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="expect perl pm open-posix python rt"
+
+DEPEND="expect? ( dev-tcltk/expect )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ # Don't create groups
+ export CREATE=0
+
+ DOC_CONTENTS="LTP requires root access to run the tests.
+ The LTP root directory is located in /opt/${PN}.
+ For more information please read the ltp-howto located in
+ /usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ # regenerate
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # FIXME: improve me
+ local myconf=
+ use open-posix && myconf+="--with open-posix-testsuite "
+ use pm && mytconf+="--with-power-management-testsuite "
+ use rt && myconf+="--with-realtime-testsuite "
+ use perl && myconf+="--with-perl "
+ use python && myconf+="--with-python "
+ use expect && myconf+="--with-expect "
+
+ # Better put it into /opt/${PN} as everything needs to
+ # be under the same directory..
+
+ econf --prefix=/opt/${PN} ${myconf}
+}
+
+src_compile() {
+ # Posix testsuite does not seem to build with -j>1
+ # Is this maintained anymore?
+ if use open-posix; then
+ export MAKEOPTS="-j1"
+ fi
+ emake
+}
+
+src_install() {
+ default
+ dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
+ # install docs
+ dodoc doc/MaintNotes
+ for txt in doc/*.txt; do
+ dodoc ${txt}
+ done
+ dodoc -r doc/examples doc/testcases
+ dohtml -r doc/automation-*.html
+ doman doc/man1/*.1
+ doman doc/man3/*.3
+ readme.gentoo_create_doc
+}