summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-06-13 18:55:44 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-06-13 18:55:44 +0000
commita6a2aec0f2353341b71e4289f22ef6e3028f0da5 (patch)
tree20b1ee3b74c6c38a0fdad4607186e570438d6ca1 /app-benchmarks
parentThe Module::Pluggable module is no longer part of core Perl and has been move... (diff)
downloadgentoo-2-a6a2aec0f2353341b71e4289f22ef6e3028f0da5.tar.gz
gentoo-2-a6a2aec0f2353341b71e4289f22ef6e3028f0da5.tar.bz2
gentoo-2-a6a2aec0f2353341b71e4289f22ef6e3028f0da5.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/ltp/ChangeLog7
-rw-r--r--app-benchmarks/ltp/ltp-20150420.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/app-benchmarks/ltp/ChangeLog b/app-benchmarks/ltp/ChangeLog
index ab1eba1bbd6f..585173defe37 100644
--- a/app-benchmarks/ltp/ChangeLog
+++ b/app-benchmarks/ltp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/ltp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.29 2015/06/09 09:06:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.30 2015/06/13 18:55:44 hwoarang Exp $
+
+*ltp-20150420 (13 Jun 2015)
+
+ 13 Jun 2015; Markos Chandras <hwoarang@gentoo.org> +ltp-20150420.ebuild:
+ version bump
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-benchmarks/ltp/ltp-20150420.ebuild b/app-benchmarks/ltp/ltp-20150420.ebuild
new file mode 100644
index 000000000000..c0968e8bcb39
--- /dev/null
+++ b/app-benchmarks/ltp/ltp-20150420.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20150420.ebuild,v 1.1 2015/06/13 18:55:44 hwoarang Exp $
+
+EAPI="5"
+
+inherit autotools eutils readme.gentoo
+
+MY_PN="${PN}-full"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A testsuite for the linux kernel"
+HOMEPAGE="http://ltp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ltp/LTP%20Source/${P}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="expect perl pm open-posix python rt"
+
+DEPEND="expect? ( dev-tcltk/expect )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ # Don't create groups
+ export CREATE=0
+
+ DOC_CONTENTS="LTP requires root access to run the tests.
+ The LTP root directory is located in /opt/${PN}.
+ For more information please read the ltp-howto located in
+ /usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ # regenerate
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # FIXME: improve me
+ local myconf=
+ use open-posix && myconf+="--with-open-posix-testsuite "
+ use pm && mytconf+="--with-power-management-testsuite "
+ use rt && myconf+="--with-realtime-testsuite "
+ use perl && myconf+="--with-perl "
+ use python && myconf+="--with-python "
+ use expect && myconf+="--with-expect "
+ # Prevent any kernel stuff for now as it leads to sandbox violations
+ myconf+="--without-modules --with-linux-dir=/dev/null"
+
+ # Better put it into /opt/${PN} as everything needs to
+ # be under the same directory..
+
+ econf --prefix=/opt/${PN} ${myconf}
+}
+
+src_compile() {
+ # Posix testsuite does not seem to build with -j>1
+ # Is this maintained anymore?
+ if use open-posix; then
+ export MAKEOPTS="-j1"
+ fi
+ emake
+}
+
+src_install() {
+ default
+ dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
+ # install docs
+ dodoc doc/MaintNotes
+ for txt in doc/*.txt; do
+ dodoc ${txt}
+ done
+ dodoc -r doc/testcases
+ dohtml -r doc/automation-*.html
+ doman doc/man1/*.1
+ doman doc/man3/*.3
+ readme.gentoo_create_doc
+}