summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-26 19:51:34 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-26 19:51:34 +0000
commit128533928fc8e7367f43ba4709f689ff3e5a986d (patch)
tree9ccda9e8f9a2a7ffa7be2d12749f3960560292f5 /app-cdr/burn-cd
parentStable for amd64, wrt bug #533054 (diff)
downloadgentoo-2-128533928fc8e7367f43ba4709f689ff3e5a986d.tar.gz
gentoo-2-128533928fc8e7367f43ba4709f689ff3e5a986d.tar.bz2
gentoo-2-128533928fc8e7367f43ba4709f689ff3e5a986d.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-cdr/burn-cd')
-rw-r--r--app-cdr/burn-cd/ChangeLog10
-rw-r--r--app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild32
2 files changed, 39 insertions, 3 deletions
diff --git a/app-cdr/burn-cd/ChangeLog b/app-cdr/burn-cd/ChangeLog
index 2e717b1e10b6..041c1e5c5e03 100644
--- a/app-cdr/burn-cd/ChangeLog
+++ b/app-cdr/burn-cd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-cdr/burn-cd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/burn-cd/ChangeLog,v 1.3 2009/11/24 14:55:12 beandog Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/burn-cd/ChangeLog,v 1.4 2014/12/26 19:51:34 mgorny Exp $
+
+*burn-cd-1.8.0-r1 (26 Dec 2014)
+
+ 26 Dec 2014; Michał Górny <mgorny@gentoo.org> +burn-cd-1.8.0-r1.ebuild:
+ Convert to python-single-r1.
*burn-cd-1.8.0 (24 Nov 2009)
@@ -14,4 +19,3 @@
06 Jun 2008; Samuli Suominen <drac@gentoo.org> +burn-cd-1.7.4.ebuild:
Initial commit for bug 204841. Ebuild by Alexander Glyzov.
-
diff --git a/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild b/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..bdafc27c6930
--- /dev/null
+++ b/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/burn-cd/burn-cd-1.8.0-r1.ebuild,v 1.1 2014/12/26 19:51:34 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Smart console frontend for virtual/cdrtools and dvd+rw-tools"
+HOMEPAGE="http://burn-cd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/cdrtools
+ app-cdr/dvd+rw-tools"
+DEPEND=""
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}
+
+src_install() {
+ python_fix_shebang ${P}
+ newbin ${P} ${PN}
+}