summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-12-13 14:04:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-12-13 14:04:17 +0000
commit5fc1aae5169b0b01cf033966137ab615b15f188e (patch)
treeed987ce4a1132daabeaaa07367579ddcfe0a0c47 /app-cdr/k3b
parentVersion bump #348147 by Francisco Javier. (diff)
downloadgentoo-2-5fc1aae5169b0b01cf033966137ab615b15f188e.tar.gz
gentoo-2-5fc1aae5169b0b01cf033966137ab615b15f188e.tar.bz2
gentoo-2-5fc1aae5169b0b01cf033966137ab615b15f188e.zip
Revision bump to fix crashing when using qt-4.7
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr/k3b')
-rw-r--r--app-cdr/k3b/ChangeLog8
-rw-r--r--app-cdr/k3b/files/2.0.1-fix-crash-with-qt-4.7.0.patch37
-rw-r--r--app-cdr/k3b/k3b-2.0.1-r1.ebuild112
3 files changed, 156 insertions, 1 deletions
diff --git a/app-cdr/k3b/ChangeLog b/app-cdr/k3b/ChangeLog
index 5c0e5fb962c4..370034fcba54 100644
--- a/app-cdr/k3b/ChangeLog
+++ b/app-cdr/k3b/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/k3b
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.255 2010/10/06 16:27:07 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.256 2010/12/13 14:04:16 scarabeus Exp $
+
+*k3b-2.0.1-r1 (13 Dec 2010)
+
+ 13 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org> +k3b-2.0.1-r1.ebuild,
+ +files/2.0.1-fix-crash-with-qt-4.7.0.patch:
+ Revision bump to fix crashing when using qt-4.7
06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org> k3b-2.0.1.ebuild:
A bit more cleanup, whitespaces
diff --git a/app-cdr/k3b/files/2.0.1-fix-crash-with-qt-4.7.0.patch b/app-cdr/k3b/files/2.0.1-fix-crash-with-qt-4.7.0.patch
new file mode 100644
index 000000000000..a99b5c639cae
--- /dev/null
+++ b/app-cdr/k3b/files/2.0.1-fix-crash-with-qt-4.7.0.patch
@@ -0,0 +1,37 @@
+Index: src/option/k3bpluginoptiontab.cpp
+===================================================================
+--- src/option/k3bpluginoptiontab.cpp (revision 1168967)
++++ src/option/k3bpluginoptiontab.cpp (working copy)
+@@ -43,12 +43,28 @@
+ layout->addWidget( label );
+ layout->addWidget( pluginSelector );
+
++ // find all categories
++ QHash<QString, QString> categoryNames;
++
+ foreach( K3b::Plugin* plugin, k3bcore->pluginManager()->plugins() ) {
+- kDebug() << "Adding plugin" << plugin->pluginInfo().name();
+- pluginSelector->addPlugins( QList<KPluginInfo>() << plugin->pluginInfo(),
++ categoryNames[ plugin->category() ] = plugin->categoryName();
++ }
++
++ // add all plugins in each category
++ foreach( const QString &category, categoryNames.keys() ) {
++ QList<KPluginInfo> plugins;
++
++ foreach( K3b::Plugin* plugin, k3bcore->pluginManager()->plugins() ) {
++ if ( plugin->category() == category ) {
++ plugins << plugin->pluginInfo();
++ kDebug() << "Adding plugin" << plugin->pluginInfo().name();
++ }
++ }
++ pluginSelector->addPlugins( plugins,
+ KPluginSelector::ReadConfigFile,
+- plugin->categoryName(),
+- plugin->category() );
++ categoryNames[ category ],
++ category
++ );
+ }
+ }
+
diff --git a/app-cdr/k3b/k3b-2.0.1-r1.ebuild b/app-cdr/k3b/k3b-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..cbe301197fa8
--- /dev/null
+++ b/app-cdr/k3b/k3b-2.0.1-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-2.0.1-r1.ebuild,v 1.1 2010/12/13 14:04:16 scarabeus Exp $
+
+EAPI=3
+
+CMAKE_MIN_VERSION=2.8.0
+MULTIMEDIA_REQUIRED=always
+WEBKIT_REQUIRED=always
+KMNAME="extragear/multimedia"
+
+# Translations are only in the tarballs, not in the svn repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="ast be bg ca ca@valencia cs csb da de el en_GB eo es et eu fi fr ga
+ gl he hi hne hr hu is it ja km ko ku lt mai nb nds nl nn oc pa pl pt pt_BR ro ru
+ se sk sl sv th tr uk zh_CN zh_TW"
+
+ SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.bz2"
+
+ DOCS=( FAQ PERMISSIONS README RELEASE_HOWTO )
+
+ S=${WORKDIR}/${P/_*}
+else
+ DOCS=( FAQ.txt PERMISSIONS.txt README.txt )
+fi
+
+inherit kde4-base
+
+DESCRIPTION="The CD/DVD Kreator for KDE"
+HOMEPAGE="http://www.k3b.org/"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug dvd emovix encode ffmpeg flac mad lame musepack musicbrainz sndfile sox taglib vcd vorbis +wav"
+
+DEPEND="
+ $(add_kdebase_dep libkcddb)
+ media-libs/libsamplerate
+ dvd? ( media-libs/libdvdread )
+ ffmpeg? ( >=media-video/ffmpeg-0.5 )
+ flac? ( >=media-libs/flac-1.2[cxx] )
+ encode? ( lame? ( media-sound/lame ) )
+ mad? ( media-libs/libmad )
+ musepack? ( >=media-sound/musepack-tools-444 )
+ musicbrainz? ( media-libs/musicbrainz:1 )
+ sndfile? ( media-libs/libsndfile )
+ taglib? ( >=media-libs/taglib-1.5 )
+ vorbis? ( media-libs/libvorbis )
+"
+RDEPEND="${DEPEND}
+ app-cdr/cdrdao
+ media-sound/cdparanoia
+ sys-apps/hal
+ virtual/cdrtools
+ dvd? (
+ >=app-cdr/dvd+rw-tools-7
+ encode? ( media-video/transcode[dvd] )
+ )
+ emovix? ( media-video/emovix )
+ encode? ( sox? ( media-sound/sox ) )
+ vcd? ( media-video/vcdimager )
+"
+
+DOCS+=( ChangeLog )
+
+PATCHES=( "${FILESDIR}/${PV}-fix-crash-with-qt-4.7.0.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ -DK3B_BUILD_K3BSETUP=OFF
+ $(cmake-utils_use debug K3B_DEBUG)
+ $(cmake-utils_use musicbrainz K3B_ENABLE_MUSICBRAINZ)
+ $(cmake-utils_use dvd K3B_ENABLE_DVD_RIPPING)
+ $(cmake-utils_use taglib K3B_ENABLE_TAGLIB)
+ -DK3B_BUILD_API_DOCS=OFF
+ $(cmake-utils_use ffmpeg K3B_BUILD_FFMPEG_DECODER_PLUGIN)
+ $(cmake-utils_use vorbis K3B_BUILD_OGGVORBIS_DECODER_PLUGIN)
+ $(cmake-utils_use mad K3B_BUILD_MAD_DECODER_PLUGIN)
+ $(cmake-utils_use musepack K3B_BUILD_MUSE_DECODER_PLUGIN)
+ $(cmake-utils_use flac K3B_BUILD_FLAC_DECODER_PLUGIN)
+ $(cmake-utils_use sndfile K3B_BUILD_SNDFILE_DECODER_PLUGIN)
+ $(cmake-utils_use wav K3B_BUILD_WAVE_DECODER_PLUGIN)
+ $(cmake-utils_use encode K3B_BUILD_EXTERNAL_ENCODER_PLUGIN)
+ )
+
+ if use encode; then
+ mycmakeargs+=(
+ $(cmake-utils_use vorbis K3B_BUILD_OGGVORBIS_ENCODER_PLUGIN)
+ $(cmake-utils_use lame K3B_BUILD_LAME_ENCODER_PLUGIN)
+ $(cmake-utils_use sox K3B_BUILD_SOX_ENCODER_PLUGIN)
+ )
+ fi
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ echo
+ elog "We don't install k3bsetup anymore because Gentoo doesn't need it."
+ elog "If you get warnings on start-up, uncheck the \"Check system"
+ elog "configuration\" option in the \"Misc\" settings window."
+ echo
+
+ local group=cdrom
+ use kernel_linux || group=operator
+ elog "Make sure you have proper read/write permissions on the cdrom device(s)."
+ elog "Usually, it is sufficient to be in the ${group} group."
+ echo
+}