summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-18 20:44:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-18 20:44:17 +0000
commit013f1003a0b41d1990210561cf20620ec05adf57 (patch)
tree2167b27764e2c6540a200c0c32ac7c36aae5efbd /app-cdr
parentBlocking the upgrade to net-fs/samba-3.0.27 due to regression (bug #199450) (diff)
downloadgentoo-2-013f1003a0b41d1990210561cf20620ec05adf57.tar.gz
gentoo-2-013f1003a0b41d1990210561cf20620ec05adf57.tar.bz2
gentoo-2-013f1003a0b41d1990210561cf20620ec05adf57.zip
add a check for flac cxx use flag, FLAC++ is needed here
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/k3b/ChangeLog7
-rw-r--r--app-cdr/k3b/k3b-0.12.17.ebuild8
-rw-r--r--app-cdr/k3b/k3b-1.0.1-r1.ebuild8
-rw-r--r--app-cdr/k3b/k3b-1.0.1.ebuild8
-rw-r--r--app-cdr/k3b/k3b-1.0.2.ebuild8
-rw-r--r--app-cdr/k3b/k3b-1.0.3.ebuild8
-rw-r--r--app-cdr/k3b/k3b-1.0.4.ebuild8
-rw-r--r--app-cdr/k3b/k3b-1.0.ebuild8
8 files changed, 55 insertions, 8 deletions
diff --git a/app-cdr/k3b/ChangeLog b/app-cdr/k3b/ChangeLog
index bb0d1b29fc07..2d330c3916a1 100644
--- a/app-cdr/k3b/ChangeLog
+++ b/app-cdr/k3b/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-cdr/k3b
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.198 2007/11/06 19:34:42 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.199 2007/11/18 20:44:17 aballier Exp $
+
+ 18 Nov 2007; Alexis Ballier <aballier@gentoo.org> k3b-0.12.17.ebuild,
+ k3b-1.0.ebuild, k3b-1.0.1.ebuild, k3b-1.0.1-r1.ebuild, k3b-1.0.2.ebuild,
+ k3b-1.0.3.ebuild, k3b-1.0.4.ebuild:
+ add a check for flac cxx use flag, FLAC++ is needed here
06 Nov 2007; Markus Rothe <corsair@gentoo.org> k3b-1.0.4.ebuild:
Added ~ppc64; bug #197779
diff --git a/app-cdr/k3b/k3b-0.12.17.ebuild b/app-cdr/k3b/k3b-0.12.17.ebuild
index 878ac2adc67e..f1d7c116093d 100644
--- a/app-cdr/k3b/k3b-0.12.17.ebuild
+++ b/app-cdr/k3b/k3b-0.12.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.17.ebuild,v 1.13 2007/08/02 04:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.17.ebuild,v 1.14 2007/11/18 20:44:17 aballier Exp $
inherit kde eutils
@@ -62,6 +62,12 @@ pkg_setup() {
die "rebuild sys-apps/dbus with the qt3 useflag"
fi
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
kde_pkg_setup
}
diff --git a/app-cdr/k3b/k3b-1.0.1-r1.ebuild b/app-cdr/k3b/k3b-1.0.1-r1.ebuild
index 457020fe8161..44334814b800 100644
--- a/app-cdr/k3b/k3b-1.0.1-r1.ebuild
+++ b/app-cdr/k3b/k3b-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.1-r1.ebuild,v 1.3 2007/08/02 04:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.1-r1.ebuild,v 1.4 2007/11/18 20:44:17 aballier Exp $
inherit kde eutils
@@ -74,6 +74,12 @@ pkg_setup() {
die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
fi
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
kde_pkg_setup
diff --git a/app-cdr/k3b/k3b-1.0.1.ebuild b/app-cdr/k3b/k3b-1.0.1.ebuild
index 7063a7465037..410cbfaebd36 100644
--- a/app-cdr/k3b/k3b-1.0.1.ebuild
+++ b/app-cdr/k3b/k3b-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.1.ebuild,v 1.3 2007/08/02 04:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.1.ebuild,v 1.4 2007/11/18 20:44:17 aballier Exp $
inherit kde eutils
@@ -74,6 +74,12 @@ pkg_setup() {
die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
fi
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
kde_pkg_setup
diff --git a/app-cdr/k3b/k3b-1.0.2.ebuild b/app-cdr/k3b/k3b-1.0.2.ebuild
index 537794a120fc..689cdac17dac 100644
--- a/app-cdr/k3b/k3b-1.0.2.ebuild
+++ b/app-cdr/k3b/k3b-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.2.ebuild,v 1.3 2007/08/02 04:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.2.ebuild,v 1.4 2007/11/18 20:44:17 aballier Exp $
inherit kde eutils
@@ -72,6 +72,12 @@ pkg_setup() {
die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
fi
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
kde_pkg_setup
diff --git a/app-cdr/k3b/k3b-1.0.3.ebuild b/app-cdr/k3b/k3b-1.0.3.ebuild
index 987501424e52..be7c5a48d4a9 100644
--- a/app-cdr/k3b/k3b-1.0.3.ebuild
+++ b/app-cdr/k3b/k3b-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.3.ebuild,v 1.3 2007/08/22 12:07:13 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.3.ebuild,v 1.4 2007/11/18 20:44:17 aballier Exp $
inherit kde eutils
@@ -72,6 +72,12 @@ pkg_setup() {
die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
fi
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
kde_pkg_setup
diff --git a/app-cdr/k3b/k3b-1.0.4.ebuild b/app-cdr/k3b/k3b-1.0.4.ebuild
index f1489e08c599..6ae19d340b41 100644
--- a/app-cdr/k3b/k3b-1.0.4.ebuild
+++ b/app-cdr/k3b/k3b-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.4.ebuild,v 1.2 2007/11/06 19:34:42 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.4.ebuild,v 1.3 2007/11/18 20:44:17 aballier Exp $
inherit kde eutils
@@ -71,6 +71,12 @@ pkg_setup() {
die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
fi
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
kde_pkg_setup
}
diff --git a/app-cdr/k3b/k3b-1.0.ebuild b/app-cdr/k3b/k3b-1.0.ebuild
index 3c0bd0f81486..027c451bfec5 100644
--- a/app-cdr/k3b/k3b-1.0.ebuild
+++ b/app-cdr/k3b/k3b-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.ebuild,v 1.7 2007/08/02 04:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.ebuild,v 1.8 2007/11/18 20:44:17 aballier Exp $
inherit kde eutils
@@ -76,6 +76,12 @@ pkg_setup() {
die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
fi
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
kde_pkg_setup