summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-16 14:23:23 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-16 14:23:23 +0000
commit6b4e20983eb8b39b5270a2a51ff1a8ae81683ad8 (patch)
tree2b139aa0c28a3b1a967a05ad342e35edb4a11e54 /app-crypt/gcr
parentCleanup due retirement, #95685 (diff)
downloadgentoo-2-6b4e20983eb8b39b5270a2a51ff1a8ae81683ad8.tar.gz
gentoo-2-6b4e20983eb8b39b5270a2a51ff1a8ae81683ad8.tar.bz2
gentoo-2-6b4e20983eb8b39b5270a2a51ff1a8ae81683ad8.zip
Version bump for Gnome 3.6.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-crypt/gcr')
-rw-r--r--app-crypt/gcr/ChangeLog5
-rw-r--r--app-crypt/gcr/gcr-3.6.2.ebuild27
2 files changed, 23 insertions, 9 deletions
diff --git a/app-crypt/gcr/ChangeLog b/app-crypt/gcr/ChangeLog
index f7d45d6de4db..934e16e2207c 100644
--- a/app-crypt/gcr/ChangeLog
+++ b/app-crypt/gcr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/gcr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.10 2012/12/16 09:47:06 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.11 2012/12/16 14:23:23 eva Exp $
+
+ 16 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org> gcr-3.6.2.ebuild:
+ Version bump for Gnome 3.6.
16 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org> gcr-3.6.2.ebuild:
Use a better subslot.
diff --git a/app-crypt/gcr/gcr-3.6.2.ebuild b/app-crypt/gcr/gcr-3.6.2.ebuild
index 78eb3c0abbed..ab5582dfe169 100644
--- a/app-crypt/gcr/gcr-3.6.2.ebuild
+++ b/app-crypt/gcr/gcr-3.6.2.ebuild
@@ -1,27 +1,35 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.6.2.ebuild,v 1.2 2012/12/16 09:47:06 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.6.2.ebuild,v 1.3 2012/12/16 14:23:23 eva Exp $
-EAPI="5"
+EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
inherit gnome2 virtualx
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2+ LGPL-2+"
-SLOT="0/1" # subslot = suffix of libgcr-3
+SLOT="0"
IUSE="debug +introspection"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+if [[ ${PV} = 9999 ]]; then
+ IUSE="${IUSE} doc"
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+fi
COMMON_DEPEND="
>=app-crypt/gnupg-2
>=app-crypt/p11-kit-0.6
>=dev-libs/glib-2.32:2
- >=dev-libs/libgcrypt-1.2.2:=
- >=dev-libs/libtasn1-1:=
+ >=dev-libs/libgcrypt-1.2.2
+ >=dev-libs/libtasn1-1
>=sys-apps/dbus-1.0
>=x11-libs/gtk+-3.0:3
introspection? ( >=dev-libs/gobject-introspection-1.29 )
@@ -31,7 +39,6 @@ RDEPEND="${COMMON_DEPEND}
"
# gcr was part of gnome-keyring until 3.3
DEPEND="${COMMON_DEPEND}
- dev-libs/gobject-introspection-common
dev-util/gdbus-codegen
>=dev-util/gtk-doc-am-1.9
>=dev-util/intltool-0.35
@@ -50,10 +57,14 @@ src_prepare() {
DOCS="AUTHORS ChangeLog HACKING NEWS README"
G2CONF="${G2CONF}
$(use_enable introspection)
- $(usex debug --enable-debug=yes --enable-debug=default)
+ --enable-debug=default
--disable-update-icon-cache
--disable-update-mime"
+ if use debug; then
+ G2CONF="${G2CONF} --enable-debug=yes"
+ fi
+
# Disable stupid flag changes
sed -e 's/CFLAGS="$CFLAGS -g"//' \
-e 's/CFLAGS="$CFLAGS -O0"//' \